Jump to content
Sign in to follow this  
jenske

Problems with Custom CSS Styling on Mobile/Ipad

Recommended Posts

jenske

Hi. I have the same theme on all 5 of my sites and styled them quite the same (same plugins, colors etc).

 

I entered my my custom css styling in my childtheme. Now it seems to work only on Google Chrome on my Desktop.

If I open my site in IE on the desktop, Google Chrome or Safari on my Ipad and Iphone it goes crazy.

 

Some of the css styling works but the header + logo size, sidebar-background, tabs (widget) - color and spacing, optin bars spill over widgets and fixed navbar - font color etc.

 

It varies from site to site but that is the basic problems. Is there a way to fix this?

 

Website URL: innerpeke.com; starvingpeke.com; beautyandthepeke.com; memyselfandpeke.com; viciouspekes.com
Framework Version: most recent
WordPress Version: most recent
Server/Host: iPage
 

Share this post


Link to post
Share on other sites
Rob

Hi,

 

I see your sites on Firefox on a Windows 7 machine without any problem.


Former PageLines Moderator, Food Expert and Raconteur

Share this post


Link to post
Share on other sites
jenske

Is example the tabs you see black or are they orange?

 

If black then the css does not work.

Share this post


Link to post
Share on other sites
Rob

The navbar and tab on the left are black.


Former PageLines Moderator, Food Expert and Raconteur

Share this post


Link to post
Share on other sites
Rob

Did you edit the following, for example:

#rum_sst_tab {
    background-color: rgb(0, 0, 0);
    border-bottom-left-radius: 10px;
    border-bottom-right-radius: 10px;
    border-style: solid;
    border-width: 0;
    color: rgb(255, 255, 255);
    font-family: Arial,sans-serif;
    top: 350px;
}

Former PageLines Moderator, Food Expert and Raconteur

Share this post


Link to post
Share on other sites
Rob

There is an option for the NavBar to be orange in Dashboard > PageLines > Site Options > NavBar


Former PageLines Moderator, Food Expert and Raconteur

Share this post


Link to post
Share on other sites
jenske

I have now tried everything. I have one site that work and compared it to the others - disabled all plugins etc that was not the same.

I cannot understand why it doesn't work. I changed the font color and size on the navbar, I want the navbar black. I know that some

of the css styling work on the mobile and ipad example the black borders around the sidebars. So why don't the other styling work?

Share this post


Link to post
Share on other sites
James B

Hi there,

 

I see your site like this - http://screencast.com/t/t9WTfAdZn

 

You have a cache plugin installed on your site, these can mask the caches on your site. Dump the cache file inside the plugin settings then disable the plugin, if you just disable without clearing the cache it won't work and you'll still see a previously saved version of your site.

 

If that doesn't work I would say backtrack through your css, adding a couple of lines at a time to see if the changes take effect up until a point and then change, it could be something in the code affecting it.


Kindly search the forum and read the documentation before posting. It will help you resolve many issues.

For CSS help be sure to check out W3Schools first and be sure to download FireBug for FireFox for troubleshooting.

James B

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this  

  • Similar Content

    • chamois_blanc
      By chamois_blanc+
      Hello,
      Shouldn't the image PL5 component be using the srcset/picture css directives to pick the correct size for an image? or it does already and I don't know how to use it? Thank you for any advice or enlightenment.
    • Dan Haddock
      By Dan Haddock
      Plugins Active and installed: 
      Akismet Anti-Spam
      Coming Soon Page & Maintenance Mode by SeedProd
      Contact Form 7
      Cookie Law Info
      DMS Professional Tools  
      Enhanced Media Library  
      Flamingo
      Google Analytics for WordPress by MonsterInsights
      Google XML Sitemap
      Jetpack by WordPress.com
      Legull 
      Loginizer   
      MailChimp for WordPress
      PageLines Updater    
      Schema App Structured Data 
      Sucuri Security - Auditing, Malware Scanner and Hardening
      Uber reCaptcha    
      Yoast SEO
      Wordpress Version: 4.8.1
      Pagelines Version: 2.2.4
       
      Good Evening/Afternoon or Morning, 
      I am running into a problem with CSS styling not applying inside of most browsers (Safari, Firefox) when I am logged in to wordpress, and all browsers that I have tested when I am logged off and the site has been made public (Chrome, Firefox and Safari).
      As a result, I have managed to identify the probable cause. It looks as though these browsers are refusing to render my sites compiled CSS file due to it being a HTTP URL rather than HTTPS.
      I have attempted to change this URL to HTTPS in my browser, however it brings back an ERROR: File not found page - https://www.shortfilmblog.com/wp-content/uploads/pagelines/compiled-css-core-1505847507.css
      What would you suggest in this regard? Would this be resolvable from your end?
      Happy to provide any further details required.
    • Borries
      By Borries+
      I know this is not an easy problem. Maybe there is a easy solution.
      I have tryed to uses the existing solution, that I have found in the forum
      I changed the colours of my nav (simple nav) and the hover effect (a. hover).
      I really tryed to highlight the active/used link in the nav but I cant figure it out.
      I want it to be black when active.
      Any help would be appreciated. Thanks.
      http://www.marcborries.de  nav link: "Sinn & Selbst" 
    • dwpoyner
      By dwpoyner+
      Not sure exactly what is causing the issue. For some reason, why you view my site on mobile, the menu does not show up. It will pop up, but it is black. You can check it out here: http://dev.caryfbc.org. I'm also attaching a screenshot where I shrunk my browser down. Any suggestions?

    • Michael Kummer
      By Michael Kummer+
      Hi guys,
      every since Chrome introduce scroll anchoring (see chrome://flags) blog posts on my page start scroll automatically as soon as the user scrolls down a bit. It is super annoying and I don't know exactly what triggers the incompatibility with Chrome's latest feature that is supposed to improve usability.
      Since I don't know what causes it (Pagelines, or a Plugin), I would like to disable the feature using a CSS override that Google describes as follow:
      "Scroll anchoring aims to be the default mode of behavior when launched, so that users benefit from it even on legacy content. A CSS property overflow-anchor can disable scroll anchoring in part or all of a webpage (opt out), or exclude portions of the DOM from the anchor node selection algorithm. This property supports the following values when applied to an element E:
      overflow-anchor: auto (the default value) declares that the DOM subtree rooted at E is eligible to participate in the anchor node selection algorithm for any scrolling box created by E or an ancestor of E. overflow-anchor: none declares that the DOM subtree rooted at E is not eligible to participate in the anchor node selection algorithm for any scrolling box created by E or an ancestor of E." Do you guys happen to know how to use that property with the ROOT element so it applies to the whole page?
      Thanks
      Michael 
×