Jump to content
Sourena

Issue with "pagelines-less"

Recommended Posts

Sourena    2
Sourena

I have two websites running Pagelines 2.4.4 as their theme (using a child theme). I also use "W3 Total Cache" and "Amazon S3" as my CDN service. The first website does not work properly when CDN is activated on "W3 Total Cache". The problem is that the LESS CSS is not uploaded to "Amazon S3" so the website misses the styles. The second website has the exact same settings but it has no problem.

 

Checking everything I noticed that the first website has a folder names "page lines" in the uploads folder (within "wp-content"). Inside this folder there are multiple compiled files of compiled CSS files. Also this line in the source code of my homepage refers to one of these compiled files:

<link rel='stylesheet' id='pagelines-less-css'  href='http://url.com/wp-content/uploads/pagelines/compiled-css-1372540484.css' type='text/css' media='all' />

In the second website the line is different:

<link rel='stylesheet' id='pagelines-less-css'  href='http://url2.com/?pageless=1_1372548999' type='text/css' media='all' />

There is no "page lines" folder created in the "uploads" folder in the second website and it has no problem.

 

Why these two websites have this difference and how can I fix that?

 


alefba.us

Web Development & Design for Right-to-Left languages

Share this post


Link to post
Share on other sites
Rob    547
Rob

Hi Sourena,

 

It seems W3 Total cache creates the uploads/pagelines folder to store the compiled CSS.  I use the came cache plugin, but with MaxCDN and have the same folder with the same type of content.

 

This could well be a permissions issue.  I'll have to wait for Simon to chime in on this as he's our genius about CDN.


Former PageLines Moderator, Food Expert and Raconteur

Share this post


Link to post
Share on other sites
Sourena    2
Sourena

Thanks.


alefba.us

Web Development & Design for Right-to-Left languages

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


  • Similar Content

    • GreyFoxWebDesign
      By GreyFoxWebDesign+
      Hi, could you let me know where the custom less/css is saved to - i.e. how I could access it directly via the server.
      I hid the Admin Bar by mistake and now can't save any changes to the Custom CSS as the Save Button is not available - so I need to find another way to access and edit the custom CSS.
      Thanks in advance
    • Audun MB
      By Audun MB+
      How do I get the LESS in a child theme to compile?
    • jeomiland
      By jeomiland+
      Just recently started using gtmetrix.com to evaluate websites to find out why my page load times seem slow. Here's a recent report: https://gtmetrix.com/reports/cassclayton.com/Q7n9gsfg
      As you can see in the Yslow section,
      Add Expires headers
      Make fewer HTTP requests
      Configure entity tags (ETags)
      all have failing marks. Along with the Configure entity tags (ETags) section, there are several DMS javascript files (and stuff from other plugins) that are being referenced. The Make fewer HTTP requests section says: "This page has 23 external Javascript scripts and 11 external stylesheets. Try combining them into one."
      Can someone please tell me how to address this?  I just signed up to cloudflare.com for a CDN account so trying that too. Anyone have experience with CDN and DMS development? Any issues or is it best to wait till after Live deployment to do that?
      Thanks guys.
    • dymond
      By dymond+
      I've been trying to upload a video to use as a video background, but the size was 12m, and the alotted max file size is 8m. I downloaded a couple of pugins that increase the size by creating php.ini files and all of that jazz, but to no avail. It would say (Max file size = 250mb) but after I uploaded I would get an "HTTP ERROR",
      Soooo I logged into my cpanel and saw that the php I was using was 4 version out of date. I upgraded my php to PHP 5.6 and now I get
      Fatal error: Out of memory (allocated 39583744) (tried to allocate 15 bytes) in /homepages/39/d200014696/htdocs/dymondentertainment.com/wp-content/themes/dms/dms/includes/less.plugin.php on line 848
      When I activiate another theme that is not pagleines, the site works fine.... but will no longer work with Pagelines DMS Version 2.2
       
      My site has no gone dark. What can I do?
    • gadeichhorn
      By gadeichhorn
      Hi All,
      anyone using the AWS plugin for S3 and cloud front?
      if you use normal WP content and add media the imag URL automatically adjusted to the optimized size i.e. 300x200, 1000x500 and so on.
      if you select media from PageLine DMS the image is always the original size and the site is super slow (images are 3Mb). I have to go and select the appropriate size from my S3 bucket per each link and that takes much longer to do.
      any idea how to make it work like the built in WP optimizer?
      cheers.
×