Jump to content
Sign in to follow this  
jbrouwer

ai1ec (timely calendar plugin) modal css problem

Recommended Posts

jbrouwer    5
jbrouwer

Hi,

 

On http://www.uitinbeeld.nl/uitagenda/ there are two buttons on the top right to add events. The calendar is the All in One Event Calendar from Timely. A modal popup window appears. However, somehting goes wrong with fading and opacity in Firefox, Chrome and Safari (in IE10 there are no problems). The problem is related to Pagelines. In Twenty Twelve the popup windows appear normaly. It's also not related to any other plugin as I tested with all othere plugins deactivated. 

 

Any idea how I can fix the css? 

 

Thanks!

 

Running Pagelines 2,4,4 and WP 3.5.2

Share this post


Link to post
Share on other sites
Rob    547
Rob

Hi,

 

I seem to recall several clients complaining about a compatibility issue with All In One Events Calendar, which turned out (I believe) to be a javascript or jQuery conflict of some kind.   Did you update the plugin?

 

http://www.pagelines.com/forum/topic/25354-fatal-error-after-all-in-one-event-calendar-update/

 

This may help though:  http://www.pagelines.com/forum/topic/25608-all-in-one-event-calender-css-problem/


Former PageLines Moderator, Food Expert and Raconteur

Share this post


Link to post
Share on other sites
jbrouwer    5
jbrouwer

Hi,

 

Both links are to different problems with the timely calendar. Both already solved.

 

The 'Cannot redeclare class lessc' was solved in Pagelines 2.4. 

The other link is to a problem with links in the calendar. Solved with some custom css.

 

Any other ideas? Pagelines also has (bootstrap) modals you can use. I expect it interferes with the modal of the timely plugin.

 

Thanks!

Share this post


Link to post
Share on other sites
Rob    547
Rob

If there's a browser-based CSS conflict between PageLines and the plugin, you can try using our Browser-Specific CSS plugin, to write some code for it, but I'd have no idea what CSS to use or even where to look. We'd recommend Firebug or Chrome's inspection tools to help you with this normally.

 

Unfortunately, this is really a customization of a third-party plugin.  I suspect you're correct that it's related to the modal, and probably because of the systems each use to generate modals.  This kind of customization calls for either a developer or, using a different plugin.   Keep in mind that our bootstrap code comes from Twitter, so if the All-in-One Calendar plugin doesn't use that, the key is going to be fixing the plugin, not PageLines or Twitter.

 

Have you reached out to Timely to show them the issue?


Former PageLines Moderator, Food Expert and Raconteur

Share this post


Link to post
Share on other sites
jbrouwer    5
jbrouwer

Hi,

 

Yes I contacted Timely, they are trying to solve it.

 

There are no problems with the plugin in twenty twelve, hence I would say the problem is also theme related. Further, Pagelines is using bootstrap for their product, any problem with bootstrap is Pagelines' responsibility. I am paying Pagelines, not bootstrap. The power of wordpress is the platform function and the availability of plugins. Any theme should therefor strive for compatability with as many well maintained plugins as possible. No customization asked, just compatibility.

Share this post


Link to post
Share on other sites
James B    436
James B

Hi there,

 

Unfortunately we're unable to be 100% compatible with all third party plugins, if there is a conflict with a plugin inside the framework then we'd advise you to go back to the plugin author. Unfortunately we're unable to tweak plugins to fit the framework, each plugin will use it's own code depending on the plugin author, not all of these will always meet Wordpress standards or guidelines and as you can appreciate there are thousands of third party plugins.

 

See if the plugin author can offer a work around or coding fix depending on the error presented. Otherwise you'll unfortunately need to find an alternative plugin which provides the same functions but doesn't conflict.


Kindly search the forum and read the documentation before posting. It will help you resolve many issues.

For CSS help be sure to check out W3Schools first and be sure to download FireBug for FireFox for troubleshooting.

James B

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this  

  • Similar Content

    • Michael Kummer
      By Michael Kummer+
      Hi guys,
      every since Chrome introduce scroll anchoring (see chrome://flags) blog posts on my page start scroll automatically as soon as the user scrolls down a bit. It is super annoying and I don't know exactly what triggers the incompatibility with Chrome's latest feature that is supposed to improve usability.
      Since I don't know what causes it (Pagelines, or a Plugin), I would like to disable the feature using a CSS override that Google describes as follow:
      "Scroll anchoring aims to be the default mode of behavior when launched, so that users benefit from it even on legacy content. A CSS property overflow-anchor can disable scroll anchoring in part or all of a webpage (opt out), or exclude portions of the DOM from the anchor node selection algorithm. This property supports the following values when applied to an element E:
      overflow-anchor: auto (the default value) declares that the DOM subtree rooted at E is eligible to participate in the anchor node selection algorithm for any scrolling box created by E or an ancestor of E. overflow-anchor: none declares that the DOM subtree rooted at E is not eligible to participate in the anchor node selection algorithm for any scrolling box created by E or an ancestor of E." Do you guys happen to know how to use that property with the ROOT element so it applies to the whole page?
      Thanks
      Michael 
    • wyo22ski
      By wyo22ski+
      Hello,
       
      I'm basically a designer and understand a little on how to change CSS, etc., so please excuse my ignorance...  I recently upgraded to the newest platform from the DMS and my old DMS theme no longer functions.  I'm trying to replace the image slider that my Horizon Photography Theme (Nick Haskins) had created.  The Impulse image slider seemed the closest to what I need, but there are problems.
      It seems the the Impulse section for sliding images defaults to the image width, no the height.  I can change the Impulse stage height and width, but this does nothing to the internal content.  For instance, if I change the height to 200 pixels, the image remains the full width and only shows a cropped section.  I would like the ability to change the Impulse height, and have the image height fit space. 
      I've put this custom CSS in, but again, this only controls the stage height of Impulse:
      .pl-sn-impulse .pl-impulse-cell .cell-wrap, .pl-impulse-container, .owl-stage-outer {
        width: 100%;
      }
       
      Any suggestions welcome.  Thanks 
    • Objectif-Mariage
      By Objectif-Mariage+
      Hello. 
      I have just realized that CSS (Less plugin) , is not working..... I have disable all plugins (except PL CUSTOM LESS and PL5) , and ... it's not working ... 
      It's not the first time. Usually I had trouble with a plugin name Autoptimize , but it's Desactivate now , all memory have been purge, and it's still not working! :-/ So it's not from this plugin. 
      NB : When I am logged on my website, if i go on the black wordpress dashboard bar, go on the PL icon, clic on </> LESS/CSS => then the page suddenly apply the CSS .... But As soon that i reload the page, nothing. I think the problem is that the plugin LESS/CSS does not load properly (if I can say that with my simples words).
      I order to keep the site "good looking" I have temporally copy/paste all my LESS code in a plugin : Script n Styles that apply the LESS/CSS code... but it's not a solution for long time.
      Can someone help me ? Did I do something wrong ? Is it an update ? 
       
      my website : https://www.wedding-photography-minneapolis.com
    • Jason
      By Jason+
      Feel free to delete this post if its not helpful or its just plain wrong.
       
      I though it might be useful to share how I customize the size of the builder. (reduce my eyestrain )
      1 - install stylerbot extension in chrome (stylerbot keeps this css every time you access the url)
       
      2- add this css to stylerbot for the site you are working on
      .CodeMirror {
          font-size: 14px;
          height: 600px;
      }
      .pl-workarea.pl-has-sidebar .pl-workarea-sidebar-container {
          right: 0px;
          width: 500px;
      }
      .pl-workarea.pl-has-sidebar .iframe-container {
          right: 500px ;
      }
       
      change sizes to suit.
       
      Cheers.
    • Jason
      By Jason+
      Hi.
      I can't seem to get the Teamwork section to accept custom css. I am trying to change the padding from 7em to 1em on the splash part
      I have tried
        .pl-sn-teamwork .pl-tw-splash {
          padding-top: 1em;
          padding-bottom: 1em;
        }
       
      This works in chrome inspect but when added to custom css nothing happens.
      I have also tried most of the classes I can see accoiated with this section but again nothng seems to happen.
      Any ideas?
×