Jump to content
Sign in to follow this  
jbrouwer

ai1ec (timely calendar plugin) modal css problem

Recommended Posts

jbrouwer

Hi,

 

On http://www.uitinbeeld.nl/uitagenda/ there are two buttons on the top right to add events. The calendar is the All in One Event Calendar from Timely. A modal popup window appears. However, somehting goes wrong with fading and opacity in Firefox, Chrome and Safari (in IE10 there are no problems). The problem is related to Pagelines. In Twenty Twelve the popup windows appear normaly. It's also not related to any other plugin as I tested with all othere plugins deactivated. 

 

Any idea how I can fix the css? 

 

Thanks!

 

Running Pagelines 2,4,4 and WP 3.5.2

Share this post


Link to post
Share on other sites
Rob

Hi,

 

I seem to recall several clients complaining about a compatibility issue with All In One Events Calendar, which turned out (I believe) to be a javascript or jQuery conflict of some kind.   Did you update the plugin?

 

http://www.pagelines.com/forum/topic/25354-fatal-error-after-all-in-one-event-calendar-update/

 

This may help though:  http://www.pagelines.com/forum/topic/25608-all-in-one-event-calender-css-problem/


Former PageLines Moderator, Food Expert and Raconteur

Share this post


Link to post
Share on other sites
jbrouwer

Hi,

 

Both links are to different problems with the timely calendar. Both already solved.

 

The 'Cannot redeclare class lessc' was solved in Pagelines 2.4. 

The other link is to a problem with links in the calendar. Solved with some custom css.

 

Any other ideas? Pagelines also has (bootstrap) modals you can use. I expect it interferes with the modal of the timely plugin.

 

Thanks!

Share this post


Link to post
Share on other sites
Rob

If there's a browser-based CSS conflict between PageLines and the plugin, you can try using our Browser-Specific CSS plugin, to write some code for it, but I'd have no idea what CSS to use or even where to look. We'd recommend Firebug or Chrome's inspection tools to help you with this normally.

 

Unfortunately, this is really a customization of a third-party plugin.  I suspect you're correct that it's related to the modal, and probably because of the systems each use to generate modals.  This kind of customization calls for either a developer or, using a different plugin.   Keep in mind that our bootstrap code comes from Twitter, so if the All-in-One Calendar plugin doesn't use that, the key is going to be fixing the plugin, not PageLines or Twitter.

 

Have you reached out to Timely to show them the issue?


Former PageLines Moderator, Food Expert and Raconteur

Share this post


Link to post
Share on other sites
jbrouwer

Hi,

 

Yes I contacted Timely, they are trying to solve it.

 

There are no problems with the plugin in twenty twelve, hence I would say the problem is also theme related. Further, Pagelines is using bootstrap for their product, any problem with bootstrap is Pagelines' responsibility. I am paying Pagelines, not bootstrap. The power of wordpress is the platform function and the availability of plugins. Any theme should therefor strive for compatability with as many well maintained plugins as possible. No customization asked, just compatibility.

Share this post


Link to post
Share on other sites
James B

Hi there,

 

Unfortunately we're unable to be 100% compatible with all third party plugins, if there is a conflict with a plugin inside the framework then we'd advise you to go back to the plugin author. Unfortunately we're unable to tweak plugins to fit the framework, each plugin will use it's own code depending on the plugin author, not all of these will always meet Wordpress standards or guidelines and as you can appreciate there are thousands of third party plugins.

 

See if the plugin author can offer a work around or coding fix depending on the error presented. Otherwise you'll unfortunately need to find an alternative plugin which provides the same functions but doesn't conflict.


Kindly search the forum and read the documentation before posting. It will help you resolve many issues.

For CSS help be sure to check out W3Schools first and be sure to download FireBug for FireFox for troubleshooting.

James B

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this  

  • Similar Content

    • glyph.marketing
      By glyph.marketing+
      Hello, I am having a problem similar to that experienced by Michael Kummer here. We have pages that show this automatic scrolling issue (examples here and here) and it is sufficiently annoying that we have seen customers bounce while trying to convert. Strangely, it only happens at specific resolutions, so it can be difficult to reproduce. In general we can only consistently reproduce it on a 4k resolution with a browser width between 1517 and 1536px. 
      Thanks to Michael Kummer's help we were able to set the overflow-anchor property to none in the entire body, which fixed the issue as far as we can tell, but also obviously disabled scroll anchoring for the whole site. I tried applying it to the specific element that looked like it was being reloaded, which was the PL Meganav extension, but that was unsuccessful. 
      Can anyone help us figure out which element or ID we can apply this property to, so that we can fix the scrolling issue but not disable scroll anchoring for the entire site?
      Thank you - 
      Glyph Language Services
    • chamois_blanc
      By chamois_blanc+
      Hello,
      Shouldn't the image PL5 component be using the srcset/picture css directives to pick the correct size for an image? or it does already and I don't know how to use it? Thank you for any advice or enlightenment.
    • Dan Haddock
      By Dan Haddock
      Plugins Active and installed: 
      Akismet Anti-Spam
      Coming Soon Page & Maintenance Mode by SeedProd
      Contact Form 7
      Cookie Law Info
      DMS Professional Tools  
      Enhanced Media Library  
      Flamingo
      Google Analytics for WordPress by MonsterInsights
      Google XML Sitemap
      Jetpack by WordPress.com
      Legull 
      Loginizer   
      MailChimp for WordPress
      PageLines Updater    
      Schema App Structured Data 
      Sucuri Security - Auditing, Malware Scanner and Hardening
      Uber reCaptcha    
      Yoast SEO
      Wordpress Version: 4.8.1
      Pagelines Version: 2.2.4
       
      Good Evening/Afternoon or Morning, 
      I am running into a problem with CSS styling not applying inside of most browsers (Safari, Firefox) when I am logged in to wordpress, and all browsers that I have tested when I am logged off and the site has been made public (Chrome, Firefox and Safari).
      As a result, I have managed to identify the probable cause. It looks as though these browsers are refusing to render my sites compiled CSS file due to it being a HTTP URL rather than HTTPS.
      I have attempted to change this URL to HTTPS in my browser, however it brings back an ERROR: File not found page - https://www.shortfilmblog.com/wp-content/uploads/pagelines/compiled-css-core-1505847507.css
      What would you suggest in this regard? Would this be resolvable from your end?
      Happy to provide any further details required.
    • Borries
      By Borries+
      I know this is not an easy problem. Maybe there is a easy solution.
      I have tryed to uses the existing solution, that I have found in the forum
      I changed the colours of my nav (simple nav) and the hover effect (a. hover).
      I really tryed to highlight the active/used link in the nav but I cant figure it out.
      I want it to be black when active.
      Any help would be appreciated. Thanks.
      http://www.marcborries.de  nav link: "Sinn & Selbst" 
    • Michael Kummer
      By Michael Kummer+
      Hi guys,
      every since Chrome introduce scroll anchoring (see chrome://flags) blog posts on my page start scroll automatically as soon as the user scrolls down a bit. It is super annoying and I don't know exactly what triggers the incompatibility with Chrome's latest feature that is supposed to improve usability.
      Since I don't know what causes it (Pagelines, or a Plugin), I would like to disable the feature using a CSS override that Google describes as follow:
      "Scroll anchoring aims to be the default mode of behavior when launched, so that users benefit from it even on legacy content. A CSS property overflow-anchor can disable scroll anchoring in part or all of a webpage (opt out), or exclude portions of the DOM from the anchor node selection algorithm. This property supports the following values when applied to an element E:
      overflow-anchor: auto (the default value) declares that the DOM subtree rooted at E is eligible to participate in the anchor node selection algorithm for any scrolling box created by E or an ancestor of E. overflow-anchor: none declares that the DOM subtree rooted at E is not eligible to participate in the anchor node selection algorithm for any scrolling box created by E or an ancestor of E." Do you guys happen to know how to use that property with the ROOT element so it applies to the whole page?
      Thanks
      Michael 
×