Jump to content
sabbadoo32

Problems with Budget Game Code in Pagelines

Recommended Posts

sabbadoo32    1
sabbadoo32

I'm with Cook County Government.  For the past 2 years we've used Platform Pro for many of our public-facing websites.  We use it for our Budget Site, and it has been very popular.  This year we updated to Pagelines.

 

Each year we use code for a game we call "Make the Tough Choices".  When I insert the same code to Pagelines from Platform Pro, the game is broken.

 

Here's a link to the old budget game: http://blog.cookcountyil.gov/budget/make-the-tough-choices/

 

Here's a link to the new budget game: http://home.cookcountyil.gov/budget/make-the-tough-choices/

 

Here's the code, taken from the Platform Pro version: http://paste.pagelines.com/958

Share this post


Link to post
Share on other sites
greenfly    230
greenfly

Are you missing a plugin that handles the sliders? Looks like the sliders are jquery powered. Have you copied the site across or just this functionality? if so did you copy across all changes to all files? where there any changes to functions.php to add the jquery? 


The answer to many issues can be found by searching in the forum before posting as someone else  may very well have had the same problem before you have.  Also, reading the documentation can help you gain a good understanding of how everything works. 

 

Please do not send me private messages. Occam's razor - The principle states "Keep things simple!"

Share this post


Link to post
Share on other sites
sabbadoo32    1
sabbadoo32

Not sure if my previous comment posted.  In the PP version, we had this code in Advanced/Headerscripts.  I've added it to the same field in PL:

 

http://paste.pagelines.com/3aq

Share this post


Link to post
Share on other sites
sabbadoo32    1
sabbadoo32

I didn't write it, and have only tweaked the values and the url reference (since we only do this once a year, it took a minute to recall. Ive since fixed the line 1 url reference as well).  Am I missing something from the js?

Share this post


Link to post
Share on other sites
James B    436
James B

Hi there

 

I've tested your code on my pagelines site and can confirm it doesn't seem to be working. I know the js library updated recently so it could be that this no longer works due to that, have you tried testing on the standard twenty/twelve theme to see if it works in there?

 

If it does try disabling any third party plugins where the js could be conflicting, but as I said I've tried it on mine so I'd imagine it's not the framework but the code etc.

 

Let us know though what happens.


Kindly search the forum and read the documentation before posting. It will help you resolve many issues.

For CSS help be sure to check out W3Schools first and be sure to download FireBug for FireFox for troubleshooting.

James B

Share this post


Link to post
Share on other sites
sabbadoo32    1
sabbadoo32

It's up and working properly.  http://home.cookcountyil.gov/budget/make-the-tough-choices/  There are some style changes to make, but the heavy lifting is done.  I forgot to add the CSS from the old site. Do I know exactly how I did it?  Not really.

 

Something else has popped up.  I'm using the Tabs and Accordions from Pagelines Tools (http://demo.pagelines.me/tools/).  I had to take some items out of the tabs.  I rebuilt it using the code from the page.  Now when I click on a tab the URLchanges(!).  I replaced the old code, and the problem doesn't go away.

 

When the page opens, I get: http://home.cookcountyil.gov/budget

 

When I click on the first tab I get: http://home.cookcountyil.gov/budget/#1, and the content within the tab doesn't show.

 

If I go to any other website where I have the tabs, it simply moves through them without changing the URL.

 

The sites have been updated to PL 3.5.2

Share this post


Link to post
Share on other sites
James B    436
James B

Hi there,

 

You could try wrapping the code in [pl_raw] tags as per the demo, these should prevent any line breaks and read the accordion code as pure code.

 

If the tabs are not changing over still, this could be a js error from a third party plugin. Try disabling any third party plugins to see if the accordion resolves and begins to switch again.


Kindly search the forum and read the documentation before posting. It will help you resolve many issues.

For CSS help be sure to check out W3Schools first and be sure to download FireBug for FireFox for troubleshooting.

James B

Share this post


Link to post
Share on other sites
sabbadoo32    1
sabbadoo32

We just tried that, and it still doesn't work properly on the Budget site.  It works fine on the other network sites.  We are looking into the game code/css to see if that's causing it.  Maybe not, but we've got to look at the most recent changes.

Share this post


Link to post
Share on other sites
greenfly    230
greenfly

Let us know how you get on 


The answer to many issues can be found by searching in the forum before posting as someone else  may very well have had the same problem before you have.  Also, reading the documentation can help you gain a good understanding of how everything works. 

 

Please do not send me private messages. Occam's razor - The principle states "Keep things simple!"

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


×