Jump to content
Sign in to follow this  
tonyzeoli

Pagelines loading only when default Permalinks setting is active

Recommended Posts

tonyzeoli    11
tonyzeoli

I noticed my Pagelines is only loading on a Wordpress mu installation when my Permalinks for DigitalStrategyWorks.com are set to DEFAULT. When I try to do custom or any other, the site breaks.

 

Currently, the site is set to the default permalinks setting and debug is set to on.

 

I checked my php.ini memory and I'm not using a lot of system resources. I even removed a few sites from the network to check them.

 

It was really when Permalinks was set to anything other than default that I have the problem.

 

I got this error in my Google Developer tools:

 

Failed to load resource: the server responded with a status of 500 (Internal Server Error) http://digitalstrate...s-8_1371948274/
  1. chrome.tabs is not available: You do not have permission to access this API. Ensure that the required permission or manifest property is included in your manifest.json. binding:202
    1. Binding.generatebinding:202
Uncaught TypeError: Cannot call method 'create' of undefined measureIt.js:120
FB.getLoginStatus() called before calling FB.init(). all.js:55
 

Share this post


Link to post
Share on other sites
greenfly    230
greenfly

Hello Tony 

 

Please could you try disabling all your non-pagelines plugins from the plugins below and see if the issue persists. 

 

Plugins : 14
akismet/akismet.php
all-in-one-seo-pack/all_in_one_seo_pack.php
bad-behavior/bad-behavior-wordpress.php
clicky/clicky.php
contact-form-7/wp-contact-form-7.php
nextgen-gallery/nggallery.php
share-this/sharethis.php
slideshare/slideshare.php
social-media-widget/social-widget.php
vipers-video-quicktags/vipers-video-quicktags.php
visual-sound/visualsound.php
wordbooker/wordbooker.php
wp-memory-usage/wp-memory-usage.php
wp-security-scan/securityscan.php

The answer to many issues can be found by searching in the forum before posting as someone else  may very well have had the same problem before you have.  Also, reading the documentation can help you gain a good understanding of how everything works. 

 

Please do not send me private messages. Occam's razor - The principle states "Keep things simple!"

Share this post


Link to post
Share on other sites
tonyzeoli    11
tonyzeoli

I deactivated all network activated plugins as well as plugins on the site instance and still have the issue.

Share this post


Link to post
Share on other sites
James B    436
James B

Hi there,

 

Try adding the following to the wp-config to see if it corrects the error.

 

define( 'PL_NO_DYNAMIC_URL', true );


Kindly search the forum and read the documentation before posting. It will help you resolve many issues.

For CSS help be sure to check out W3Schools first and be sure to download FireBug for FireFox for troubleshooting.

James B

Share this post


Link to post
Share on other sites
tonyzeoli    11
tonyzeoli

That did work. Can you please explain what that does and if it affects anything else that I should be concerned about?

Share this post


Link to post
Share on other sites
James B    436
James B

As far as I'm aware from what the developers written previously, that code will allow you to use a url regardless of how the permalinks have been set. It should effect anything else on the site, only the url for the compiled css.


Kindly search the forum and read the documentation before posting. It will help you resolve many issues.

For CSS help be sure to check out W3Schools first and be sure to download FireBug for FireFox for troubleshooting.

James B

Share this post


Link to post
Share on other sites
tonyzeoli    11
tonyzeoli

Okay, thanks. You can consider this resolved.

Share this post


Link to post
Share on other sites
greenfly    230
greenfly

Thanks for letting us know 


The answer to many issues can be found by searching in the forum before posting as someone else  may very well have had the same problem before you have.  Also, reading the documentation can help you gain a good understanding of how everything works. 

 

Please do not send me private messages. Occam's razor - The principle states "Keep things simple!"

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this  

  • Similar Content

    • kri8it
      By kri8it
      Hi,
      I seem to be having a problem with my pages being detected as 'type' -> 'blog' when I use a custom permalink structure ( /%category%/%postname%/ ).
      However, when I switch to the default wordpress permalink structure, the pages work fine and show up as 'type' -> 'page'.
      I've used DMS on a lot of sites and this is the first time I've experienced this. I have deactivated all plugins, removed all custom code and the problem still persists. 
      Any help would be amazing...
    • superhumains
      By superhumains
      hello,
       
      I'm a dms pro user but i can't post in the appropriate forum !!
       
      Whatever the article on which you click, it takes on the same article.    The URL that appears correct but not Article! So we can not see the good post.    I checked the HTACCESS. I revalidate permalinks settings.    But I still have the same problem:    www.superhumains.com
    • jakenielson
      By jakenielson
      Hi,
       
      I'm having an issue that may have to do with permalinks but I'm not certain. Ever since I upgraded to the new DMS version, whenever I access certain pages on my site when not logged into the site as an administrator, the correct URL shows in the address bar but the incorrect post content is shown on the page.
       
      However, when I'm logged in as an administrator and when the DMS pagelines editor is on, I always get the correct post with the correct URL.
       
      Below is my debug information:
      DMS Debug Info WordPress Version
      3.8.1
      WordPress Debug
      Disabled
      Multisite Enabled
      No
      Current Role
      Administrator
      Framework Path
      /home/content/p3nexnas03/34/2066234/html/wp-content/themes/dms
      Framework URI
      http://theinnovativemanager.com/wp-content/themes/dms
      Framework Version
      1.1.7
      PHP Version
      5.4
      PHP memory
      256
      Mysql version
      5.5.33-log
      PHP type
      Cgi-fcgi
      PHP User
      Posix functions are disabled on this host!
      OS
      Linux
      Licence OK
      Jakenielson@gmail.com
      Installed Plugins
      advanced-iframe/advanced-iframe.php
      aweber-web-form-widget/aweber.php
      custom-sidebars/customsidebars.php
      dms-plugin-pro/dms-plugin-pro.php
      download-manager/download-manager.php
      feedburner-plugin/fdfeedburner.php
      hybridconnect/hybridconnect.php
      jetpack/jetpack.php
      jquery-smooth-scroll/jquery-smooth-scroll.php
      leadpages/leadpages.php
      outbrain/outbrain.php
      pagelines-sections/pagelines-sections.php
      social-sharing-toolkit/social_sharing_toolkit.php
      tinymce-advanced/tinymce-advanced.php
      ubermenu-megamenu-adapter/ubermenu-megamenu-adapter.php
      ubermenu/ubermenu.php
      updraftplus/updraftplus.php
      wordpress-seo/wp-seo.php
      youtube-embed-plus/youtube.php
    • gogeiger
      By gogeiger
      Hi,
       
      I originally had problem
       
      My site http://www.elitehvaccontractors.com/ not having a main blog page for blog ,
       
      I changed my permalink
       
      To custom /blog/%postname%/ and now I have a blog page http://www.elitehvaccontractors.com/blog/
       
      New problem developed
       
      My location page went from http://www.elitehvaccontractors.com/locations/hvac-contractors-collegeville-pa/
      To the following: http://www.elitehvaccontractors.com/blog/locations/hvac-contractors-collegeville-pa/
       
       
      I need help with the following:
      Keeping Blog main page for web site Change locations back to original and not have it follow blog file Goal:
      http://www.elitehvaccontractors.com/blog/
      http://www.elitehvaccontractors.com/Locations/
       
      NOTE:
      I use plug in Yoast WordPress SEO: Local SEO have contacted them and they say plug in is working and resulting because I put blog in custom permalink. They could not support any further advice.
      If I take blog out then my main blog page disappears.
        
       
      Thank you in advance for a solution,
      Tim Geiger
       
       
    • Oxide
      By Oxide
      When I change the permalinks structure to a custom structure (pages) it breaks my site. I've read other posts about how the CSS doesn't work if the permissions aren't set correctly on the server, but I'm not sure which files need increased permissions. I would rather not use 777 if I don't have to. I have attached a screenshot of what it looks like when it breaks. 
       
      Things I've tried:
       
      Updating permissions on .htaccess to 755
      Deleting .htaccess altogether
      Tried adding the following to wp-config: define( 'PL_NO_DYNAMIC_URL', true ); as suggested by http://forum.pagelines.com/topic/27761-pagelines-loading-only-when-default-permalinks-setting-is-active/?hl=permalinks.
      Live-chatted with my hosting service - they were no help.
      Tried this too: http://forum.pagelines.com/topic/21053-permalinks-affecting-the-pagelines-layout/?hl=permalinks
       
      I'm new to web development, so forgive me if the answer is painfully obvious.
       
      Help?
×