Jump to content
Sign in to follow this  
davemoppert

Align center issue on menu items with submenu

Recommended Posts

davemoppert    6
davemoppert

for some reason, any menu item that has a drop down aligns to the left.  I cannot fix it with CSS... can you please take a look and help me troubleshoot?

 

http://epicgeniussites.com/wlhunting

Share this post


Link to post
Share on other sites
batman    389
batman

Hi davemoppert

Please, you can try with

 

 

.section-hero-nav .hero-nav .hero-nav-ul .dropdown-menu li a {text-align: right;}

and

.section-hero-nav .hero-nav .hero-nav-ul .dropdown-menu li > a:hover {text-align: right;}


Life is too short to remove USB safely ...

Share this post


Link to post
Share on other sites
davemoppert    6
davemoppert

Thanks... I appreciate the quick reply batman!  So, I don't need to change the alignment for the dropdown menu -- the problem is the main menu items that have a dropdown are not aligned center.  The main menu items that don't have a dropdown align center as it should do by default.  See attached image.  Hunt the West, Hunt Sonora, and Photo Gallery all have drop down menus, and are aligned left, BUT the About, Testimonials, and Contact Us page don't have a drop down and are aligned center (the way I want the main menu to look).  

 

Thanks for any future help!

 

error.png

Share this post


Link to post
Share on other sites
batman    389
batman

Sorry, i understand now

Please take a look with

 

.caret.icon-caret-down {width: 0em;}

or

li [class*=" icon-"]{width: 0em;}

 

I´m not sure

:)


Life is too short to remove USB safely ...

Share this post


Link to post
Share on other sites
evan    0
evan

davemoppert,

 

Try this:

.section-hero-nav .caret {
display: none;
}

Share this post


Link to post
Share on other sites
davemoppert    6
davemoppert

Boy do I feel dumb.  I thought they were aligned left in the CSS and couldn't find it.  Didn't even think about the caret.  Thanks!  You fixed it!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this  

  • Similar Content

    • vikzee
      By vikzee+
      Hero Nav 1.3
      DMS 2.1.9.3
      Wordpress 4.2.2
      I just downloaded the latest version of Hero Nav from my Pagelines account but when I try to upload it to the plugins page it gives me this error:
      The package could not be installed. No valid plugins were found.
      Plugin install failed.
      So I unzipped the package and find that all it contains is a README file.
      Can you send me the latest version (vikzee (@AT@) yahoo.co.uk) in it's entirety or re-load it to the Pagelines site so people who've paid for it can get the latest version?
      Thanks! 
    • AppLEaDaY
      By AppLEaDaY
      Hello.
       
      I did not personally install what I'm trying to fix. I'm working on a preexisting installation of WordPress and Pagelines.
      But when I arrived the problem was already there: just upon posts displaying in the hero nav main menu I get a "Home" link not working,
      due to a anchor completely missing the href attribute.
       
      I made some tests and I noticed what follows.
      The same problem occurs with every plain link I add that hero menu (not with pages), I mean with links showed as CUSTOM Curiously enough I found in a sublevel a link of that kind, it has somehow back in the past inserted by someone else, no me: it works just like it is supposed to do No problem of that kind in a fixed navigation bar (I tried to enable it) I underscore the mentioned problem occurs only when displaying posts, not with pages.
       
      Any clues? Since I'm afraid it may take a too long time to fix this specific problem, I also ask: could you possibly point to what I am supposed to read in order to do without the hero nav bar and use some other navigation bar in the same place of the template?
       
      Thanks in advance
       
       
      Andrea
    • limelight
      By limelight+
      Hello, I'm having a strange issue with the background of my Hero Nav drop-down being "see through". Can anyone direct me on how to make this solid black instead??  Thank you! 
       
      Site URL: http://multicolores.org/ And there is a drop-down menu when you hover over 'About'.
       
       
    • ScribbleGD
      By ScribbleGD+
      Hi there,
       
      Whenever I make changes to the formatting options in the Hero Nav section of Site Settings such as font base colour it doesn't appear to change the look of my nav bar,
       
      Any reason as to why this is happening? Screenshot attached.
       
      Thanks.
       
      URL - staging.scribblegraphicdesign.com.au
       
      Tim
       
    • webmktco
      By webmktco+
      Evan,
       
      I've had issues with making edits to the Hero Nav settings for a while now.  I've been able to work around the issue, but I thought I'd bring this to your attention.
       
      Do you know why this is happening and how to fix it?
       
      Here's the debug info: http://josephfoxdds.myddsdev.com/?pldebug=1

      WP: 4.0
      DMS: 2.1.1
×