Jump to content

Archived

This topic is now archived and is closed to further replies.

webmktco

Modal Popup- Is it possible to disable automatic popup?

Recommended Posts

webmktco+    21
webmktco

Is it possible to disable the automatic popup?  I'd like to create a request appointment button where the user clicks the button.  The popup has a form in it. 

 

Would Modal Popup work for this?

Or am I missing the whole point of the automatic popup???  :)

Share this post


Link to post
Share on other sites
MrFent+    28
MrFent

The main benefit of the Modal PopUp section is so that your visitors don't HAVE to click on a trigger to make the PopUp appear. However, you are the second person requesting the feature to be able to disable the automation completely, so I will go ahead and add it to a future update :) I just took my Macbook to the repair shop, so it'll probably be at least a week before I get it back and am able to add that feature. HOWEVER, you can easily accomplish your goal with the current version by setting a delay in the PageLines Meta Settings. There's a setting to add the delay (in milliseconds) and you can just add a huge delay so that the PopUp won't appear. 3144695200 milliseconds equals 1 year, so just use a big number like that and as long as your visitors don't keep that page open on their computer for 1 year, the PopUp will never show up :) 

  • Like 2

Share this post


Link to post
Share on other sites
MrFent+    28
MrFent

Ask & ye shall receive: "Disable Automation" option added to version 1.0.2.

Share this post


Link to post
Share on other sites
paul_t    21
paul_t

If you are using the PL short code for the popup

I think using the undocumented parameter

show = false

will stop the modal from oping up on page load

show=true will make it pop up

Share this post


Link to post
Share on other sites

  • Similar Content

    • abuzzelli
      By abuzzelli+
      I need the modal popup background to be solid and I can't get the css to work. Not sure what to do. Here's the page: http://bellissimoplasticsurgery.com/breast-augmentation-test-page/
    • 21thirteen
      By 21thirteen
      I've used the Modal Popup for an optin form on http://thecommonthreadgroup.com for both an automatic popup on the home page and a manual popup on every page of the site by using a different Custom Modal ID - no problem - they both work.
      I'm trying to use just the manual trigger on this site under development: http://seidner.21thirteenhost.com/
      I've got the section in the superfooter (I've tried it in other places as well) and a manual trigger on the superfooter as well as in the sidebar here: http://seidner.21thirteenhost.com/category/blog/
      It is not working. The difference is that in this site I'm using the Easy Smooth Scroll Links plugin, Version 2.0, by Jeriff Cheng.
      Obviously there is a conflict here and I don't understand enough about this sort of thing to do anything about it. I really need to use both plugins.
      I'm more of a web designer with some pretty decent knowledge of html and css, and not a php guy. ANY help would be greatly appreciated.
      WP and DMS2 versions are totally update, as are all plugins.
      Additional data is that there is a place in the ESSL plugin for "Exclude Anchors Beginning With ( default is #tab #quicktab #pane )" and "Exclude Anchors Exactly Match". I've put #ModalPopUp, #Modal, and Modal in the provided fields, but still no go.
      Thank you in advance,
      Perry
    • ade55
      By ade55+
      Just installed this and can only get the header to appear in the popup.
       
      I've tried plain text in the body or selecting a page to show its content but only ever get 1 line of header
       
      see here for example.
       
      http://fishingtails.co.uk/about-us/
       
      press push me button to activate popup
    • Claude203
      By Claude203
      Hi, the Modal Popup is working fine. But whenever I look on the DMS Editor, that section is gone. It was placed at the bottom of the Footer. The first time it happened, I thought maybe I had inadvertently deleted it, or not saved properly. So I re-created another one. And so on. Then I finally realized it was working after all. But now I'm wondering if there are several of my popups in place, all of them the same, yet none of them visible, but yet all of them working. I've tried adjusting/saving into a new page template. I've tried turning on/off the DMS Editor. Still can't find a trace of the Modal Popup section, yet I know it works because I used Safari and Firefox to confirm, even on a different computer. Thanks for any help/insight you might provide.
       
      http://www.blackfives.org
    • pauloso
      By pauloso
      Dear Chris,
       
      I have a page with multiple pop-ups.
      When user clicks on the link it was supposed to open the pop-up.

      But when we click it opens up the pop-up and immediately closes it.
      I tested it on many browsers and all had the same strange behavior.

      You can see it on page: http://qualitaexpress.com.br/etapas-de-uma-importacao/
      Click on any of the links under the main big icons.

      Or click on any of the buttons on page: http://qualitaexpress.com.br/servicosparaimportacao/

      I have WordPress 4.0.1 running iBlogPro theme.
      Any idea on how to fix it?
      Thanks
×