Jump to content
wpclincoln

My mobile menu has... "shrinkage"

Recommended Posts

wpclincoln    0
wpclincoln
When our site is viewed on a mobile device (both Android and iOS), the menu icon appears in the top left as normal. 
 
When you tap on the menu icon, it expands to display the search box & menu items, but only for a half-second or so, then immediately contracts to display only the search box.
 
Below is the custom CSS I use on the menu. Could it be that my mods have caused this errant behavior somehow?
 
Any thoughts are appreciated.
 
- Chris
 
 
CSS:
.plbrand-text { display:none; }

.navbar { font-size: 1.5em; }

.navbar .navline { margin-left: 10px; position: absolute; }

.navbar.pl-color-blue	{
	background: rgb(0,43,64);
	background: -moz-linear-gradient(top,  rgba(0,43,64,1) 0%, rgba(0,64,94,1) 8%, rgba(0,43,64,1) 100%);
	background: -webkit-gradient(linear, left top, left bottom, color-stop(0%,rgba(0,43,64,1)), color-stop(8%,rgba(0,64,94,1)), color-stop(100%,rgba(0,43,64,1)));
	background: -webkit-linear-gradient(top,  rgba(0,43,64,1) 0%,rgba(0,64,94,1) 8%,rgba(0,43,64,1) 100%);
	background: -o-linear-gradient(top,  rgba(0,43,64,1) 0%,rgba(0,64,94,1) 8%,rgba(0,43,64,1) 100%);
	background: -ms-linear-gradient(top,  rgba(0,43,64,1) 0%,rgba(0,64,94,1) 8%,rgba(0,43,64,1) 100%);
	background: linear-gradient(to bottom,  rgba(0,43,64,1) 0%,rgba(0,64,94,1) 8%,rgba(0,43,64,1) 100%);
	filter: progid:DXImageTransform.Microsoft.gradient( startColorstr='#002b40', endColorstr='#002b40',GradientType=0 );
}

.navbar .navline > li.current-menu-item > a { color: #ffffff; }

 

Share this post


Link to post
Share on other sites
James B    436
James B

Hi there,

 

I've tested your site and can see what you mean.

 

There's nothing in the css above I can see that would cause the menu to drop and then disappear. I would think it's coming from a js conflict possibly, if you have any third party plugins try disabling them first and then clear the browser cache to see if the drop down resolves.

 

If you've added any additional scripts to the header or footer areas of the custom code page, then try removing them as well to see if this resolves the drop down.


Kindly search the forum and read the documentation before posting. It will help you resolve many issues.

For CSS help be sure to check out W3Schools first and be sure to download FireBug for FireFox for troubleshooting.

James B

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


  • Similar Content

    • dwpoyner
      By dwpoyner+
      Not sure exactly what is causing the issue. For some reason, why you view my site on mobile, the menu does not show up. It will pop up, but it is black. You can check it out here: http://dev.caryfbc.org. I'm also attaching a screenshot where I shrunk my browser down. Any suggestions?

    • kwaoru
      By kwaoru
      Hi,
       
      I have been using DMS and pagelines.
      I am facing to a huge trouble with the appearance of one of my page on mobile (smart phones) built with pagelines.
      However I haven’t come to any solutions to organise either edit the appearance of mobile view to look neat or deactivate the responsive function. 
      Now it looks totally messy on the phone...
       
      1. Is there any way to edit the appearance of the mobile version (responsive theme)?
      2. Is there any way to deactivate responsive function?
       
      If I could receive support from you to go thorough this process I would be happy to be a pro member. 
       
      Looking forward to hearing from you.
    • khat
      By khat+
      I think I may have installed pagelines pro incorrectly, and then used features incorrectly. I installed first platforms framework theme and then the child, thinking I could do setup for child later. I tried to set up a background image, and tried custom css feature in pagelines dashboard. I had mistakes in my css, and just thought that if I deleted the info in the css custom feature in pagelines dashboard that the new information would overwrite the old info. The background image didn't respond at all, probably because I didn't have the child directory renamed. I then tried to use the LSS plugin to create css and added more css, possibly, somewhere -sigh-. I never did change the background image and get it placed properly. I used a workaround and in nested containers I placed a background image which worked well enough, so I moved on to try to create my nav bar/ menu bar. When I go to the Menus panel, there is NO area where I can place a menu on a page. I have read and reread and re- re- reread the instructions for placing a menu. I've used the pagelines editor to place a menu, however only HOME shows up. I've been at this for many hours. I've since uninstalled all of my pagelines items and reinstalled, thinking that it would restore all my changes to default, but no, it is still all there, with all my unresolved issues. I am completely at a loss as to what to do next.
    • poseyg
      By poseyg+
      This just happened to a site I'm working on. When I decrease width of browser to check for responsiveness...the pagelines content section is not responding???
×