Jump to content
wpclincoln

My mobile menu has... "shrinkage"

Recommended Posts

wpclincoln
When our site is viewed on a mobile device (both Android and iOS), the menu icon appears in the top left as normal. 
 
When you tap on the menu icon, it expands to display the search box & menu items, but only for a half-second or so, then immediately contracts to display only the search box.
 
Below is the custom CSS I use on the menu. Could it be that my mods have caused this errant behavior somehow?
 
Any thoughts are appreciated.
 
- Chris
 
 
CSS:
.plbrand-text { display:none; }

.navbar { font-size: 1.5em; }

.navbar .navline { margin-left: 10px; position: absolute; }

.navbar.pl-color-blue	{
	background: rgb(0,43,64);
	background: -moz-linear-gradient(top,  rgba(0,43,64,1) 0%, rgba(0,64,94,1) 8%, rgba(0,43,64,1) 100%);
	background: -webkit-gradient(linear, left top, left bottom, color-stop(0%,rgba(0,43,64,1)), color-stop(8%,rgba(0,64,94,1)), color-stop(100%,rgba(0,43,64,1)));
	background: -webkit-linear-gradient(top,  rgba(0,43,64,1) 0%,rgba(0,64,94,1) 8%,rgba(0,43,64,1) 100%);
	background: -o-linear-gradient(top,  rgba(0,43,64,1) 0%,rgba(0,64,94,1) 8%,rgba(0,43,64,1) 100%);
	background: -ms-linear-gradient(top,  rgba(0,43,64,1) 0%,rgba(0,64,94,1) 8%,rgba(0,43,64,1) 100%);
	background: linear-gradient(to bottom,  rgba(0,43,64,1) 0%,rgba(0,64,94,1) 8%,rgba(0,43,64,1) 100%);
	filter: progid:DXImageTransform.Microsoft.gradient( startColorstr='#002b40', endColorstr='#002b40',GradientType=0 );
}

.navbar .navline > li.current-menu-item > a { color: #ffffff; }

 

Share this post


Link to post
Share on other sites
James B

Hi there,

 

I've tested your site and can see what you mean.

 

There's nothing in the css above I can see that would cause the menu to drop and then disappear. I would think it's coming from a js conflict possibly, if you have any third party plugins try disabling them first and then clear the browser cache to see if the drop down resolves.

 

If you've added any additional scripts to the header or footer areas of the custom code page, then try removing them as well to see if this resolves the drop down.


Kindly search the forum and read the documentation before posting. It will help you resolve many issues.

For CSS help be sure to check out W3Schools first and be sure to download FireBug for FireFox for troubleshooting.

James B

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


  • Similar Content

    • Liv Kundalini
      By Liv Kundalini+
      Hi -
      Pulling my hair out over here, and would love an assist!
      Site I am building, http://www.livkundalini.com/home, has a problem with the submenu items in the nav not appearing. 
      If anyone wants to see what the Nav should look like, feel free to look in the footer on the left hand side.
      Have tried disabling Pagelines and using the twentyseventeen theme, but problem persists.
      Saw this error (pasted at the bottom of this post) displaying in the inspector, and saw discussion of Jetpack potentially being a culprit. Disabled Jetpack, but the problem persists.
      Had the hosting company even flush the server-side cache, but no avail.
      Any thoughts? Please? It's the only thing keeping me from launching this site!
      Many Thanks,
      Todd
       
      WebSocket connection to 'wss://public-api.wordpress.com/pinghub/wpcom/me/newest-note-data' failed: Error during WebSocket handshake: Unexpected response code: 403   O @ (index):7
    • russe-intensif
      By russe-intensif+
      Hi team,
      checking my site today, i'm surprised to see my MegaNav all in bottom of the pages, while it's in header.
      After getting to change it in couple of pages onto Template part (too time consuming !), i'm desperate and ask you for help :-)
      apprendre-le-russe-avec-ania.fr
      Thank you in advance !

    • dwpoyner
      By dwpoyner+
      Not sure exactly what is causing the issue. For some reason, why you view my site on mobile, the menu does not show up. It will pop up, but it is black. You can check it out here: http://dev.caryfbc.org. I'm also attaching a screenshot where I shrunk my browser down. Any suggestions?

    • kwaoru
      By kwaoru
      Hi,
       
      I have been using DMS and pagelines.
      I am facing to a huge trouble with the appearance of one of my page on mobile (smart phones) built with pagelines.
      However I haven’t come to any solutions to organise either edit the appearance of mobile view to look neat or deactivate the responsive function. 
      Now it looks totally messy on the phone...
       
      1. Is there any way to edit the appearance of the mobile version (responsive theme)?
      2. Is there any way to deactivate responsive function?
       
      If I could receive support from you to go thorough this process I would be happy to be a pro member. 
       
      Looking forward to hearing from you.
×