Jump to content
Business-Manager

PageLines Core LESS/CSS error. expected color value: failed at `.ibp-boxshadow(@ibp-bg);` line: 7140

Recommended Posts

Business-Manager

Getting a new error

 

PageLines Core LESS/CSS error.

expected color value: failed at `.ibp-boxshadow(@ibp-bg);` line: 7140

 

How do you repair this?

Share this post


Link to post
Share on other sites
greenfly

Hello Business manager 

 

Please could you paste in your CSS code to here please so we can take a look. http://paste.pagelines.com/ Please provide a link to your paste. 

 

Also can we have a link to your site please? 


The answer to many issues can be found by searching in the forum before posting as someone else  may very well have had the same problem before you have.  Also, reading the documentation can help you gain a good understanding of how everything works. 

 

Please do not send me private messages. Occam's razor - The principle states "Keep things simple!"

Share this post


Link to post
Share on other sites
Business-Manager

I just posted the syle.css

 

I have the pagelines framework and the iblog5 theme.

Share this post


Link to post
Share on other sites
James B

Hi there,

 

The code which seems to be throwing the error is a LESS variable. I can't see this added in your custom code, LESS code would go into a Style.LESS instead of a Style.css. Have you made any amendments to the box shadow anywhere?

 

On the wp admin bar, do you see a button appear that says FLUSH? If so press that to see if the error repairs itself.


Kindly search the forum and read the documentation before posting. It will help you resolve many issues.

For CSS help be sure to check out W3Schools first and be sure to download FireBug for FireFox for troubleshooting.

James B

Share this post


Link to post
Share on other sites
James B

Client responded but it went by email instead on the thread, posting message in for other admins to see complete conversation etc.

 

I have not made any changes to the box shadow - the error just showed up.

it is when I have activated the iblog5 child theme.

there is no file called styles.less

 

IBlog Pro uses LESS in it's core code, if you've switched back to the main theme and then error is still showing you'll need to recompile/flush the LESS/Css.

 

Go to Pagelines>site options>advanced and check the 'enable debug' checkbox. Then go to view the page and you'll see a FLUSH LESS button on the admin bar, like this - http://screencast.com/t/KE6foQBEKZ8 press the button to clear and re-compile the code. This should hopefully remove the error message you're seeing.


Kindly search the forum and read the documentation before posting. It will help you resolve many issues.

For CSS help be sure to check out W3Schools first and be sure to download FireBug for FireFox for troubleshooting.

James B

Share this post


Link to post
Share on other sites
Business-Manager

Ok

 

enabled the debug

 

also selected flush less

 

error still returned

Share this post


Link to post
Share on other sites
Business-Manager

this is not good

 

site went live today with an email campagin

 

what is up

Share this post


Link to post
Share on other sites
James B

That's strange, that code is part of the IBlog Pro core files, so it shouldn't have a problem at all. I've just installed IBlog Pro 5 to see if I can get the error to replicate in case it's something related to the theme etc. But so far no LESS errors showing.

 

Make sure you're using the latest version of IBlog Pro 5. You can check the version number in appearance>themes. The latest version is 5.2.5

 

I would say the first thing to do would be to copy your css and paste it into a blank text document, then remove it from the custom code box and save. So you site has no custom css, save and test to see if the error clears. If not re-paste in your css.

 

Then try disabling all your plugins and then flush the LESS to see if the error clears, you currently have 45 plugins installed so it could be something conflicting there with the core code for the theme. Disable the Pagelines plugins too, some of these will use LESS. If the message clears it will be a case turning each one on/off to see which is causing the error and then we can investigate further etc.

 

People viewing the site won't be able to see the LESS error, this is a warning in your admin area just stating it was expecting a certain value and got another etc.


Kindly search the forum and read the documentation before posting. It will help you resolve many issues.

For CSS help be sure to check out W3Schools first and be sure to download FireBug for FireFox for troubleshooting.

James B

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


×