Jump to content
Sign in to follow this  
andulka

qTranslate messing up the date

Recommended Posts

andulka

I would like to switch from xLamguage to qTranslate (Station Pro), and everything else is working fine, only the dates get all messed up. This has something to do with the plugin, see here - I just don't have a clue where I should add that piece of code or if it is the right one. Would be great if you were able to point me to the right direction. Currently, depending on the qTranslate settings (which are: Use emulated date function; Use emulated date function and replace formats with the predefined formats for each language; Use strftime instead of date; Use strftime instead of date and replace formats with the predefined formats for each language) I get either the post date or the comment date to show correctly, but not both at the same time.

Share this post


Link to post
Share on other sites
cmunns

Does the plug-in author have a contact? It would be best to talk to him directly as we aren't familiar with that plug-in or it's authors code.

Share this post


Link to post
Share on other sites
andulka

Yes, there is a forum and it's been discussed here - what the author says, 'if you want everything to work the way before, simply uncheck strftime support' doesn't work, so I guess I should try the other options. Someone has solved it like this: 'The reason that there are no date shown if strftime is enabled is because my theme only uses the_time function. So I just changed it into the_date function to show date and the_time function to show time, and qtranslate handles all into strftime automatically.' Perhaps you could tell where to start looking for those functions?

Share this post


Link to post
Share on other sites
catrina

Hello, The person who solved it probably edited those functions in their Theme Functions file (functions.php) but I am not sure. I think it's best if you get an account for that qTranslate Forum so you can get in touch with that person who came up with the solution and ask him or her where those functions are located.


Please read the docs before posting. Please do not private message me unless I ask you to.

Designer | Catrina Dulay

Founder | Catrina and Mouse

Share this post


Link to post
Share on other sites
andulka

I've already submitted this there, but as far as I've noticed, the files tend to be theme spesific and oftentimes it turns out that files with the same name don't have the same functions at all. Sometimes the files I've been looking for after having read some instructions don't exist at all.

Share this post


Link to post
Share on other sites
catrina

Have you tried the other provided options yet? If so and they're not working, then it's a good idea to get in direct contact with the plug-in author by e-mail and see if he has any other solutions that weren't presented. The author is more familiar with how the plug-in works, so perhaps he can give you more specific direction that can be helpful.


Please read the docs before posting. Please do not private message me unless I ask you to.

Designer | Catrina Dulay

Founder | Catrina and Mouse

Share this post


Link to post
Share on other sites
andulka

Judging by the comments and replies he's given on the forum, I'm not very hopeful. If there was a universal fix that worked with all themes. I'm sure he would've presented it by now. Direct email contact may not be possible, as he says there that he doesnt have the time to give free private instructions, but I will of course try that too. Still, I'm kinda hoping that the developers of this theme will know where to look for those particular functions in this theme, even though they don't know the plugin (simlarly, the plugin developer won't be familiar with the theme...) And yes, I've tried all sorts of solutions, also ones that involve changing/deleting some code (of which I knew where it was) :-) but no luck so far. :-(

Share this post


Link to post
Share on other sites
catrina

You can try to contact the plug-in developer but in case that doesn't work out, I can still forward this problem to the theme developers to see if there is any possible workaround for it.


Please read the docs before posting. Please do not private message me unless I ask you to.

Designer | Catrina Dulay

Founder | Catrina and Mouse

Share this post


Link to post
Share on other sites
andulka

My original link appears to be leading to a wrong problem (which I also had - apparently the head gets a bit muddled up, having to wrestle with things one isn't familiar or comfortable with), aplogies! The actual link is here - they discuss about changing the function calls in the template files. That's the one thing I haven't tried yet, as I haven't had the time and energy to figure out which template files those are (and was hoping someone might be able to tell me here...) :-) I'll let you know how it goes once/if I can locate the files and try to make the changes.

Share this post


Link to post
Share on other sites
andulka

It doesn't look like anyone is responding on the plugin's support forum, I guess they're fed up with hearing about this... I just wonder why the developer hasn't done anything to fix it, can't be that hard and people have been complaining about it for years. So it looks like I'm stuck with xLanguage, which is OK except it's rather difficult to use for anyone who doesn't know first thing about html (as are the people writing the blogs on the site), as it tends to mess up things if there is any formatting included in the text. qTranslate is easier as it has two completely separate boxes where the different language texts go. Also it doesn't translate everything, like the comment box texts etc. I'm still hoping to be able to find a fix for the qTranslate date problem though, apparently it's solvable, should just somehow find out how its done with this particular theme as the suggested solutions don't do the trick.

Share this post


Link to post
Share on other sites
cmunns

I have a suggesting in your other thread, I'm going to close this one.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this  

×