Jump to content

Archived

This topic is now archived and is closed to further replies.

mtaus

pagelines-compiled-css won't cache

Recommended Posts

mtaus+    5
mtaus

I just setup W3 Total Cache on this site and it appears that all the assets have are working on the CDN (Amazon S3), except for this file: /wp-content/themes/pagelines/pagelines-compiled-css-X_XXXXXXXXXX

 

While most of the site's CSS seems to be working, the CSS will not load for the /blog/ section of the site. Any ideas?

 

Thanks in advance.

Share this post


Link to post
Share on other sites
Simon    247
Simon

Ok first things 1st.

 

Clear the cache and disable the plugin.

 

The reason the file is not pushed to the CDN is that is not a real file.

 

http://www.crowdstreet.com/wp-content/themes/pagelines/pagelines-compiled-css-1_1370025844/

 

This is because for whatever reason the Framework could not write a real css file so it falls back to this dynamic fake css file, works fine for browsers but not so with cdns.

 

So enable debug under advanced settings and we might be able to help more.

Share this post


Link to post
Share on other sites
mtaus+    5
mtaus

Thanks, Simon. I've enabled debug. What now?

Share this post


Link to post
Share on other sites
Simon    247
Simon

Might be enabled for you but all we see is a cached page.

 

We cant do anything at all until we see live pages, sorry.

Share this post


Link to post
Share on other sites
mtaus+    5
mtaus

Oops... I thought I had disabled it. Can you try now?

Share this post


Link to post
Share on other sites
Simon    247
Simon
PHP User : Posix functions are disabled on this host!
So your gonna have to force it.
 
Install the free pagelines-customize plugin. You'll see it in the store.
Activate it.
Open wp-contents/plugins/pagelines-customize/functions.php
Add the following:
 
https://gist.github.com/Pross/5069166

Share this post


Link to post
Share on other sites
mtaus+    5
mtaus

Thanks, Simon. I've added the above to the end of functions.php. However, the pagelines compiled css is still not working. This may have something to do with the fact that I'm using a child theme. Thoughts?

Share this post


Link to post
Share on other sites
mtaus+    5
mtaus

Simon, I see that now. Thanks for the help... However, the custom LESS code is no longer working.

Share this post


Link to post
Share on other sites
Simon    247
Simon

What custom less code?

Share this post


Link to post
Share on other sites
mtaus+    5
mtaus

I have some custom LESS code in the Pagelines panel to change NavBar and some other items. Since, I've activated the Customization Plugin the styles are slightly off in some places. For example, to set the logo size in nav I added the following: 

 

.plbrand{

...

img{max-height: 59px;} 

}

 

This is correctly setting the logo size, but it is also forcing other images on the site to a max height of 59px, for example here http://www.crowdstreet.com/real-estate/future-of-real-estate-crowdfunding/ and  http://www.crowdstreet.com/about/

 

skitch.png?resizeSmall&width=832

 

 

skitch.png?resizeSmall&width=832

Share this post


Link to post
Share on other sites
mtaus+    5
mtaus

Simon, I figured this out. I apparently had a duplicate style sheet in place which was causing an error. Sorry to trouble you and thanks for your help. 

 

Feeling bleary-eyed after several hours of mindless troubleshooting. So, I'm going to try to get this CDN in place after a few beers and a good night sleep!

 

Many thanks!

 

:startle:  :geek:  :startle:

Share this post


Link to post
Share on other sites
mtaus+    5
mtaus

I've continued to have problems with the way that my caching plugin (W3 Total Cache) works with Pagelines' CSS compiler, specifically because the compiled css file gets a new filename whenever changes are made. I found a workaround that I wanted to share, just in case anyone else runs in to this issue.

 

I was able to solve this problem, but adding the following to the CDN > Custom File list in W3TC: wp-content/uploads/pagelines/compiled-css-*.css ... By including an asterisk (*) instead of the generated number, W3TC will load and serve any new variation of the compiled CSS file.

 

Hope this helps! :)

Share this post


Link to post
Share on other sites
mtaus+    5
mtaus

I have a new site that is running DMS. Wondering if this solution from Simon_P (below) works with DMS, too. I can't seem to figure out how to install the customize plugin. 

 

PHP User : Posix functions are disabled on this host!

So your gonna have to force it.
 
Install the free pagelines-customize plugin. You'll see it in the store.
Activate it.
Open wp-contents/plugins/pagelines-customize/functions.php
Add the following:
 
https://gist.github.com/Pross/5069166

 

Share this post


Link to post
Share on other sites
Simon    247
Simon

You can put it in a child theme functions file too.

Share this post


Link to post
Share on other sites

  • Similar Content

    • Michael Kummer
      By Michael Kummer+
      Hi guys,
      every since Chrome introduce scroll anchoring (see chrome://flags) blog posts on my page start scroll automatically as soon as the user scrolls down a bit. It is super annoying and I don't know exactly what triggers the incompatibility with Chrome's latest feature that is supposed to improve usability.
      Since I don't know what causes it (Pagelines, or a Plugin), I would like to disable the feature using a CSS override that Google describes as follow:
      "Scroll anchoring aims to be the default mode of behavior when launched, so that users benefit from it even on legacy content. A CSS property overflow-anchor can disable scroll anchoring in part or all of a webpage (opt out), or exclude portions of the DOM from the anchor node selection algorithm. This property supports the following values when applied to an element E:
      overflow-anchor: auto (the default value) declares that the DOM subtree rooted at E is eligible to participate in the anchor node selection algorithm for any scrolling box created by E or an ancestor of E. overflow-anchor: none declares that the DOM subtree rooted at E is not eligible to participate in the anchor node selection algorithm for any scrolling box created by E or an ancestor of E." Do you guys happen to know how to use that property with the ROOT element so it applies to the whole page?
      Thanks
      Michael 
    • jeomiland
      By jeomiland+
      In DMS2 there was a button to click to flush pagelines cache. Don't see this in platform5. Am having a big problem with caches. Have W3 Total cache plugin, but now even if I deactivate it, the code in css/less seems to not be registering??? I can delete all custom css, save, then add just a bit of the css (that used to work just fine the other day) and that small section of css takes effect. Then when I paste the whole css (that worked fine the other day), it seems to not work???
      About to restore DB backup from a couple days ago to see if that solves it, but it's a drag that this issue exists. Makes it hard to finetune the site.
      Thanks for help
      site is: http://permacultureecovillage.com/lev2017/
      lev styles most recent.css.rtf
    • wyo22ski
      By wyo22ski+
      Hello,
       
      I'm basically a designer and understand a little on how to change CSS, etc., so please excuse my ignorance...  I recently upgraded to the newest platform from the DMS and my old DMS theme no longer functions.  I'm trying to replace the image slider that my Horizon Photography Theme (Nick Haskins) had created.  The Impulse image slider seemed the closest to what I need, but there are problems.
      It seems the the Impulse section for sliding images defaults to the image width, no the height.  I can change the Impulse stage height and width, but this does nothing to the internal content.  For instance, if I change the height to 200 pixels, the image remains the full width and only shows a cropped section.  I would like the ability to change the Impulse height, and have the image height fit space. 
      I've put this custom CSS in, but again, this only controls the stage height of Impulse:
      .pl-sn-impulse .pl-impulse-cell .cell-wrap, .pl-impulse-container, .owl-stage-outer {
        width: 100%;
      }
       
      Any suggestions welcome.  Thanks 
    • Objectif-Mariage
      By Objectif-Mariage+
      Hello. 
      I have just realized that CSS (Less plugin) , is not working..... I have disable all plugins (except PL CUSTOM LESS and PL5) , and ... it's not working ... 
      It's not the first time. Usually I had trouble with a plugin name Autoptimize , but it's Desactivate now , all memory have been purge, and it's still not working! :-/ So it's not from this plugin. 
      NB : When I am logged on my website, if i go on the black wordpress dashboard bar, go on the PL icon, clic on </> LESS/CSS => then the page suddenly apply the CSS .... But As soon that i reload the page, nothing. I think the problem is that the plugin LESS/CSS does not load properly (if I can say that with my simples words).
      I order to keep the site "good looking" I have temporally copy/paste all my LESS code in a plugin : Script n Styles that apply the LESS/CSS code... but it's not a solution for long time.
      Can someone help me ? Did I do something wrong ? Is it an update ? 
       
      my website : https://www.wedding-photography-minneapolis.com
    • Jason
      By Jason+
      Feel free to delete this post if its not helpful or its just plain wrong.
       
      I though it might be useful to share how I customize the size of the builder. (reduce my eyestrain )
      1 - install stylerbot extension in chrome (stylerbot keeps this css every time you access the url)
       
      2- add this css to stylerbot for the site you are working on
      .CodeMirror {
          font-size: 14px;
          height: 600px;
      }
      .pl-workarea.pl-has-sidebar .pl-workarea-sidebar-container {
          right: 0px;
          width: 500px;
      }
      .pl-workarea.pl-has-sidebar .iframe-container {
          right: 500px ;
      }
       
      change sizes to suit.
       
      Cheers.
×