Jump to content
Sign in to follow this  
WebWerx

Weird Level 2 NAV Issue

Recommended Posts

WebWerx

For some reason as soon as I add a Level 2 NAV to my site, the level one's slug gets messed up. Check the bottom left of the attached screenie for the menu item "Industries". It goes from "/industries" to "/#m1". This happens with any menu time I work with. 

 

Site URL: http://goo.gl/eSjqF

 

This may not be a PL issue at all.

post-32834-0-32096100-1369959993_thumb.p

Share this post


Link to post
Share on other sites
Danny

Hi,

 

If you used the search feature before posting, you would have found a number of topics covering this question. The Navbar which is the navigation section you're using, does not allow a parent menu item to be linkable, it acts as a anchor, which upon click opens your sub menu. The Navbar section is based on Bootstrap who designed their menu system this way.

If you do not like this functionality and want your parent menu items to act as links instead of anchors, I recommend you replace the navbar section with Nav Classic.


Please search our forums, before posting!

Share this post


Link to post
Share on other sites
WebWerx

Thanks Danny. I did search - apparently for the wrong thing. I get it now. Your feedback is appreciated. I knew that it was something like this. Just couldn't get my head around things as I was pretty pooped ( :sleep: ) when I posted my question. 

I am wondering if there would be any way to change menu's behaviour from anchor to link? Or do I have to go back to Classic if I wish to do so?

 

:zoro:

Share this post


Link to post
Share on other sites
James B

Hi there,

 

Unfortunately there's no option to change anchor from menu to link that I'm aware of, not without re-writing the section code. Without editing the code the classic nav is the easiest option. 


Kindly search the forum and read the documentation before posting. It will help you resolve many issues.

For CSS help be sure to check out W3Schools first and be sure to download FireBug for FireFox for troubleshooting.

James B

Share this post


Link to post
Share on other sites
WebWerx

Hi there,

 

Unfortunately there's no option to change anchor from menu to link that I'm aware of, not without re-writing the section code. Without editing the code the classic nav is the easiest option. 

Thanks James... Had to ask..

 

It's time for you to go and grab a beer!

 

:zoro:

Share this post


Link to post
Share on other sites
James B

:-) Have a great weekend


Kindly search the forum and read the documentation before posting. It will help you resolve many issues.

For CSS help be sure to check out W3Schools first and be sure to download FireBug for FireFox for troubleshooting.

James B

Share this post


Link to post
Share on other sites
WebWerx

:-) Have a great weekend

Always!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this  

  • Similar Content

    • russe-intensif
      By russe-intensif+
      Hi team,
      checking my site today, i'm surprised to see my MegaNav all in bottom of the pages, while it's in header.
      After getting to change it in couple of pages onto Template part (too time consuming !), i'm desperate and ask you for help :-)
      apprendre-le-russe-avec-ania.fr
      Thank you in advance !

    • dwpoyner
      By dwpoyner+
      Not sure exactly what is causing the issue. For some reason, why you view my site on mobile, the menu does not show up. It will pop up, but it is black. You can check it out here: http://dev.caryfbc.org. I'm also attaching a screenshot where I shrunk my browser down. Any suggestions?

    • khat
      By khat+
      I think I may have installed pagelines pro incorrectly, and then used features incorrectly. I installed first platforms framework theme and then the child, thinking I could do setup for child later. I tried to set up a background image, and tried custom css feature in pagelines dashboard. I had mistakes in my css, and just thought that if I deleted the info in the css custom feature in pagelines dashboard that the new information would overwrite the old info. The background image didn't respond at all, probably because I didn't have the child directory renamed. I then tried to use the LSS plugin to create css and added more css, possibly, somewhere -sigh-. I never did change the background image and get it placed properly. I used a workaround and in nested containers I placed a background image which worked well enough, so I moved on to try to create my nav bar/ menu bar. When I go to the Menus panel, there is NO area where I can place a menu on a page. I have read and reread and re- re- reread the instructions for placing a menu. I've used the pagelines editor to place a menu, however only HOME shows up. I've been at this for many hours. I've since uninstalled all of my pagelines items and reinstalled, thinking that it would restore all my changes to default, but no, it is still all there, with all my unresolved issues. I am completely at a loss as to what to do next.
    • bnapoli
      By bnapoli+
      http://731.34b.myftpupload.com/ this website is using the NavPro navigation in Platform 5. It has a lot of menu items, so it breaks to two lines when the window is sized down. What is the media query to make the navigation either a) switch to "mobile mode" at a higher width, or b ) expand the nav into two lines. Thanks
    • Jarek
      By Jarek+
      How to make the Impulse menu sticky?
      Here is a site that seems like it is doing just that: http://www.manhattanperiodontist.com/
      Here is the site I am working on: http://boeriu.digitalvector.com/ 
      I have no problem showing the menu at the bottom, but when scrolling up it does not stick.  I tried to add Nav Pro menu but when I do that, it just shows on top and no matter what I try is not working as I want it to.
      Any suggestions?
×