Jump to content
mattpato

Issue With "Fixed" Nav Bar On Mobile Devices

Recommended Posts

mattpato

Hi, 

I have been trying to fix this for a while now and have had no success. 

 

I have the fixed navigation bar activated on the site, however when you open up the site on a mobile for example on an iPhone and zoom in on the page, the "Fixed" nav is not fixed at all and ends up taking up 80% of the screen blocking the content. 

 

Here is my site: www.ijailbreakthis.com 

 

I have added no custom CSS to the fixed nav, so not sure what is going on. 

 

Please help, thanks in advance. 

Cheers, 
Matthew 

 

 

Share this post


Link to post
Share on other sites
James B

Hi Matthew

 

The site seems to be set to responsive in the layout editor, the entire page is acting responsivly except for the div labelled 'my-add-image'. Has this been added as a hook? If so you'll need to make sure the media is added so it acts responsively (using a % width rather than a static px width) so it resizes with the screen. The navbar seems to be moving in line with the full width of the content, its the add above which is keeping the page at a larger size. 


Kindly search the forum and read the documentation before posting. It will help you resolve many issues.

For CSS help be sure to check out W3Schools first and be sure to download FireBug for FireFox for troubleshooting.

James B

Share this post


Link to post
Share on other sites
mattpato

Sorry, that just confused me... could you explain to me again what I need to do? 

Share this post


Link to post
Share on other sites
mattpato

I have added :

 

.top_ad{
width: 100%;
}
 

 

But the fixed nav is still not working right. 

Share this post


Link to post
Share on other sites
mattpato

Even if the div labelled 'my-add-image' is removed the top fixed nav still does not work correctly. 

Share this post


Link to post
Share on other sites
Rob

Hi,

 

I just looked at your site on an Android (Samsung Galaxy SIII), and zoomed in and out.  The fixed nav did not occupy any more space than it should. So I suspect that it needs some browser specific CSS.   We have a free plugin for that called Browser Specific CSS found at Dashboard > PageLines > Store > Plugins > Top Free.

 

I did take note that after zooming back, the fixed nav bar did shift to the right, remaining there, but it did not block any content. The problem I noticed with that is simply that the navigation disappeared off the fixed nav.  This could be the result of some custom CSS or a plugin conflict.


Former PageLines Moderator, Food Expert and Raconteur

Share this post


Link to post
Share on other sites
mattpato

Thanks for the comments, I have just tested on an iPad and the fixed nav is perfect (zoomed and normal). It just seems to be iPhone?

 

What specific CSS do I need to add? 

Share this post


Link to post
Share on other sites
mattpato

Yeah I have it installed, but I can find what I need to know. To be honest I am not even sure what I am looking for. 

Share this post


Link to post
Share on other sites
mattpato

Thanks I found that, but what I am saying is that I am not sure what needs to be added to make the fixed nav stop doing this. We have figured out that it seems to be effecting the iPhone only, so it needs a .iphone css class adding but what needs adding before it? 

Share this post


Link to post
Share on other sites
Rob

Honestly, I have no idea.  Do you use Firebug for Firefox or Chrome's Inspection Tool? Either of those should point you to the element that needs a solution.


Former PageLines Moderator, Food Expert and Raconteur

Share this post


Link to post
Share on other sites
mattpato

Yes I have it and am using it, however still have no idea what CSS code is needed to prevent this. 

Share this post


Link to post
Share on other sites
mattpato

Getting to the point now where the fixed nav is becoming more hassel than it is worth. What is the reason that it is doing this, have others had the same issue? 

Share this post


Link to post
Share on other sites
Rob

I haven't seen this issue come up before.  It could be a plugin conflict or a conflict with CSS (either custom or from a plugin).  It's very hard to tell.  I'd recommend deactivating your non-PageLines plugins, to see if the issue resolves.  Reactivate each, one at time, checking after each reactivation if the problem recurs. When it does, the last activated plugin is the problem.


Former PageLines Moderator, Food Expert and Raconteur

Share this post


Link to post
Share on other sites
mattpato

I have deactivated all plugins and it is still an issue... grrr. 

Share this post


Link to post
Share on other sites
Rob

I will alert our developers to see if they can identify the issue. Thanks for your patience.


Former PageLines Moderator, Food Expert and Raconteur

Share this post


Link to post
Share on other sites
mattpato

No worries, if you could please keep me in the loop and let me know where we are and if you need me to do anything. If you try to write a comment on a post the fixed nav drops down to the comment field and wont go away! 

Share this post


Link to post
Share on other sites
Rob

As soon as the developers have a chance to read through this thread, they'll either reply directly or answer me.  Either way, you'll be kept in the loop. Meanwhile, don't deactivate it, so they can see what it's doing.


Former PageLines Moderator, Food Expert and Raconteur

Share this post


Link to post
Share on other sites
mattpato

Thanks, have we managed to get anywhere with this yet?

Share this post


Link to post
Share on other sites
mattpato

Hi guys, could someone please fill me in with any developments? 

Share this post


Link to post
Share on other sites
James B

Evening, I've checked with Rob for you, he's not heard back from the developer team yet though.

 

Checking your site this evening the navbar seems to be stretching the full width of the site now on the iphone. http://screencast.com/t/nD9fMa7U

 

Even when zoomed in I'm seeing it stretch right out to the edges of the screen - http://screencast.com/t/FCRA9kPr

 

I can't see that div with the 'my-add-image' id anymore, did removing that resolve the layout?


Kindly search the forum and read the documentation before posting. It will help you resolve many issues.

For CSS help be sure to check out W3Schools first and be sure to download FireBug for FireFox for troubleshooting.

James B

Share this post


Link to post
Share on other sites
mattpato

Hi thanks for checking back in. 

 

I have removed the fixed nav and replaced it with SaleBar for now. However when you try to write a comment on one of the blog posts the fixednav/sale bar still drops off and gets stuck in the comments box... see image > http://www.screencast.com/t/gGP0ujP1wK

 

This also happens with the fixed nav. 

 

Removing the 'my-add-image-' has played no effect at all. 

 

Cheers. 

Share this post


Link to post
Share on other sites
James B
Hi there, ok I can see it happening in the comments box on the iphone. It's strange as I 
can't get it to replicate on mine. 

Try using the below css to see if this will force the width and edit the font size on the 
iphone to get it to fit all in one line full width. 

/* iPhone [portrait + landscape] */

@media only screen and (max-device-width: 480px)

{ .pl-salebar .sale-text {font-size: 9px;} }

 

/* iPhone [portrait + landscape] */

@media only screen and (max-device-width: 480px)

{ .pl-salebar {width:100% !important;} }

 

Let us know if that has any effect.

 


Kindly search the forum and read the documentation before posting. It will help you resolve many issues.

For CSS help be sure to check out W3Schools first and be sure to download FireBug for FireFox for troubleshooting.

James B

Share this post


Link to post
Share on other sites
mattpato

Hi thanks for this, I have added the above CSS and it seems to have improved the zoom issue a little however the problem with the comments is still happening. 

 

Fixed nav drops off and gets stuck there when you try to write a comment. 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


  • Similar Content

    • glyph.marketing
      By glyph.marketing+
      Hello, I am having a problem similar to that experienced by Michael Kummer here. We have pages that show this automatic scrolling issue (examples here and here) and it is sufficiently annoying that we have seen customers bounce while trying to convert. Strangely, it only happens at specific resolutions, so it can be difficult to reproduce. In general we can only consistently reproduce it on a 4k resolution with a browser width between 1517 and 1536px. 
      Thanks to Michael Kummer's help we were able to set the overflow-anchor property to none in the entire body, which fixed the issue as far as we can tell, but also obviously disabled scroll anchoring for the whole site. I tried applying it to the specific element that looked like it was being reloaded, which was the PL Meganav extension, but that was unsuccessful. 
      Can anyone help us figure out which element or ID we can apply this property to, so that we can fix the scrolling issue but not disable scroll anchoring for the entire site?
      Thank you - 
      Glyph Language Services
    • chamois_blanc
      By chamois_blanc+
      Hello,
      Shouldn't the image PL5 component be using the srcset/picture css directives to pick the correct size for an image? or it does already and I don't know how to use it? Thank you for any advice or enlightenment.
    • Dan Haddock
      By Dan Haddock
      Plugins Active and installed: 
      Akismet Anti-Spam
      Coming Soon Page & Maintenance Mode by SeedProd
      Contact Form 7
      Cookie Law Info
      DMS Professional Tools  
      Enhanced Media Library  
      Flamingo
      Google Analytics for WordPress by MonsterInsights
      Google XML Sitemap
      Jetpack by WordPress.com
      Legull 
      Loginizer   
      MailChimp for WordPress
      PageLines Updater    
      Schema App Structured Data 
      Sucuri Security - Auditing, Malware Scanner and Hardening
      Uber reCaptcha    
      Yoast SEO
      Wordpress Version: 4.8.1
      Pagelines Version: 2.2.4
       
      Good Evening/Afternoon or Morning, 
      I am running into a problem with CSS styling not applying inside of most browsers (Safari, Firefox) when I am logged in to wordpress, and all browsers that I have tested when I am logged off and the site has been made public (Chrome, Firefox and Safari).
      As a result, I have managed to identify the probable cause. It looks as though these browsers are refusing to render my sites compiled CSS file due to it being a HTTP URL rather than HTTPS.
      I have attempted to change this URL to HTTPS in my browser, however it brings back an ERROR: File not found page - https://www.shortfilmblog.com/wp-content/uploads/pagelines/compiled-css-core-1505847507.css
      What would you suggest in this regard? Would this be resolvable from your end?
      Happy to provide any further details required.
    • Borries
      By Borries+
      I know this is not an easy problem. Maybe there is a easy solution.
      I have tryed to uses the existing solution, that I have found in the forum
      I changed the colours of my nav (simple nav) and the hover effect (a. hover).
      I really tryed to highlight the active/used link in the nav but I cant figure it out.
      I want it to be black when active.
      Any help would be appreciated. Thanks.
      http://www.marcborries.de  nav link: "Sinn & Selbst" 
    • Michael Kummer
      By Michael Kummer+
      Hi guys,
      every since Chrome introduce scroll anchoring (see chrome://flags) blog posts on my page start scroll automatically as soon as the user scrolls down a bit. It is super annoying and I don't know exactly what triggers the incompatibility with Chrome's latest feature that is supposed to improve usability.
      Since I don't know what causes it (Pagelines, or a Plugin), I would like to disable the feature using a CSS override that Google describes as follow:
      "Scroll anchoring aims to be the default mode of behavior when launched, so that users benefit from it even on legacy content. A CSS property overflow-anchor can disable scroll anchoring in part or all of a webpage (opt out), or exclude portions of the DOM from the anchor node selection algorithm. This property supports the following values when applied to an element E:
      overflow-anchor: auto (the default value) declares that the DOM subtree rooted at E is eligible to participate in the anchor node selection algorithm for any scrolling box created by E or an ancestor of E. overflow-anchor: none declares that the DOM subtree rooted at E is not eligible to participate in the anchor node selection algorithm for any scrolling box created by E or an ancestor of E." Do you guys happen to know how to use that property with the ROOT element so it applies to the whole page?
      Thanks
      Michael 
×