Jump to content

Archived

This topic is now archived and is closed to further replies.

eglashcreative

Modal Not Working - Section Ordering

Recommended Posts

eglashcreative+    2
eglashcreative

Hi all - 

 

I'm positioning a new newsletter-signup element in the subheader (using ContentBox) using a modal popup.

 

http://creationok.com/our-team/

 

The problem is that it's greyed out - the lightbox doesn't operate over the Crackbar. In fact, you can see the Crackbar, outside of the lightbox, on top of it. I'm wondering what your advice is for positioning the element so that it pops out in front, while (hopefully) keeping the modal in the subheader.

 

I'm wondering if it's a problem with the Pagelines template section ordering.

 

Thanks!


Joe Eglash

Eglash Creative

Share this post


Link to post
Share on other sites
James B    436
James B

Hi

 

If you remove the crackbar does it operate normally? I would think it's a z-index issue, try adjusting the z-index. The below seems to effect it, but you might have to tweak it a bit.

.modal-backdrop {
    top: 0;
    z-index: 14;
}

Kindly search the forum and read the documentation before posting. It will help you resolve many issues.

For CSS help be sure to check out W3Schools first and be sure to download FireBug for FireFox for troubleshooting.

James B

Share this post


Link to post
Share on other sites
eglashcreative+    2
eglashcreative

Works great. It should've occurred to me, but I was thinking that z-index wouldn't affect it unless the navbar (Crackbar) wasn't in front. I was wrong. Thanks, James.


Joe Eglash

Eglash Creative

Share this post


Link to post
Share on other sites
James B    436
James B

Hey Joe,

 

You're welcome, glad it worked :-)


Kindly search the forum and read the documentation before posting. It will help you resolve many issues.

For CSS help be sure to check out W3Schools first and be sure to download FireBug for FireFox for troubleshooting.

James B

Share this post


Link to post
Share on other sites
agent654l    2
agent654l

Having similar issue with modal popup in DMS - you can see popup lightbox functionality but entire screen greyed-out without modal box focus z-index floating above background. ideas? I'm trying to place HTML in footer but even I try short code in main content post, still same problem.

Share this post


Link to post
Share on other sites
Danny    1,327
Danny

agent654l - This topic is resolved. Therefore, can you create new topic and provide a link to your site so we can see the issue first hand please.


Please search our forums, before posting!

Share this post


Link to post
Share on other sites

  • Similar Content

    • Grant Turck
      By Grant Turck+
      Navbar Broken on All Devices When Not Logged Into Wordpress. See screenshots attached from mobile. What is causing this issue and how do I fix? Site is venicepride [dot] org.


    • PierreFF
      By PierreFF+
      Hello, 
      I have an issue with NavPro on mobile when the link of the menue is on the same page. 
      Here is my website: http://foundersofthefuture.co
      The isssue comes from the fact that in my menue most of the items send somewhere else on the same page using anchor link (eg. #container_u788888). 
      This works well on desktop but on mobile, nothing happens when clicking on the link. One of the link of the menue of the homepage "France" sends to another page of the website and this one works well even on mobile. 
      I am using the Pagelines framework theme and also used a wordpress plugin (jQuery Smooth Scroll) for smooth scrolling . 
      Thanks in advance for your help and let me know if I need to provide more information. 
      Best,
      Pierre
    • tristanrodgers
      By tristanrodgers+
      Hi there!
      I'd love to have some social media buttons in my navbar like my online-shop has!
      http://mc1r-magazine.com/
      Can someone explain me how to create them? I tried a lot but don't know how to realize them...
      Greetings from Germany,
      Tristan
    • jeomiland
      By jeomiland+
      Hi guys. Just now trying out Platform 5. I like the reletive simplcity of the new interface but there are things I'm used to in DMS that I'm not seeing yet in 5. Is there a good manual, documentation, video series about some of the basics?
      In particular, I've got a simple navigation menu, created the standard way in WP menus section with several top level parents, then 3-4 children menu items below a couple parent items. Have them moved to the right to create the standard parent-child relationship but all I see on the page is the parent level items - no dropdown!. So I changed themes from Platform5 to the standard 2015 default theme and now I see absolutely no menu at top, except for the mobile (hamburger?) icon.
      In DMS, one had Navi and Navbar, etc sections and each would work differently and give different results. How do you work the menu system in 5? And how get different results ?
      thanks
    • nizami
      By nizami+
      I have a problem at http://kambo.world. Using navbar for the main site navigation. It works fine in normal/desktop mode [first screenshot], using the WP Menu I have specified. But in hamburger mode it seems to do its own thing, picking a few pages at random [second screenshot] A fix for this greatly appreciated! 
       


×