Jump to content
Sign in to follow this  
helvetik_a

header image trough header+content

Recommended Posts

helvetik_a

Hi,

I need to center my background image behind the navigation and content. I tried with this code:

 

#branding .content {
   <span class="searchlite">background</span>-<span class="searchlite">image</span>: url('http://wp.tanzprojekte.ch/wordpress/wp-content/uploads/2013/05/header_schrift_01.jpg');
   <span class="searchlite">background</span>-position: center;
   <span class="searchlite">background</span>-repeat: no-repeat;
   <span class="searchlite">background</span>-height:600px;
   <span class="searchlite">background</span>-width: 995px;
   <span class="searchlite">background</span>-left: 300px ;
   }

But the image remains cutted of. I use a full width layout and it has to be responsive. I tried also with a z-index position...but it did not work out....

Can you help me?

Thx Corina

 

My site:

 

http://wp.tanzprojekte.ch/wordpress/kursangebot/

 

How it has to be...

 

 

http://imgur.com/IRPCjpl

 

Share this post


Link to post
Share on other sites
Rob

Hi Corina,

 

The CSS you're using is incorrect. It mixes stylesheet CSS with inline CSS, which is not the best way to achieve results.  I'll recommend you study the resources here to learn more about CSS:  http://w3schools.com/css/

 

You should apply the background to the site using our internal settings, found at Dashboard > PageLines > Site Options > Color Control.  There, you can upload a background image, without CSS, and set the vertical alignment and horizontal alignments correctly, without custom coding.

 

As for the brand logo, that will require some CSS, but the method of doing that is probably best achieved with a plugin we offer called Sexy Snips, found in Dashboard > PageLines > Store > Plugins > Top Free.  Just install and activate it, and Sexy Snips will provide you with the CSS to center a branding image.


Former PageLines Moderator, Food Expert and Raconteur

Share this post


Link to post
Share on other sites
helvetik_a

Hi Rob. Thx for your response.

Css is not a problem, i'll correct the code...I tried before the background image option, but i do not liked it at all. Infact, it is not a usual background...more a header background entering in the content area.

when i scroll down the page, the bg-image has to scroll up and to disappear and with this method i did not found out the css selectors of the background...

I will try with the sexy snips and let you know.

 

Thx

Corina

Share this post


Link to post
Share on other sites
Rob

Keep us posted and let us know if you need more help.


Former PageLines Moderator, Food Expert and Raconteur

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this  

  • Similar Content

    • Michael Kummer
      By Michael Kummer+
      Hi guys!
      I have noticed that my primary sidebar becomes intermittently invisible when browsing through various blog articles on michaelkummer.com/blog.
      See:
      https://www.dropbox.com/s/z646sgoa3mfjl1j/Screenshot 2018-07-12 15.57.46.jpg?dl=0 and https://www.dropbox.com/s/vdledzzgginvwgv/Screenshot 2018-07-12 15.57.57.jpg?dl=0
      Upon refresh, the sidebar appears. I have been using the following CSS code to hide the sidebar on mobile without any issues. 
      @media only screen and (max-width: 993px) {
      /* hide sidebars */
           .plsb {
              display: none !important;
          }
      }
      I tried to add the following CSS to force the sidebar to show on screens that are wider than 994 pixels but to no avail. Any clue what could be causing this issue?
    • Michael Kummer
      By Michael Kummer+
      Hi guys!
      I am using the LESS/CSS Pagelines extension and tried to add the following code to make use of FontAwesome:
      a.c2a:before {
          content: "\f07a\00a0";
          font-family: "Font Awesome 5 Pro";
          Font-weight: 900;
          font-style: normal;
          font-weight: normal;
          text-decoration: inherit;
          padding-left: 4px;
      }
       
      The issue is that as soon as I have the CSS via the Custom Styling text box, Pagelines (or the extension) strips out the backslashes (\). As a result, I had to abandon the CSS/LESS extension and instead add all my CSS code to a separate .css file.
      Is there a fix or workaround for this?
      Thanks
      Michael
    • glyph.marketing
      By glyph.marketing+
      Hello, I am having a problem similar to that experienced by Michael Kummer here. We have pages that show this automatic scrolling issue (examples here and here) and it is sufficiently annoying that we have seen customers bounce while trying to convert. Strangely, it only happens at specific resolutions, so it can be difficult to reproduce. In general we can only consistently reproduce it on a 4k resolution with a browser width between 1517 and 1536px. 
      Thanks to Michael Kummer's help we were able to set the overflow-anchor property to none in the entire body, which fixed the issue as far as we can tell, but also obviously disabled scroll anchoring for the whole site. I tried applying it to the specific element that looked like it was being reloaded, which was the PL Meganav extension, but that was unsuccessful. 
      Can anyone help us figure out which element or ID we can apply this property to, so that we can fix the scrolling issue but not disable scroll anchoring for the entire site?
      Thank you - 
      Glyph Language Services
    • chamois_blanc
      By chamois_blanc+
      Hello,
      Shouldn't the image PL5 component be using the srcset/picture css directives to pick the correct size for an image? or it does already and I don't know how to use it? Thank you for any advice or enlightenment.
    • chamois_blanc
      By chamois_blanc+
      Please see screenshot. I think it should be self-explanatory.

×