Jump to content
Jarrod H

WooCommerce Template

Recommended Posts

Jarrod H    4
Jarrod H

I just recently switched from jigoshop to woocommerce.  I noticed that know after setting everything up my products wont show up.  I have the  shop page page pointing to http://www.rockfordartdeli.com/deli-case/

 which is my shop page.  Does the default template page go to product archives instead of a normal template?  Did i miss a step into making this function properly? 

 

Thanks,

 

 

Share this post


Link to post
Share on other sites
ellenmva    112
ellenmva

This happened to someone who was using the WooCommerce for Pagelines plugin and they ended up creating a new page and assigning it as the shop page and it worked. You might want to give that a try and see if the products show up.

 

Also, check the other ecommerce pages like Cart, Checkout, My Account, etc. and make sure the shortcode on those pages says woocommerce_ , not jigoshop_. Right now your Cart page is [jigoshop_cart] should be [woocommerce_cart].

 

Lastly, you may want to use the WooCommerce for Pagelines plugin because once you get the shop page working the products will display in a single column, rather than across and there is css in the plugin that fixes the issue.


Ellen Moore

Pagelines Developer

www.elsue.com www.betterdms.com

Share this post


Link to post
Share on other sites
Jarrod H    4
Jarrod H

I tried that a few times with no luck.  Still points says nothing found. http://www.rockfordartdeli.com/store/

 

I have the woocommerce for pagelines plugin installed already.  Thanks

Share this post


Link to post
Share on other sites
ellenmva    112
ellenmva

Okay, it looks like the WooCommerce Sections aren't on the Product Archive and Product Templates.  Go to Pagelines --> Drag & Drop click on Templates and Product Archive.  Make sure the section ProductContent is in Active Sections. Then click on the Content Area and make sure ProductLoop is in Active Sections. Do the same on the Product Template.

 

Screenshot_5_12_13_11_43_AM.png

 

 

Screenshot_5_12_13_11_44_AM-4.png

 

Let me know if that works.

 

Ellen


Ellen Moore

Pagelines Developer

www.elsue.com www.betterdms.com

Share this post


Link to post
Share on other sites
Jarrod H    4
Jarrod H

Wow not sure how i missed that part.  So its getting closer.  http://www.rockfordartdeli.com/store/

  Still none of my products will show up.  They are all visible in the products area should i recreate them?  these are all from my jigoshop store original setup.

Share this post


Link to post
Share on other sites
Jarrod H    4
Jarrod H

Should I delete all these and recreate them?  It looks like it just pulled them into WooCommerce when I added the plugin.

 

http://d.pr/i/E7gv

 

I dont have a ton so its not a huge deal.  Just want to make sure its the correct way before i delete them all and start over.

Share this post


Link to post
Share on other sites
ellenmva    112
ellenmva

Ya, that's weird that they came over -- wonder why they have a paid plugin for that.  Though that still may be the problem. Can you see the individual products on your site?

 

Let's make sure that it has nothing to do with Pagelines. Disable the WooCommerce for Pagelines Plugin and then switch the theme to TwentyTwelve. Then look at your shop page -- do the products show up?

 

If the products are still not there then it is something to do with WooCommerce. I would post on their Community Forum and explain to them that you switched from Jigoshop to WooCommerce and the products are there but not showing on shop page.

 

If the products do show up with TwentyTwelve then maybe something is still not set up with the sections on the Product Archive template.

 

Let me know your result.


Ellen Moore

Pagelines Developer

www.elsue.com www.betterdms.com

Share this post


Link to post
Share on other sites
Jenny    33
Jenny

Please let us know if you still need assistance, otherwise I will close this topic in 7 days. Thanks!


Jenny :: Web designer at Simple Mama (follow me at @simplemamacom)

Check out Share Me, a social sharing add-on for DMS that is super simple to set up.

Share this post


Link to post
Share on other sites
Jarrod H    4
Jarrod H

@Jenny Im pretty sure its all good now.  Just adding new products in.  Thanks

  • Like 1

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


  • Similar Content

    • hibbsy78
      By hibbsy78+
      Anyone having issues with Apple Pay & woocommerce? Before I start with trying to disable plugins one by one I thought I'd check here first!
      I'm having issues with the payment processing part which just times out?
      https://www.hibbslupustrust.org/shop/
       
      Thanks!
    • Paul
      By Paul+
      I have woocommerce store, product shows title and price fine until reduce screen with on a tablet/mobile phone the price and title gets removed?  Any ideas? 
      Here's an example page: https://thelaptopfixers.com/product/operating-system-re-install/
      Try it on both desktop PC browser then resize to mobile/cell phone size!  
      Thanks
    • Jared Smith
      By Jared Smith+
      I haven't figured out how to get the "Sync Loaded Item" option in templates menu of Platform 5 to stay checked. It doesn't give me an option to save settings when I select it, and when I select it then click off the editor, it unselects. Also if I select it before loading a template, it doesn't stay checked there either.  Whats going on?
    • ProCom
      By ProCom+
      I am trying to resolve a few issues. The first one is when I have the Platform 5 activated the product image will not display. However, once I deactivate the plugin the image will appear.  Can someone tell me if there is a article on how to customize the WooCommerce product, and shop pages using PageLines? 
       
       

    • Queue-it
      By Queue-it+
      Hi,
      I created a Pagelines template for a "Post type" post. Whenever creating a new post page it firstly display that template post and I have to manually change it in the scope from "All of type posts " to "Current page". 
      Is there a way to fix that? 
       
       

×