Jump to content

Archived

This topic is now archived and is closed to further replies.

sonaros

Roundabout Auto Play

Recommended Posts

sonaros    0
sonaros

Is there a way to turn off the auto rotate feature or control the speed of the rotation?

Share this post


Link to post
Share on other sites
cmunns    16
cmunns
Yes, there is an option to enable/disable autoplay

Share this post


Link to post
Share on other sites
sonaros    0
sonaros

Where is that option?  The only item I see that may be it is under site defaults/Auto rotate the roundabout panels?  I currently have that unchecked but it is still rotating.

 

Thanks!

Share this post


Link to post
Share on other sites
cmunns    16
cmunns
<p>Perhaps the logic is switched, did you try checking that box to see if it stops it from rotating?</p>

Share this post


Link to post
Share on other sites
sonaros    0
sonaros

Yes, and it did not stop.

Share this post


Link to post
Share on other sites
cmunns    16
cmunns
<p>On my demo site it looks like the options works partially. I did not catch it because it only starts rotating automatically after you clicked a directional arrow. Is your situation similar or does it autorotate regardless ?</p>

Share this post


Link to post
Share on other sites
cmunns    16
cmunns
<p>I've added some callbacks that will fix this issue in v 1.2</p>

Share this post


Link to post
Share on other sites
sonaros    0
sonaros

On my site the roundabout slider auto rotates automatically once the page loads.  I am looking to set for only manual rotation via navigation arrows.

Share this post


Link to post
Share on other sites
cmunns    16
cmunns
<p>Can you please send me a link? I need to check your configuration to make sure it matches my updated demo which is working properly.</p>

Share this post


Link to post
Share on other sites
sonaros    0
sonaros

We are only on a local test server.  Is there another way I can help?

Share this post


Link to post
Share on other sites
cmunns    16
cmunns

well I fixed the problem after duplicating it, but if you are still having the issue I can't assist unless I can see your site.

Share this post


Link to post
Share on other sites
sonaros    0
sonaros

I am still having the issue.  My issue is that their current domain is live and I am building the site on a local server.  Can you modify your hosts file to re-direct the domain to our test server IP address?

Share this post


Link to post
Share on other sites
sonaros    0
sonaros

I have finally soft launched my site and was wondering if you could take a look at this problem again.  It has not been resolved.  I have "Auto rotate the roundabout panels?" unchecked but it still automatically when the page loads.  The site is learn.cid.edu.

 

Thanks!

Share this post


Link to post
Share on other sites
sonaros    0
sonaros

It's been a couple of weeks since I sent this post update but have not heard back.  Have you had a change to look at this problem now that our site is off our test server?

Share this post


Link to post
Share on other sites
cmunns    16
cmunns

This was fixed months ago when this thread was active. As I stated above, I found the problem and did fix it but I'm sure it was some sort of malfunction in the deployment of the product to the then PageLines store. At any rate, I can't update the product since I have nothing to do with PageLines at this point so here is the latest zip of the plugin

 

https://dl.dropboxusercontent.com/u/10661648/roundabout-master.zip

Share this post


Link to post
Share on other sites
anlinares    1
anlinares

Wooohooo!  I *THINK* that did it.  Thanks! 

 

After 3 years of developing with Pagelines, I think that resolves my final issue with with my final Pagelines site.

Share this post


Link to post
Share on other sites
anlinares    1
anlinares

NOOOOOOOO........  It is still doing it........

Share this post


Link to post
Share on other sites
anlinares    1
anlinares

Seems to do it whenever you place your mouse over the image and then move the mouse, without clicking.  The roundabout begins rotating.

 

It does the same thing on  your site - http://adammunns.com/roundabout/

Share this post


Link to post
Share on other sites
sonaros    0
sonaros
This is the part of the section.php that controls the autoplay.  Nowhere do I see where you can just turn if off. 
 
You can pause on hover, drag/drop and when you click on the arrow but nowhere in the code does it say to just stop.
 
$('#rnd_wrap').roundabout({
        childSelector: "div.panel",
responsive: true,
enableDrag: true,
autoplay: <?php echo $autoplay;?>,
          autoplayDuration: 2000,
          autoplayPauseOnHover: true,
shape: "<?php echo $shape;?>",
minOpacity: <?php echo $minOpacity;?>,
minScale: <?php echo $minScale;?>,
btnPrev: 'div.rnd_prev',
btnNext: 'div.rnd_next',
dropCallback: function(){
//stop autoplay on dragDrop
$(this).roundabout("stopAutoplay");
}
});
 
// stop autoplay on next/prev click
$('div.rnd_prev, div.rnd_next').click(function(e){
e.preventDefault();
$('#rnd_wrap').roundabout("stopAutoplay");
});

Share this post


Link to post
Share on other sites
anlinares    1
anlinares

Did you ever figure out a solution?

Share this post


Link to post
Share on other sites

  • Similar Content

    • anlinares
      By anlinares
      Looks like Pagelines and cmunns"] have abandoned support for his products.  A couple of us - @[member="sonaros - have been having an issue for a few months and need a resolution.  We're obviously not using this to develop sites now, but these sites were developed or under development before the switch so we'd appreciate some help with getting this issue resolved.
       
      The roundabout section is rotating (even with auto rotating turned off).  If we can't fix this problem I at least need to get it slowed down.  It gives me whip lash as is.
       
      See it on the site at: http://holleyporterwright.com/
       
      See more details about our issues here: http://forum.pagelines.com/topic/28392-roundabout-error-autoplay-on-click/
    • anlinares
      By anlinares
      I am using the brandnav section in my header and have the roundabout section at the top of my home page.  When I scroll over drop down menu items, the the sub menu appears behind the roundabout section.  I need it to be in front so that visitors can actually see the menu.  I know the slides already have z-indexes applied but I tried applying z-indexes to the brandnav section, the nav itself, the roundabout, and the page without success.  Help, please!
    • anlinares
      By anlinares
      Hi!  I would like my roundabout section to only rotate when clicked.  But once it is clicked, it begins auto rotating.
       
      Using Roundabout v1.2
       
      http://ashleylinares.com/hpw
    • sonaros
      By sonaros
      Is there a way to take the roundabout headline and content and create an overlay on the right hand side of each slide?
       
      Thanks!
×