Jump to content
quinntinm

Accordion shortcode not working

Recommended Posts

quinntinm    4
quinntinm

Hi there.

I have tried some shortcode i found on the pagelines site but it just doesn't seem to work.

 

[pl_accordion name="accordion"][pl_accordioncontent name="accordion" number="1" heading="Tile 1" open="yes"]

Content 1

[/pl_accordioncontent]

 

[pl_accordioncontent name="accordion" number="2" heading="Title 2"]

<img class="pl-imageframe" src="" alt="" />

[/pl_accordioncontent]

 

[/pl_accordion]

 

 

 

 

Is there something i need to install first?

 

 

Thanks.

 

 

Share this post


Link to post
Share on other sites
Danny    1,327
Danny

Hi,

 

Can you provide a link to the site in question and also where have added the accordion code ?


Please search our forums, before posting!

Share this post


Link to post
Share on other sites
Danny    1,327
Danny

OK, you're using PageLines Framework 2.3.3, I recommend you perform a backup and then update to the latest version, which is 2.4.1.

 

If this doesn't resolve your issue, I suggest disabling all non-PageLines plugins and see if that resolves your issue.


Please search our forums, before posting!

Share this post


Link to post
Share on other sites
Danny    1,327
Danny

Thanks for informing us the issue has been resolved, I would recommend using our Carousel section instead of the plugin.


Please search our forums, before posting!

Share this post


Link to post
Share on other sites
Rob    547
Rob

Hi Benz, could you paste the code you used? Its very likely there's some missing operand.


Former PageLines Moderator, Food Expert and Raconteur

Share this post


Link to post
Share on other sites
benz_admin    0
benz_admin

Hi Rob, thanks for your reply.

This is my code:

 

 

[pl_accordion name="SLK-POINT"]

[pl_accordioncontent name="SLK-POINT" number="1" heading="+ ABRUZZO"] elenco sedi [/pl_accordioncontent]

[pl_accordioncontent name="SLK-POINT" number="2" heading="+ BASILICATA"] elenco sedi [/pl_accordioncontent]

[pl_accordioncontent name="SLK-POINT" number="3" heading="+ CALABRIA"]elenco sedi[/pl_accordioncontent]

[pl_accordioncontent name="SLK-POINT" number="4" heading="+ CAMPANIA"]elenco sedi[/pl_accordioncontent]

[pl_accordioncontent name="SLK-POINT" number="5" heading="+ EMILIA-ROMAGNA"]elenco sedi[/pl_accordioncontent]

[pl_accordioncontent name="SLK-POINT" number="6" heading="+ FRIULI VENEZIA GIULIA"]elenco sedi[/pl_accordioncontent]

[pl_accordioncontent name="SLK-POINT" number="7" heading="+ LAZIO"]elenco sedi[/pl_accordioncontent]

[pl_accordioncontent name="SLK-POINT" number="8" heading="+ LIGURIA"]elenco sedi[/pl_accordioncontent]

[pl_accordioncontent name="SLK-POINT" number="9" heading="+ LOMBARDIA"]elenco sedi[/pl_accordioncontent]

[pl_accordioncontent name="SLK-POINT" number="10" heading="+ MARCHE"]elenco sedi[/pl_accordioncontent]

[pl_accordioncontent name="SLK-POINT" number="11" heading="+ MOLISE"]elenco sedi[/pl_accordioncontent]

[pl_accordioncontent name="SLK-POINT" number="12" heading="+ PIEMONTE"]elenco sedi[/pl_accordioncontent]

[pl_accordioncontent name="SLK-POINT" number="13" heading="+ PUGLIA"]elenco sedi[/pl_accordioncontent]

[pl_accordioncontent name="SLK-POINT" number="14" heading="+ SARDEGNA"]elenco sedi[/pl_accordioncontent]

[pl_accordioncontent name="SLK-POINT" number="15" heading="+ SICILIA"]elenco sedi[/pl_accordioncontent]

[pl_accordioncontent name="SLK-POINT" number="16" heading="+ TOSCANA"]elenco sedi[/pl_accordioncontent]

[pl_accordioncontent name="SLK-POINT" number="17" heading="+ TRENITNO ALTO ADIGE"]elenco sedi[/pl_accordioncontent]

[pl_accordioncontent name="SLK-POINT" number="18" heading="+ UMBRIA"]elenco sedi[/pl_accordioncontent]

[pl_accordioncontent name="SLK-POINT" number="19" heading="+ VENETO"]elenco sedi[/pl_accordioncontent]

[/pl_accordion]

Share this post


Link to post
Share on other sites
Rob    547
Rob

You have breaks in the code.

If you wraps the code in [pl_raw] tags it will strip out the breaks like this

http://screencast.com/t/EOCDbZjwL


Former PageLines Moderator, Food Expert and Raconteur

Share this post


Link to post
Share on other sites
Rob    547
Rob

Okay, remove the open="yes" and wrap the whole code in pl_raw.


Former PageLines Moderator, Food Expert and Raconteur

Share this post


Link to post
Share on other sites
Rob    547
Rob

Pesaro

 

if you create a new admin level user for robert@pagelines.com, I'll take a look as soon as I can.


Former PageLines Moderator, Food Expert and Raconteur

Share this post


Link to post
Share on other sites
Rob    547
Rob

Nothing yet.


Former PageLines Moderator, Food Expert and Raconteur

Share this post


Link to post
Share on other sites
Rob    547
Rob

Hi,

 

There is nothing wrong with the shortcode.  There must be a bad plugin or some bad CSS in your site. I copied your code and tested it on my own site. See this example.

 

http://www.epicurus.com/members/test-modal

 

Try deactivating the non-PageLines plugins to see if the problem resolves.


Former PageLines Moderator, Food Expert and Raconteur

Share this post


Link to post
Share on other sites
benz_admin    0
benz_admin

Ok, I solve it.

For everybody who will have the same problem, it was a conflict with a javascript code that was set on
Pagelines > Site Option > Custom code > Headerscripts Code

 

Thanks a lot to Rob for your help.

Share this post


Link to post
Share on other sites
Rob    547
Rob

No problem!


Former PageLines Moderator, Food Expert and Raconteur

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


×