Jump to content
Sign in to follow this  
brighteyes

Submit Button #e5e5e5 Space - Formidable Form

Recommended Posts

brighteyes    0
brighteyes

Good Day,

 

You were quick to help me with a prior question and couldn't find this next question in the forum search so thought I would ask for help since I'm a new Paglines Framework customer and amatuer with Wordpress. 

 

I'm now using the Formidable Forms plugin and when I apply the plugin to the site with Pagelines activated, I get a large white space underlying the submit button.  I don't get this if Pagelines is deactivated.  With my WhiteHouse Pro, I was able to remove the .button CSS code in the wp_core.css file which worked.

 

Using Google Chrome Dev Tools (I'm new to this tool as well), I believe I found the source of the CSS code that needs to be commented out.  see attached.  I just can't seem to find the actual file to make the change at.  Are you familiar with this compatibility issue between Formidable and Pagelines Framework?  Which file and where can I make changes in Pagelines Framework to the main CSS?   Appears style.css isn't accessible on the server (FTP) or through Editor; though I'm not sure if this style.css is where the code is...?

 

Thank you!

Share this post


Link to post
Share on other sites
James B    436
James B

Hi there,

 

If you're using the Pagelines Framework all css changes can be made in Pagelines>site options>custom code. Any code placed in there will override the default options. We don't advise editing any core files within the framework as the changes will be overwritten on update.

 

You can see the different customization options for the Framework here - http://support.pagelines.me/docs/customization/customization-methods/

 

I've not heard of any issues relating to that form plugin with the framework. It could be there's additional padding/margins under the submit button that need to be removed to reduce the white space.


Kindly search the forum and read the documentation before posting. It will help you resolve many issues.

For CSS help be sure to check out W3Schools first and be sure to download FireBug for FireFox for troubleshooting.

James B

Share this post


Link to post
Share on other sites
brighteyes    0
brighteyes

Thanks James for helping with this!  I'm still struggling.  I've looked at the custom code area at Pagelines>site options>custom code and then also checked out the customization plugin as well.  One side note I noticed in the custom code area is that I needed to Save twice before the changes took place.

 

Again, the field started existing when Pagelines was activated but appeared normal prior.  I may be wrong but I believe this code here below in the CSS is what needs to be changed to remove the underlying field with the Submit button.  This is similar to what I removed in wp_core.css with Whitehouse Pro which worked. 

 

If this area is to overwrite code only, how would I simply delete code instead.  I was thinking of maybe trying to comment out the area related to background but it appears to revert any color changes back to default css.  I also tried or think I attempted correctly to add Opacity code to see if that would simply make it transparent. (I'll leave it in the code shown below) No luck if I did it right.  I'm quite novice with coding.  :-)

 

Any thoughts on how to customize to remove the area?   Thanks!!

 

 

 

input[type="submit"]:hover,
.submit:hover,
input[type="button"]:hover,
.button:hover,
input[type="reset"]:hover,
.reset:hover {
  opacity:0.9;
  color: #000000;
  text-decoration: none;
  text-shadow: 0 1px 0 rgba(255,255,255,0.5);
  border: 1px solid #aeaeae;
  background-color: #e5e5e5;
  background-image: -moz-linear-gradient(top,#f3f3f3,#cfcfcf);
  background-image: -ms-linear-gradient(top,#f3f3f3,#cfcfcf);
  background-image: -webkit-gradient(linear,0 0,0 100%,from(#f3f3f3),to(#cfcfcf));
  background-image: -webkit-linear-gradient(top,#f3f3f3,#cfcfcf);
  background-image: -o-linear-gradient(top,#f3f3f3,#cfcfcf);
  background-image: linear-gradient(top,#f3f3f3,#cfcfcf);
  background-repeat: repeat-x;
  filter: progid:DXImageTransform.Microsoft.gradient(startColorstr='#f3f3f3', endColorstr='#cfcfcf', GradientType=0);
}
input[type="submit"]:active,
.submit:active,
input[type="button"]:active,
.button:active,
input[type="reset"]:active,
.reset:active {
  opacity:0.9;
  color: #000000;
  text-shadow: 0 1px 0 rgba(255,255,255,0.5);
  border: 1px solid #8e8e8e;
  background-color: #bdbdbd;
  background-image: -moz-linear-gradient(top,#afafaf,#d3d3d3);
  background-image: -ms-linear-gradient(top,#afafaf,#d3d3d3);
  background-image: -webkit-gradient(linear,0 0,0 100%,from(#afafaf),to(#d3d3d3));
  background-image: -webkit-linear-gradient(top,#afafaf,#d3d3d3);
  background-image: -o-linear-gradient(top,#afafaf,#d3d3d3);
  background-image: linear-gradient(top,#afafaf,#d3d3d3);
  background-repeat: repeat-x;
  filter: progid:DXImageTransform.Microsoft.gradient(startColorstr='#afafaf', endColorstr='#d3d3d3', GradientType=0);
  box-shadow: none;
}

Share this post


Link to post
Share on other sites
James B    436
James B

Pagelines will have its own padding/margins for each section which are set inside the core code, this will differ from other themes or the standard 2012 theme.

 

Looking into your currentl page, that one area has 5-6 areas of padding which will need to be removed to get this type of result - http://screencast.com/t/FTQrSpfPS

 

I'd advise looking into classes like, article, p, respond, hentry, comments, post and postloop as there's various padding and margins insterted within each which will allow to two sections to be brought closer together.


Kindly search the forum and read the documentation before posting. It will help you resolve many issues.

For CSS help be sure to check out W3Schools first and be sure to download FireBug for FireFox for troubleshooting.

James B

Share this post


Link to post
Share on other sites
brighteyes    0
brighteyes

Hello again, the screen shot you linked to is what I currently have.  I'm trying to rid that area around the submit button.

 

I've spent lots of time going through the core css code through Chrome Dev tools as well as learned a few things from W3 because of this but still can't seem to get to the bottom of the source and make the needed change.  I tried putting the form in different page areas too.

 

You mentioned deleting some padding/margin areas... what steps do I take to delete these?

 

After playing with the code I provided earlier in the thread, I'm having doubts that would be the source of the issue.  With it being Active or Hover, no matter what is changed, the 'field' is still there with default color that appears to be #e5e5e5.  I then searched other areas with "button" , "submit" and "e5e5e5" but nothing seems to impact the default field.  Where is the code that places that default field in the submit spot?  Perhaps this is where I need to focus on making it Hidden.

 

www.byomini.com  you can see that it appears to be two buttons when clicking on the difference areas which reflect the gradient color changes.  I just need the smaller submit button to appear, not the larger space/button.

 

Thanks again for your time with this!!!

Share this post


Link to post
Share on other sites
James B    436
James B

Hi there,

 

I've recorded a short screencast for you to see the code. http://screencast.com/t/cTHwUVfHM

 

The yellow areas in the screen preview are the margins, they're attached to the <p> tag so you can remove them with css. I'm not sure how formidable forms is inserted, whether its a shortcode etc, but the reason you're getting two buttons is because <p> that the submit button inside is also given the class .submit. So they're both being colored with the gradient and having the effects applied. If you're able to edit the class for the <p> tag you'll just end up with the small button.

 

If not, you're going to need to play with the css for the .submit class and .button class separately to see if you can get it to work that way. That's going to be difficult to do in firebug as the code is grouped together for the three. The easiest way would be to paste it into the css editor and then begin to take out each class to see which removes the bigger button without affecting the smaller one.


Kindly search the forum and read the documentation before posting. It will help you resolve many issues.

For CSS help be sure to check out W3Schools first and be sure to download FireBug for FireFox for troubleshooting.

James B

Share this post


Link to post
Share on other sites
brighteyes    0
brighteyes

Thank you for the great demo!   Formidable is shortcode based but does have some areas for direct html customization; however, there is not direct html customization for the submit area.  It only has dynamic options for submit settings like, padding, margins, color, etc. 

 

I have reached out to them with your remarks on the conflicted submit class and they have now informed me that they are coming out with a beta this week that will allow html customization for the submit.  I'll check daily and provide an update.  Probably worth waiting for it before trying to attempt the other possible options with submit/button css.

 

P.S.  Meanwhile, I'm going to try out that Jing screencast program you used.  Thanks!

 

(topic on hold for Formidable beta release within week)

Share this post


Link to post
Share on other sites
James B    436
James B

Excellent, that's great news, keep us posted on how you get one, we'll leave this post open for you.


Kindly search the forum and read the documentation before posting. It will help you resolve many issues.

For CSS help be sure to check out W3Schools first and be sure to download FireBug for FireFox for troubleshooting.

James B

Share this post


Link to post
Share on other sites
brighteyes    0
brighteyes

Good Day James!  I was able to install the Formidable beta update "formidable-1.07.0b1" and it resolved the issue.  I didn't have to make any tweaks after installing either.  Thank you very much for your help!!!

 

Side note:  recently, there was an issue with the reCaptcha used by Formidable in that the graphic was abit off with some browsers.  I'm not sure what he root cause was from but the fix found through the Formidable forum is adding this code below to the customized code section in Pagelines which resolved the issue.  Just wanted to share in case someone searches on Formidable through this forum as well.  Thanks again!

 

#recaptcha_response_field {
height: 20px;
}

Share this post


Link to post
Share on other sites
James B    436
James B

Hi there

 

Excellent, that's great news, glad you got it sorted :-)

 

Thank you for posting back with the resolution as well, that will help other users in the future.


Kindly search the forum and read the documentation before posting. It will help you resolve many issues.

For CSS help be sure to check out W3Schools first and be sure to download FireBug for FireFox for troubleshooting.

James B

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this  

  • Similar Content

    • Michael Kummer
      By Michael Kummer+
      Hi guys,
      every since Chrome introduce scroll anchoring (see chrome://flags) blog posts on my page start scroll automatically as soon as the user scrolls down a bit. It is super annoying and I don't know exactly what triggers the incompatibility with Chrome's latest feature that is supposed to improve usability.
      Since I don't know what causes it (Pagelines, or a Plugin), I would like to disable the feature using a CSS override that Google describes as follow:
      "Scroll anchoring aims to be the default mode of behavior when launched, so that users benefit from it even on legacy content. A CSS property overflow-anchor can disable scroll anchoring in part or all of a webpage (opt out), or exclude portions of the DOM from the anchor node selection algorithm. This property supports the following values when applied to an element E:
      overflow-anchor: auto (the default value) declares that the DOM subtree rooted at E is eligible to participate in the anchor node selection algorithm for any scrolling box created by E or an ancestor of E. overflow-anchor: none declares that the DOM subtree rooted at E is not eligible to participate in the anchor node selection algorithm for any scrolling box created by E or an ancestor of E." Do you guys happen to know how to use that property with the ROOT element so it applies to the whole page?
      Thanks
      Michael 
    • wyo22ski
      By wyo22ski+
      Hello,
       
      I'm basically a designer and understand a little on how to change CSS, etc., so please excuse my ignorance...  I recently upgraded to the newest platform from the DMS and my old DMS theme no longer functions.  I'm trying to replace the image slider that my Horizon Photography Theme (Nick Haskins) had created.  The Impulse image slider seemed the closest to what I need, but there are problems.
      It seems the the Impulse section for sliding images defaults to the image width, no the height.  I can change the Impulse stage height and width, but this does nothing to the internal content.  For instance, if I change the height to 200 pixels, the image remains the full width and only shows a cropped section.  I would like the ability to change the Impulse height, and have the image height fit space. 
      I've put this custom CSS in, but again, this only controls the stage height of Impulse:
      .pl-sn-impulse .pl-impulse-cell .cell-wrap, .pl-impulse-container, .owl-stage-outer {
        width: 100%;
      }
       
      Any suggestions welcome.  Thanks 
    • Objectif-Mariage
      By Objectif-Mariage+
      Hello. 
      I have just realized that CSS (Less plugin) , is not working..... I have disable all plugins (except PL CUSTOM LESS and PL5) , and ... it's not working ... 
      It's not the first time. Usually I had trouble with a plugin name Autoptimize , but it's Desactivate now , all memory have been purge, and it's still not working! :-/ So it's not from this plugin. 
      NB : When I am logged on my website, if i go on the black wordpress dashboard bar, go on the PL icon, clic on </> LESS/CSS => then the page suddenly apply the CSS .... But As soon that i reload the page, nothing. I think the problem is that the plugin LESS/CSS does not load properly (if I can say that with my simples words).
      I order to keep the site "good looking" I have temporally copy/paste all my LESS code in a plugin : Script n Styles that apply the LESS/CSS code... but it's not a solution for long time.
      Can someone help me ? Did I do something wrong ? Is it an update ? 
       
      my website : https://www.wedding-photography-minneapolis.com
    • Jason
      By Jason+
      Feel free to delete this post if its not helpful or its just plain wrong.
       
      I though it might be useful to share how I customize the size of the builder. (reduce my eyestrain )
      1 - install stylerbot extension in chrome (stylerbot keeps this css every time you access the url)
       
      2- add this css to stylerbot for the site you are working on
      .CodeMirror {
          font-size: 14px;
          height: 600px;
      }
      .pl-workarea.pl-has-sidebar .pl-workarea-sidebar-container {
          right: 0px;
          width: 500px;
      }
      .pl-workarea.pl-has-sidebar .iframe-container {
          right: 500px ;
      }
       
      change sizes to suit.
       
      Cheers.
    • Jason
      By Jason+
      Hi.
      I can't seem to get the Teamwork section to accept custom css. I am trying to change the padding from 7em to 1em on the splash part
      I have tried
        .pl-sn-teamwork .pl-tw-splash {
          padding-top: 1em;
          padding-bottom: 1em;
        }
       
      This works in chrome inspect but when added to custom css nothing happens.
      I have also tried most of the classes I can see accoiated with this section but again nothng seems to happen.
      Any ideas?
×