Jump to content
Sign in to follow this  
chrisw

Problem uploading a pdf

Recommended Posts

chrisw    0
chrisw

Hi

 

I have recently upgraded to the pagelines framework and just received an error message when uploading a pdf to the site (something I do each week).

 

The error message reads:

 

File is empty. Please upload something more substantial. This error could also be caused by uploads being disabled in your php.ini or by post_max_size being defined as smaller than upload_max_filesize in php.ini.

 

The file is no different to any of the pdfs I normally upload, using the same template etc. and I haven't changed any code in the php files so I am not sure what has caused this to change?

 

Thanks

 

Chris

Share this post


Link to post
Share on other sites
Rob    547
Rob

Hi Chris,

 

First, let's make sure the PDF itself is intact.  Have you opened it to make sure everything is there that should be?

 

Next, how are you uploading the PDF?

 

Let us know.

  • Like 1

Former PageLines Moderator, Food Expert and Raconteur

Share this post


Link to post
Share on other sites
chrisw    0
chrisw

Hi Rob thanks for the quick reply, the file was saved as 

 

Shale gas in India - The wrong path? .pdf

 

I just renamed it it to

 

 

Shale gas in India The wrong path .pdf

 

And it seems to be working ok.

 

Cheers

 

Chris

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this  

  • Similar Content

    • BentleyD
      By BentleyD+
      Hi Everyone,
       
      I am currently working on MoonBodySoul.com When platform 5 is activated, I am unable to upload images. I get an HTTP Error. The moment I deactivate the plugin, images are easily uploaded. Please help! Thank you in advance.
       
      -Bentley
    • bwdsl247
      By bwdsl247
      2 related questions:
       
      1. Want to do a page like this: http://themes.pagelines.com/dms/embed-user-guide/ ----- which DMS section did you use to achieve this?
       
      2. I tried using Media Box and came up with this: 
       
      http://bwise.wpengine.com/stats-maps/
       
      however, at least for me (Chrome), it doesn't open up PDF to fill the whole container. Even though I set it to:
       
      <embed src="http://www.businesswise.com/uploads/100017_statsandmaps/100149.pdf" width="900" height="800"> </embed>
       
      It only displays PDF as a small object and - when viewing the page, I'm having to click the media box controls at the bottom right to get it to stretch to full media box available area.
       
      Suggestions?
       
      Thanks!
       
      P.S. By the way, why is the 'Attach This File' option on this forum set to limit file size to 469 bytes?? I don't have any files that tiny...
       
       
       
    • nizami
      By nizami+
      Admittedly not a DMS 2 issue but a WP one, only posting here in case someone has the answer: WP.org does not, or it has many answers, none of which have solved this total blocker for me. I can't upload images any more, or at least, it only works a random 10% of the time. AFAIK this only happened upon upgrading to WP 3.9.1. Have tried with different file sizes and ratios but get the same results: Either the little red flag at the top of the media upload screen, or error messages like these:
       
      Fatal error: Maximum execution time of 30 seconds exceeded in/home/content/77/12052677/html/wp-includes/class-wp-image-editor-imagick.php on line 355
       
      Fatal error: Maximum execution time of 30 seconds exceeded in/home/content/77/12052677/html/wp-includes/class-wp-image-editor.php on line 391
       
      Apologies – this is not a DMS issue – but if you can help much appreciated! 
       
      N
       
    • cambridgenaturals
      By cambridgenaturals
      Hi,
       
      I am having trouble uploading the new DMS 2 to my wordpress site. I downloaded the zip file, uploaded as instructed, and receive this message:
       
      Unpacking the package…
      Installing the theme…
      Destination folder already exists. /home/cnatural/public_html/wp-content/themes/dms/
      Theme install failed.
       
      Please advise.
    • lindaped
      By lindaped+
      I have been trying to create links to a couple of PDFs that I want my clients to be able to download or view when they click on the link. I uploaded the files through the WP media uploader to my media library, grabbed the URLs (not the attachment links) from the Edit Media pages and created basic text links on my page. When I click on the links, the URL gets changed from the direct link to the page URL+direct link, i.e., http://cckitchenrental.com/wp-content/uploads/2014/03/CCKR-Client-Application.pdf gets changed to cckitchenrental.com/get-started/“http:/cckitchenrental.com/wp-content/uploads/2014/03/CCKR-Client-Application.pdf”. 
       
      I also tried sharing the files through Dropbox, hoping an external link would work, but again, it adds cckitchenrental.com/get-started/ to the beginning of the Dropbox link. Other external links to web sites work fine on this page--it's just the links to PDFs that get changed.
       
      Thanks in advance for any help!
      Linda
×