Jump to content
nitro455

Navbar Broken/Sticking

Recommended Posts

nitro455    0
nitro455

Hello,

 

I have the standard navbar at the top of all my pages.  At first, I could change the menus normally via wordpress.  I created several different menus, and when I switch them, hit save, and save menu, nothing changes on my front page.  Also, it will not let me change the footer menu.  Occasionally, if I try a bunch of times, and a bunch of different, it ways, it changes, but not to what I want it to change to.  I created a specific footer menu, and now, it is just listing all of my "pages" in the footer...peculiar.

 

What to do?

 

 

Share this post


Link to post
Share on other sites
nitro455    0
nitro455

I just created a secondary nav bar for a page, which looks rather plain by the way, just words linked, and that seems to be working just fine.  There is no dropdown functionality however, which I would have liked, but at least it is displaying the menu items that I want.

Share this post


Link to post
Share on other sites
Simon    247
Simon

Please provide a URL

Share this post


Link to post
Share on other sites
nitro455    0
nitro455

It seems like more is broken than that too.  For example, I can't change my site width.  I can't change my layout handling, or site design mode.

Share this post


Link to post
Share on other sites
James B    436
James B

Do you have a cache plugin active on the site? Anything that might be masking the changes you're making, like super cache or total cache plugins etc?


Kindly search the forum and read the documentation before posting. It will help you resolve many issues.

For CSS help be sure to check out W3Schools first and be sure to download FireBug for FireFox for troubleshooting.

James B

Share this post


Link to post
Share on other sites
nitro455    0
nitro455

I have purged the cache several times.

Share this post


Link to post
Share on other sites
Simon    247
Simon

Your using cloudflare, this will cache css/js changes. Not sure if its even needed if your on wpengine??

 

You have a lot of javascript errors on the admin pages, caused by 404 errors like this:

replace_with_your_hostname/wp-content/themes/pagelines/admin/js/codemirror/less/less.js

So maybe you didnt upload the entire framework.

 

 

Please try deactivating all plugins 1st. We have no way to debug errors when you have 20+ plugins active.

Share this post


Link to post
Share on other sites
nitro455    0
nitro455

I have a staging area of my website.  It is an exact copy of the live site, as of now.  I will send you URL in one moment, and we can deactivate all plugins and debug there.  Is there any way to reinstall paginelines while saving my work?

Share this post


Link to post
Share on other sites
Simon    247
Simon

Well 'we' cant as its 3am here, please contact James instead.

You only have to re-upload all the files. Nothing needs saving.

Share this post


Link to post
Share on other sites
nitro455    0
nitro455

In staging area I disabled all plugins, and I have deactivated all cloudflare services, then I purged the cache again, and the menu still sticks.  What is next?  I PMed you James.

Share this post


Link to post
Share on other sites
James B    436
James B

Hi there,

 

Checking the errors which are appearing on the actual site, these don't appear in the staging site with the plugins disabled and cloudfare dusabled. This will probably down to a plugin which is restricting access. If you go through the plugins one by one, turning them on and then seeing when the error with the navbar begins to appear you'll be able to track down which one is causing this. It could be related to a security plugin which is blocking certain content etc.


Kindly search the forum and read the documentation before posting. It will help you resolve many issues.

For CSS help be sure to check out W3Schools first and be sure to download FireBug for FireFox for troubleshooting.

James B

Share this post


Link to post
Share on other sites
nitro455    0
nitro455

In my staging area, all plugins disabled, cloudflare disabled, cache purged.  "Working Menu" is selected for Navbar, and footer bar, but "Main" menu is displaying for navbar.

Share this post


Link to post
Share on other sites
nitro455    0
nitro455

Ok.  I just deleted and reinstalled pagelines, and it fixed the site layout option problems, but the menu is still sticking.

Share this post


Link to post
Share on other sites
James B    436
James B

Hmm ok, the only thing I can see which is showing now is an activity monitor plugin.

 

There's an error showing in the admin area still, it seems to be blocking certain content. I've enabled your Pagelines debug so we'll see what shows up in there.


Kindly search the forum and read the documentation before posting. It will help you resolve many issues.

For CSS help be sure to check out W3Schools first and be sure to download FireBug for FireFox for troubleshooting.

James B

Share this post


Link to post
Share on other sites
James B    436
James B

Ok I've just tested the menu option again in Pagelines>site options>navbar selecting from the drop down and it's changing each time now. Can you test your end and see if you get the same


Kindly search the forum and read the documentation before posting. It will help you resolve many issues.

For CSS help be sure to check out W3Schools first and be sure to download FireBug for FireFox for troubleshooting.

James B

Share this post


Link to post
Share on other sites
nitro455    0
nitro455

Well,

 

Changing the menu at that location did indeed change my main navbar, but the footer navbar remains stuck.

Share this post


Link to post
Share on other sites
nitro455    0
nitro455

And what will happen with secondary navbars and such.  Isn't pagelines supposed to interface with Wordpress native menu settings?

Share this post


Link to post
Share on other sites
James B    436
James B

Hi there,

 

Standard menu areas will work using the options from the top left of the appearance>menu's page. The nav section which is currently in the footer area in the drag and drop is the simple nav. That's the one you'll need to use to set the footer navigation, I've just set that in the appearance>menu page for you to check it switched over.

 

Originally we only offered the classic nav when Pagelines came out, when bootstrap was integrated into the core and the navbar was added we needed to add another navigation selector for the navbar, this was placed in with the sections options so all they all remained in one place.


Kindly search the forum and read the documentation before posting. It will help you resolve many issues.

For CSS help be sure to check out W3Schools first and be sure to download FireBug for FireFox for troubleshooting.

James B

Share this post


Link to post
Share on other sites
nitro455    0
nitro455

James, 

 

I will take a closer look at this tomorrow night.  Thanks for the help.

 

-N.

Share this post


Link to post
Share on other sites
James B    436
James B

You're welcome :-)

 

We'll leave this thread open for you, just drop in a new post in if you need us.


Kindly search the forum and read the documentation before posting. It will help you resolve many issues.

For CSS help be sure to check out W3Schools first and be sure to download FireBug for FireFox for troubleshooting.

James B

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


×