Jump to content
Sign in to follow this  
Tang

iBlogPro5 overwrites Better-Carousel

Recommended Posts

Tang    3
Tang

Better-Carousel from Nick Haskins as an alternative responsive carousel section perfectly integrates with the framework. Editing underlying Flexslider2 parameters in the corresponding better-carousel > section.php works perfectly to adjust section behavior.

 

But when switching to iBlogPro5 things change! At first sight you will see the thumbnails of the better-carousel jump to full 100% size. The width, adjusted in Better-Carousel to 125px is somehow overwritten or not loaded.

 

Screenshot Framework only:

 

http://www.screencast.com/t/gddLXB1nxAj

 

Screenshot with iBlogPro5:

 

http://www.screencast.com/t/nLcqIpucOJU

 

Trying to find the reason, please help!

 

And yes, I did an almost complete customization of better-carousel fitting perfectly into the design of iBlogPro5.

 

http://www.screencast.com/t/UO6RPwwVemui

 

I also posted the CSS-Customization for this Design at Nick Haskins Forum Section with Paglines:

 

http://www.pagelines.com/forum/topic/26655-better-carousel-customized-for-iblogpro5/

 

Everything seemed to be perfect simply putting the correct width into Custom CSS (125px). But that was only CSS-cosmetics. Something in the background - coming from iBlogPro5 - changed mor than this. Later I figured out: parts of the Flexslider2.js don't work correctly with iBlogPro5 or may not load at all. Eiting parameters in the corresponding better-carousel > section.php has no more influence on the behavior or appearance (it did with framework only). And yes, I tested without the Custom-CSS of course.

 

 

 

 

 

 

 

Share this post


Link to post
Share on other sites
catrina    103
catrina

To troubleshoot your issue, please deactivate ALL active non-PageLines plugins and see if the problem persists. If the problem does not persist, re-activate each plugin one at a time and keep checking your site each time to spot the problem plugin. When you spot it, please leave that plugin deactivated since it was causing the issue in the first place.


Please read the docs before posting. Please do not private message me unless I ask you to.

Designer | Catrina Dulay

Founder | Catrina and Mouse

Share this post


Link to post
Share on other sites
Tang    3
Tang

All Plugins deactivated … that includes of course the Custom Code Plugin … nothing changed … 

Share this post


Link to post
Share on other sites
James B    436
James B

Admin note : Moved thread into store products forum.


Kindly search the forum and read the documentation before posting. It will help you resolve many issues.

For CSS help be sure to check out W3Schools first and be sure to download FireBug for FireFox for troubleshooting.

James B

Share this post


Link to post
Share on other sites
Tang    3
Tang

Since noone here helped me on this, I had to find out on my own - with a little help from my local friends  :P

 

Problem was created by a jQuery-conflict coming from iBlogPro5 when using the iAccordion-Section!

To be more specific:  jQuery UI 1.8.16 - from iAccordion seems to be causing a conflict with jQuery FlexSlider v2.1 in Better-Carousel.

 

 

My solution was: erasing  jQuery UI 1.8.16 in pagelines-iblogpro5 > sections > iaccordion > jquery.ui.accordion.js

And don't touch the parts: jQuery UI Widget 1.8.16 and jQuery UI Accordion 1.8.16 ! They seem to be responsible to have a working accordion widget in the sidebar.

 

I'm not a pro and I was just playing around with that, but this gave me a working Accordion-Widget + the Better-Carousel working like default and untouched.

 

Please note: Editing directly in the core will be overwritten with future updates - so whenever you install a iBlogPro5-Update - you might have to redo this work! 

 

 

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this  

  • Similar Content

    • dawsonbarber
      By dawsonbarber+
      Scratch this topic: the usual way does work. I think I need sleep.
       
      (Couldn't prefix the topic with iblogpro6 because it's not in the topic prefix dropdown).
       
      Anyway, I've tried the usual way, with Danny's Skeleton theme, but it's not working.
       
      Could someone let me know what I need to do?
       
      Thanks
       
      Dawson
    • darcythe2nd
      By darcythe2nd
      I don't want to keep the pagelines, html5, or css3 icons in the solid footer. I don't see how to get rid of them. They're there even if I leave the website address blank. How to get rid of them??
    • darcythe2nd
      By darcythe2nd
      I installed this but am unable to find where I can change the color of the solidfooter to anything other than the original white! Please help!
    • hypman
      By hypman
      Hi
       
      I thought i had installed this properly a few days ago but now im not sure as i ve seen 2 versions of frameowrk in my themes. (see image)
       
      if i activate the multi coloured fromawork theme i see no error messages, but when i activate the other framework theme i see this again:
       
      Install Error!
      PageLines Framework must be installed in a folder called 'pagelines' to work with child themes and extensions.

      Current path: /home/stopsmok/public_html/ripley-hypnotherapy.co.uk/wp-content/themes/PageLines
       
       
      Will the ilblog not run correctly if i ignore this? i cant see nay issues with the theme?
       
      thanks
       
      ps the site is ripley-hypnotherapy.co.uk
    • hypman
      By hypman
      Hi guys
       
      Ive just installed framework then i added iblog pro 5 and the site seems ok but i ve got an error message:
       
      Install Error! PageLines Framework must be installed in a folder called 'pagelines' to work with child themes and extensions.

      Current path: /home/warringt/public_html/wp-content/themes/PageLines-Framework-master
       
       
      Im not sure how to correct this, but as i say the site looks ok anyway
       
      waringtoncycles.com
       
      Any ideas? ive read a little but im still confused lol
×