Jump to content
Sign in to follow this  
pspr

Feature Section

Recommended Posts

pspr

website: www.headedforgreatness.com

 

So the feature load time has been bugging me for the past couple days. I can't seem to find a solution for it... I dont know if I installed WP Super Cashe the right way. The thing thats really frustrating is when i go to my home page, It doesn't matter which browser I use, Even if I use my cell phone it doesnt matter. The way the feature slider loads is It Immediatly shows all of my slides vertically for a few seconds while my page is loading, then it puts them in the slider.... But whenever I go to other websites like espn.com or yahoo.com there sliders dont do that.... I would really appreciate any help I can get.

 

Thank You,

 

Seena Khoee

Share this post


Link to post
Share on other sites
Rob

Hi,

 

The problem I'm seeing on your site is that you have very large images in the slides.  The slider doesn't scale, it crops. In otherwords, if a slide should be seen by visitors as 600px by 350px  but you're using a 1280px by 720px image, the visitor may only see the desired size, but the whole image loads.  All that cropped space uses memory, and if you have multiple large images, the slider will slow down considerably, as will the page load time where the slider appears.

 

The solution is to use a graphics editor (such as Photoshop), and resize or crop the images, replacing that 1280px by 720px image with one that fits exactly the size desired. This will vastly reduce the load time of the slider and the page.

 

You can see what I'm observing by looking at the image in the Kobe Bryant slide:  http://www.headedforgreatness.com/wp-content/uploads/2013/04/kobe.png

 

With this image: http://www.headedforgreatness.com/wp-content/uploads/2013/04/kdrussel2.jpg the slider is compelled to stretch it, using additional processes to perform that function.  The best solution with sliders is always to make the background images the same size, minimizing the load time.

 

The transition speeds set for your slides seems to be slow. Can you tell us what those settings are?


Former PageLines Moderator, Food Expert and Raconteur

Share this post


Link to post
Share on other sites
pspr

Wow. Very insightful. Thanks Rob! My settings are. Static Mode. Static Height 410px Timout4500 Transition4500

Share this post


Link to post
Share on other sites
Rob

Thanks for the compliment!

 

Try setting the Timeout to 7500 and the transition to 1500 ms. Cumulatively, the time is the same, but the Timeout allows more time for your visitors to view the slide, while the transition is simply the time it takes to go from one slide to the next. 

 

All your images should be no higher or smaller than 410px in that case, and each should be no wider than the content area width set in your layout.

 

I hope this helps you speed up the transition and load time.


Former PageLines Moderator, Food Expert and Raconteur

Share this post


Link to post
Share on other sites
pspr

Huge help. Thanks Rob. Hoping this is going to solve the problem.

Share this post


Link to post
Share on other sites
Rob

Anytime.  That's why we're here! :D


Former PageLines Moderator, Food Expert and Raconteur

Share this post


Link to post
Share on other sites
pspr

Rob last question. How do you think my website is layed out? I dont know what else to add because I am obviously targeting NBA fans and I want more stuff on my website..... just want to continue to increase my page views and unique visitors everyday..... do you think there is enough content or do i still need more?

Share this post


Link to post
Share on other sites
Rob

I like it. I think it looks busy, but not so busy as to be overwhelming.  Busy, in an informative, fulfilling way, not a bad way. The spacing is great, and gives easy flow to the view of the page.  I love the way you've broken up the categories.  Well done!


Former PageLines Moderator, Food Expert and Raconteur

Share this post


Link to post
Share on other sites
pspr

Thank you for your analyzation... Hopefully I can have some followers and increase my unique visitors. Appreciate your help and insight.

Share this post


Link to post
Share on other sites
pspr

Rob I minimized the Images on the features.. they all have a height of 410px which is what the static height is set too.. and all of the width is definitely lower than the tolerance given. but for some reason my feature slider is still loading the same way. showing all my slides when the image loads. then going to normal...

Share this post


Link to post
Share on other sites
weekendknitter

I believe I have a similar problem.  When I load my homepage, it tends to show a portion of one of the photos underneath where the slider should be.  Then it goes to normal as well.  Anyone have any other ideas as to why that is happening?  http://www.greenbankmill.com

Share this post


Link to post
Share on other sites
pspr

Please somebody help us. Super Super Frustrating. 

Share this post


Link to post
Share on other sites
pspr

I would like to mention the problem I am having has improved! by improving i mean they are loading a big faster after changing the size of the images. but it is still showing all the slides for a second or two..

Share this post


Link to post
Share on other sites
James B

Hi there, to stop the additional slides stacking below before they load fully add this code to your css

#page #feature-area {
                overflow: hidden;
        }

Kindly search the forum and read the documentation before posting. It will help you resolve many issues.

For CSS help be sure to check out W3Schools first and be sure to download FireBug for FireFox for troubleshooting.

James B

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this  

×