Jump to content
rpeople

Navbar shows strange behaviour with WPML

Recommended Posts

rpeople    0
rpeople

Hello

I am using WP 3.5.1 together with Pagelines Framework 2.4.1 and WPML 2.7.1.

My site is http://www.r-people.com/

 

I use Ubermenu for my Primary Navigation at the top. The second menu under the bradning section is a standard navbar, which behaves a bit strange. I want it to hoover but the menu title should be clickable to open the underlying link. At the moment it only fixes the submenu but it should open the link.
I really have no more ideas what to Change to make it a link. In the menu definition it is a link but it appears in the browser only like a title. With firebug it shows me that Pagelines attaches a #m1, #m2, ... to each link. How can I get rid of this?

If I cannot Change this behavior it is no big issue.

 

The bigger Problem is the following:

The more I placed a language selection from WPML on the navbar. Here another strange thing happens: The language selection can be made only partially related to the menu item I selected and the page I visit.

If I select the shopping blog or forum I can select the language again. If I choose other blogs I cannot choose the language selector again. It works only with the shopping, power and mobility blogs and all forums.
I checked it with firebug but have no more ideas what to change to make it work.

Thank you for your help

 

Gernot
 

 

 

Share this post


Link to post
Share on other sites
Danny    1,327
Danny

Hi Gernot,

 

1. The Navbar section is based on Bootstrap navigation design, where drop down menus are access upon click rather than hover. Therefore, any menu item that has a sub menu, will no longer be a link to a page/post etc.. but will act as anchor instead of a link. If you do not wish to have this functionality and would prefer a standard design navigation, then I recommend you replace the NavBar section with the Nav Classic.

 

2. This is most likely cause by either a plugin or custom code. Therefore, I recommend you disable all non-PageLines plugins and see if this resolves the issue.


Please search our forums, before posting!

Share this post


Link to post
Share on other sites
rpeople    0
rpeople

Thank you for your more the fast reply. You do a great Job.

Point one is solved with your answer. I will integrate those first links in the menu.

 

The second issue is solved too. It had not been the otther plugins or custom code but a stupid mistake I made with WPML. 

Sorry to have stolen your time,

Thank you for the wonderful theme and Framework and your great support!!

Have a nice easter holiday

Gernot

Share this post


Link to post
Share on other sites
Danny    1,327
Danny

Thanks for informing us that you issues have been resolved, we appreciate it.


Please search our forums, before posting!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


  • Similar Content

    • JP
      By JP+
      Hello,
      We are working on a 2 languages site (https://liguecardioliga.be) with wpml, and lately the call of a category in the loops section (and all the sections requiring a category to select posts) doesn't work in the translated language. It worked well until recently so I wonder if it's because of a recent update (wordpress, wpml, pagelines, a plugin?). Anyone has the same problem? a solution?
      TIA
    • mrhinsh
      By mrhinsh
      I am trying to get WPML working on my Pagelines instance. I am interested in getting help from anyone that has tried, especially @claudedagenais who seams to have it working.
      My issues are:
      How to translate header and footer How to get the menu to show all nav even if not translated How to get non-translated posts /pages to show up when only in default language - true for Masonry, Newsfront, and other list showing items... I have zero skills in PHP and its my site for my company. 
      note: Multi-lingual is a business decision and is required. I have vetted all of the multi-lingual options and the only one fit for purpose is WPML. 
    • Grant Turck
      By Grant Turck+
      Navbar Broken on All Devices When Not Logged Into Wordpress. See screenshots attached from mobile. What is causing this issue and how do I fix? Site is venicepride [dot] org.


    • JP
      By JP+
      Hello,
      How can you set the translations with platform5, the parts that are not in pages or posts? Texts and images…
    • PierreFF
      By PierreFF+
      Hello, 
      I have an issue with NavPro on mobile when the link of the menue is on the same page. 
      Here is my website: http://foundersofthefuture.co
      The isssue comes from the fact that in my menue most of the items send somewhere else on the same page using anchor link (eg. #container_u788888). 
      This works well on desktop but on mobile, nothing happens when clicking on the link. One of the link of the menue of the homepage "France" sends to another page of the website and this one works well even on mobile. 
      I am using the Pagelines framework theme and also used a wordpress plugin (jQuery Smooth Scroll) for smooth scrolling . 
      Thanks in advance for your help and let me know if I need to provide more information. 
      Best,
      Pierre
×