Jump to content
Sign in to follow this  
imagineutopia

issues on godaddy

Recommended Posts

imagineutopia

hi.

 

my client is hosting on godaddy. I'd rather he didn't, but he does.

 

I have come across a bug early into this and I want to see if I can do anything while things haven't really been developed too far yet.

 

with the pagelines framework active, I am getting the following error printed out twice on my coming soon page.

 

Warning: call_user_func_array() [function.call-user-func-array]: First argument is expected to be a valid callback, 'Array' was given in /home/content/99/8907999/html/beyaonline/wp-includes/plugin.php on line 406

 

I've also attached a screen shot.

 

so my fear is this godaddy account is on one of their random horrible servers and is going to be throwing me issues. is there anything I could have their IT guys set or up that would allow pagelines to run better on there? I know on a westhost account I have, we had to have them change the mod_security and some other thing as well.

 

The plug in I'm using is called Coming Soon Pro. This is them. http://www.seedprod.com/features/

 

my plan was to have that running in the foreground and then I can develop the site in the backend.

 

thanks,

 

John

Share this post


Link to post
Share on other sites
James B

Hi John

 

Looking at the error message I would think its more that the plugin is the problem rather than godaddy. The messages are only warnings, so if you disable debug in the wp-config.php they will be hidden from view.

 

Is it definitely that plugin which is causing the error? If you disable it does it go away?


Kindly search the forum and read the documentation before posting. It will help you resolve many issues.

For CSS help be sure to check out W3Schools first and be sure to download FireBug for FireFox for troubleshooting.

James B

Share this post


Link to post
Share on other sites
imagineutopia

when the coming soon is on and the theme is pagelines, I get the error. but I only see it cause I'm on the coming soon page.

 

when its off and 2011 is on, the coming soon shows no error.

 

when I browse around in the pagelines site I'm building, so far it is running fine.

 

when coming soon is off, there is no coming soon and pagelines runs fine.

 

so I guess its fine if I can hide this error message.

 

I called the godaddy people, but they are being difficult about helping me turn off that error function.  they blamed wordpress in general.

 

DEBUG was already false. when I set it to true I get a lot more junk showing up. is there another setting in there I can change to true or false that you know of that might kill this last error here? 

 

define('WP_DEBUG', false);   is what I changed to true and got more errors.

 

should I email that plugin company for this coming soon pro and let them know and see what they say?

Share this post


Link to post
Share on other sites
Danny

Hi,

 

 

All of the PageLines products are built according to WordPress API standards and do work with the majority of plugins out there. Therefore, the best course of action is would be to contact the plugins support team and ask them for assistance. 


Please search our forums, before posting!

Share this post


Link to post
Share on other sites
imagineutopia

alright. I'll post their response.

Share this post


Link to post
Share on other sites
Danny

Thanks, keep us posted.


Please search our forums, before posting!

Share this post


Link to post
Share on other sites
imagineutopia

this worked. here's what he sent me back.

 

Hi John,

I have traced these errors back to the Pagelines theme.

*Here's a workaround:*
Add these two line to the top of your wp-config.php just below the opening
php tag.


#####
define('WP_DEBUG_DISPLAY', false);
@ini_set('display_errors',0);
####

This should keep the warnings from displaying unless another plugin is
toggling it back on.

*Here's the issue:*
To use gravity forms we have to include the wp_head and wp_footer
WordPress functions so gravity forms functions properly. Pagelines also
hooks into these two WordPress functions and assumes their theme is loaded
and running. Hover it's not, it being overridden with the coming soon page.
so when there function
print_template_section_scripts for example try to runs it creates an error
because the theme is not loaded and it's looking for some value for it to
work.

Let me know if you have any more questions.

Share this post


Link to post
Share on other sites
James B

Hi John, that's great, so it was a clash between the plugin and the framework using the same hooks.

 

Glad you got it sorted.


Kindly search the forum and read the documentation before posting. It will help you resolve many issues.

For CSS help be sure to check out W3Schools first and be sure to download FireBug for FireFox for troubleshooting.

James B

Share this post


Link to post
Share on other sites
imagineutopia

yup. thanks for the help.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this  

×