Jump to content
Sourena

"Filtering" Section on Bilingual Websites

Recommended Posts

Sourena    2
Sourena

I am trying to use on a "Filtering" Section on bilingual website. Everything works fine except the words "Show All", "Prev" and "Next" could not be translated.

How can I fix that?


alefba.us

Web Development & Design for Right-to-Left languages

Share this post


Link to post
Share on other sites
ellenmva    112
ellenmva

Hi,

 

It's something I have to fix in Filtering.  You can change the Show All phrase in options but ideally Filtering should translate that phrase. I should have an update later today or tomorrow for you.  Will let you know when I do.

 

Ellen


Ellen Moore

Pagelines Developer

www.elsue.com www.betterdms.com

Share this post


Link to post
Share on other sites
Sourena    2
Sourena

Thank you!


alefba.us

Web Development & Design for Right-to-Left languages

Share this post


Link to post
Share on other sites
ellenmva    112
ellenmva

I pushed an update and it should work.  I tested it with Transposh and did have to set the option for pretty permalinks otherwise the pagination doesn't work.

 

Any problems let me know.

 

Ellen


Ellen Moore

Pagelines Developer

www.elsue.com www.betterdms.com

Share this post


Link to post
Share on other sites
Sourena    2
Sourena

Ellen,

 

Transposh is not the right plugin to test this. To translate a wordpress themes or plugin you need to do certain things described in this page:

http://wp.tutsplus.com/tutorials/how-to-localize-wordpress-themes-and-plugins/

 

I am not sure how you can localize a Pagelines "section" but there should be a way to include "Show all", "Prev" and "Next" in Pagelines' "mo" and "po" files.


alefba.us

Web Development & Design for Right-to-Left languages

Share this post


Link to post
Share on other sites
ellenmva    112
ellenmva

Yes, my code is like what is in the tutorial except that Pagelines creates the .pot file in the section folder. When I created the section I didn't have the Show All, Prev and Next localized.  They are now localized and part of the filtering.pot file.

 

So, those phrases should now translate.

 

Ellen 


Ellen Moore

Pagelines Developer

www.elsue.com www.betterdms.com

Share this post


Link to post
Share on other sites
Sourena    2
Sourena

Where is the section folder located? I searched the themes folder but I cannot find it among the sections.


alefba.us

Web Development & Design for Right-to-Left languages

Share this post


Link to post
Share on other sites
ellenmva    112
ellenmva

The folder is in wp-content/plugins/pagelines-sections/filtering. There should be a filtering.pot file there.  If it is not, let me know and I will investigate further.

 

Ellen


Ellen Moore

Pagelines Developer

www.elsue.com www.betterdms.com

Share this post


Link to post
Share on other sites
ellenmva    112
ellenmva

I wanted to see if the phrases translated for you with the adjustments I made to the section.  If not, I want to help get it working for you. Please let me know if you need further assistance.

 

Ellen


Ellen Moore

Pagelines Developer

www.elsue.com www.betterdms.com

Share this post


Link to post
Share on other sites
Sourena    2
Sourena

Thanks. I have a problem with my server. I downloaded the POT file and translated it. Then I tried to upload the files but the server does not allow me to upload them because the permissions are set to 755 and I cannot change it from my FTP client software. I have to take care of this issue first, then I can see if the translation works.


alefba.us

Web Development & Design for Right-to-Left languages

Share this post


Link to post
Share on other sites
Sourena    2
Sourena

I finally uploaded the tranlstion files but now it seems the section works incorrectly. Check this page and try to navigate through pages 1 to 6:

http://shahrefarang.com/new/en/

 

It seems the content doesn't change sometimes. I click on "next" or page numbers but the page only reloads the same content.


alefba.us

Web Development & Design for Right-to-Left languages

Share this post


Link to post
Share on other sites
ellenmva    112
ellenmva

Hmm, it's seems to have to do with the /new being there.  The page changes but the pagination on the bottom doesn't change.  I'm going to setup a test site that is in a sub-folder of root and see if I can replicate the issue.  

 

Again, sorry that it is not working properly.  Will try and get it fixed as soon as possible.

 

Ellen


Ellen Moore

Pagelines Developer

www.elsue.com www.betterdms.com

Share this post


Link to post
Share on other sites
Sourena    2
Sourena

Thanks for your quick response and your effort to fix this!


alefba.us

Web Development & Design for Right-to-Left languages

Share this post


Link to post
Share on other sites
ellenmva    112
ellenmva

I setup a test site like yours and it worked fine using a subfolder, whew!  I think the culprit is Views, it is loading a pagination script and I think that is conflicting with the pagination in Filtering.  Could you try deactivating Views and see if the problem still exists?  

 

Let's hope that's the issue.  Then we can figure out how to handle it.

 

Ellen


Ellen Moore

Pagelines Developer

www.elsue.com www.betterdms.com

Share this post


Link to post
Share on other sites
Sourena    2
Sourena

THat is strange. Because before the update it was working fine even though Views was active.

 

I just disabled Views. But the problem is still there. My plugins are:

 

 
Contact Form 7
 
FancyBox for WordPress
 
Pagelines Sections
 
Post Types Order
 
WPML Media
 
WPML Multilingual CMS

alefba.us

Web Development & Design for Right-to-Left languages

Share this post


Link to post
Share on other sites
ellenmva    112
ellenmva

I have access to WPML but it will take me a bit to set it up. Before I do, if you could do me one more favor and disable all plugins except pagelines sections and see if the pagination still isn't advancing since it is happening in both the Persian and English. If it works, just reactivate the WPML plugin and see if it doesn't work again. If it doesn't work without WPML activated then something else is going on. If it is only broken with WPML then I'll need to know how you have things setup. Another thing to try is going into wp-config.php and set Debug to true and see if you are getting any error messages on the page. Ellen Sent from my iPad using Tapatalk HD


Ellen Moore

Pagelines Developer

www.elsue.com www.betterdms.com

Share this post


Link to post
Share on other sites
Sourena    2
Sourena

"Filtering" had no problem before the update. It was working fine with all the other plugins installed.

 

I disabled all the plugins (except Pagelines sections) and it still had the same problems: No "Prev", additional "/", and the problem with "Next".


alefba.us

Web Development & Design for Right-to-Left languages

Share this post


Link to post
Share on other sites
Jenny    33
Jenny

Please let us know if you still need assistance with this issue otherwise I will close the topic in 7 days. Thanks!


Jenny :: Web designer at Simple Mama (follow me at @simplemamacom)

Check out Share Me, a social sharing add-on for DMS that is super simple to set up.

Share this post


Link to post
Share on other sites
Sourena    2
Sourena

I still need assistance. I need some time to test it again.


alefba.us

Web Development & Design for Right-to-Left languages

Share this post


Link to post
Share on other sites
ellenmva    112
ellenmva

Sorry, we were messaging privately working on fixing the issue.  An update was pushed and will see if resolved the problem. Should know soon :)


Ellen Moore

Pagelines Developer

www.elsue.com www.betterdms.com

Share this post


Link to post
Share on other sites
Jenny    33
Jenny

Okay just let me know when this is resolved, or the original post creator can click a "mark solved" button. :)


Jenny :: Web designer at Simple Mama (follow me at @simplemamacom)

Check out Share Me, a social sharing add-on for DMS that is super simple to set up.

Share this post


Link to post
Share on other sites
Sourena    2
Sourena

Thank you Ellen. The plugin works perfectly now!

 

@Jenny: This issue is resolved.


alefba.us

Web Development & Design for Right-to-Left languages

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


  • Similar Content

    • Josiah Jones
      By Josiah Jones
      Hi,
      I'm currently using the Filtering plugin on a website that is not yet live (http://www.RetroLeaders.com/ - currently hidden by a "Coming Soon" plugin) however after updating to the most recent version of Wordpress and DMS the Filtering plugin has stopped working and is causing DMS to display the never ending load icon.
      Inspecting the code for errors I see the following problems:
      . jquery.isotope.min.js?ver=1.7.4:11 Uncaught TypeError: Cannot read property 'opera' of undefined (anonymous function) @ jquery.isotope.min.js?ver=1.7.4:11 (anonymous function) @ jquery.isotope.min.js?ver=1.7.4:11 (index):66 Uncaught TypeError: mycontainer.isotope is not a function (anonymous function) @ (index):66 jQuery.Callbacks.fire @ jquery.js?ver=1.11.2:3143 jQuery.Callbacks.self.fireWith @ jquery.js?ver=1.11.2:3255 jQuery.extend.ready @ jquery.js?ver=1.11.2:3467 completed @ jquery.js?ver=1.11.2:3498
        Can you please check if everything is working properly and provide an update if necessary? The filtering function is a crucial part of my web design and we cannot go live without it!
      Please let me know what you find.
      Best,
      - Josiah 
    • evscicats
      By evscicats
      Ellen,
       
      What version number is the latest for the Filtering section?  I have version 1.6 and hope that I'm up-to-date.  If there's a new version, how do I get the latest update and do I have to pay again?
       
      Thanks,
       
      Jerrad
    • jujutanada@gmail.com
      By jujutanada@gmail.com
      Hi, I found out that if I go to the archive of a tag e.g. http://mysite/?tag=lotd , it doesn't work. It doesn't show the correct posts tagged with lotd, --but it works for categories. It only works when I use WP Content. How do I display this using Postpins?
      And is it possible to create a different archive page for only a particular category?
       
    • jujutanada@gmail.com
      By jujutanada@gmail.com
      Hi, I found out that if I go to the archive of a tag e.g. http://mysite/?tag=lotd , it doesn't work. It doesn't show the correct posts tagged with lotd, --but it works for categories. It only works when I use WP Content. How do I display this using Postpins?
      And is it possible to create a different archive page for only a particular category?
       
    • aldisney
      By aldisney+
      Hello, PageLines!
      I have a problem I'm running into with trying to get a featured image (in a WP loop) to display as a circle. I'm using the filtering plugin, too. Here's the image I'm trying to show displayed as a circle:
      [sharedmedia=core:attachments:2460]   I've tried adding:   .filtering-image center {   border-radius: 50%;  }  
      I think I just have the wrong tag, but I can't seem to figure it out. Anyone have any ideas?
×