Jump to content
Sign in to follow this  

Drop Down hides behind NextGen Gallery

Recommended Posts


When I use NextGen Gallery slideshow you can see the drop down menus at the top of the page drop down in front of the Slide images. However, once the slideshow cycles through to a second time the drop down menu hides behind the slide show. If I refresh the page it's fine again until the 2nd cycle.


Anyone know why?

Share this post

Link to post
Share on other sites



Notice the Info drop down which extends down onto the images. Wait 20 images and it will be covered up.

Share this post

Link to post
Share on other sites
James B



The plugin seems to have it's own settings for the different slider layers which go over the dropdown.


Try adding the following to your custom css box (Pagelines>site options>custom code) to see if it resolves.


.ngg-slideshow {
    overflow: hidden;
    position: relative;
    z-index: 0;
  • Like 1

Kindly search the forum and read the documentation before posting. It will help you resolve many issues.

For CSS help be sure to check out W3Schools first and be sure to download FireBug for FireFox for troubleshooting.

James B

Share this post

Link to post
Share on other sites

Awesome. That solved it.


Thank you so much.  :D

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this  

  • Similar Content

    • marshallsolutions
      By marshallsolutions
      For the site https://marshallsirishpub.com I am running
      Wordpress 4.9.4
      Pagelines base theme 1.0.2
      Pagelines Framework 2.5.0
      Specific page not working properly is https://marshallsirishpub.com/photo-gallery/
      I am using NextGen gallery which is activated and showing the pictures in the gallery.  Page was edited to add the carousel and points to the NextGen gallery.  Meta settings and page were both saved.
      When I'm logged into Wordpress I see the following error at the top of the page:
      The site was hacked last month and it seems the hacker changed some things on the site, but I can't figure out what was changed to make the Carousel not show on the page.
    • Kedark
      By Kedark+
      how to set the menu navi:
      - The background color when you expand a submenu,
      - Background color on mouseover,
      - The color of the text,
      - Width of submenu
      Please help, nowhere in the forum I have not found the answers to these questions ..
    • FRevi
      By FRevi+
      It took me a long time to figure this out so I thought I'd share my experience. Maybe someone can verify or benefit.
      NextGen is a popular gallery plugin. With the Plus or Pro versions, which have features you need, there is a second plugin called NextGen Pro.
      With NextGen Pro activated, you can't add DMS sections, the DMS2 GUI just doesn't let you drag them. However, you can work with the sections that are already on the page.
      With NextGen Pro DE-activated, its functionality breaks but you can add sections (e.g., ones containing the galleries you're creating). 
      Bottom line, workflow is
      - leave the regular NextGen plugin activated
      - deactivate the NextGen Pro plugin to add DMS2 sections
      - reactivate the NextGen Pro plugin to configure your galleries and publish the site
      Hope this helps.
    • Mark_Hazeldine
      By Mark_Hazeldine
      I recently upgraded Wordpress to 4.0.1 and DMS to the latest version. I also updated to the latest incarnation of the NextGEN Pro product, but now, having done all these changes, I don't see anything but white background on my home page, instead of a nice pro slideshow gallery.
      I contacted NextGEN and they said:
      "I'd strongly suggest contacting the developer of the Theme in case they could look into this sooner for you. I'd suggest you or they look into any conflicting code in theme functions, possible JQuery or Javascript, or checking to confirm that the footer is called in the footer.php:

      Has the call to <?php wp_footer(); ?> added directly before </body>"
      Is anyone able to help?
      Thanks, Mark
    • orangecricket
      By orangecricket
      - If this is a duplicate I apologize, I don't see my first attempt to post this in the forum.
      I purchase the Navbanner and I love it but I needed it to drop down on hover for sub menus. I checked the Demo before purchase and the demo dropped down when I moused over it so I assumed it would be as easy as checking a box like the Navbar but I don't see this option anywhere. Am I missing something?
      Is there an easy way to make my submenus drop down on hover like the Demo?