Jump to content
Sign in to follow this  
SaleekR

Ok Really simple CSS question

Recommended Posts

SaleekR    1
SaleekR

My brain is fried and i'm sure this is a simple fix, but my mind just wants to sleep...

I'm trying to replace the branding section with the universal sidebar and a text widget to get 3 divs floating side by side.

But for the life of me i just can't get it to work.

Any suggestions as to what i did wrongs?

 

http://cloudcomputingnewyork.com/dev/

 

Thanks

 

 

Share this post


Link to post
Share on other sites
SaleekR    1
SaleekR

Sorry. Here is the code

<div id="10head">
<div id="con">
<h4>10/10 OPTICS</h4>
<p>P. 212.366.1010 | F. 212.366.1466<br /> E. <a href="mailto:info@1010optics.com">info@1010optics.com</a></p>
</div>
<div id="10logo"><img class="aligncenter size-full wp-image-488" alt="1010_Logo" src="http://cloudcomputingnewyork.com/dev/wp-content/uploads/2013/03/1010_Logo.png" width="135" height="132" /></div>
<div id="addy">
<h4>50 MADISON AVE.</h4>
<span style="font-size: 17px;">at 26th St</span>
<h6>NEWYORK</h6>
</div>
</div>

and the css

.widget #10head {

  margin: 0 auto;
    max-width: 1000px;
	top:0px;
	width:992px;
	height:152px;
}

.widget #con {
	float:left;
	top:0px;
	width:432px;
	height:152px;
	text-align:center;
}
.widget #con h4 { font-size:28px;
	
}
.widget #addy h4 { font-size:28px;
	
}
.widget #addy h6 { font-size:24px;
letter-spacing:20px;
color:#666;
	
}


.widget #10logo {
	float:left;
	top:0px;
	width:148px;
	height:152px;
}

.widget #addy {
	
  float:right;
		top:0px;
	width:411px;
	height:152px;
	text-align:center;
}
You'll need Skype CreditFree via Skype

Share this post


Link to post
Share on other sites
James B    436
James B

Hi there,

 

I've just checked your site and the widgets are floating side by side, you seem to have this working now.

 

Let us know if you need further assistance


Kindly search the forum and read the documentation before posting. It will help you resolve many issues.

For CSS help be sure to check out W3Schools first and be sure to download FireBug for FireFox for troubleshooting.

James B

Share this post


Link to post
Share on other sites
SaleekR    1
SaleekR

No, I was just trying out using a table instead, but that didn't work in keeping the site responsive. Still need help.

Share this post


Link to post
Share on other sites
James B    436
James B

Hi there,

 

I think your easiest option would be to place a contentbox in the header section, content box is a free section available from the pagelines store. It allows you to add extra text/html to an area just like in the wp editor. You can then use the pagelines grid shortcodes to create three columns and enter your content in there. That way it will be perfectly aligned within the header.

 

You can find the grid shortcodes here - http://demo.pagelines.me/tools/

 

If you're still looking at the float option you'll need to float the all left in order for them to align horizontally.


Kindly search the forum and read the documentation before posting. It will help you resolve many issues.

For CSS help be sure to check out W3Schools first and be sure to download FireBug for FireFox for troubleshooting.

James B

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this  

  • Similar Content

    • Michael Kummer
      By Michael Kummer+
      Hi guys,
      every since Chrome introduce scroll anchoring (see chrome://flags) blog posts on my page start scroll automatically as soon as the user scrolls down a bit. It is super annoying and I don't know exactly what triggers the incompatibility with Chrome's latest feature that is supposed to improve usability.
      Since I don't know what causes it (Pagelines, or a Plugin), I would like to disable the feature using a CSS override that Google describes as follow:
      "Scroll anchoring aims to be the default mode of behavior when launched, so that users benefit from it even on legacy content. A CSS property overflow-anchor can disable scroll anchoring in part or all of a webpage (opt out), or exclude portions of the DOM from the anchor node selection algorithm. This property supports the following values when applied to an element E:
      overflow-anchor: auto (the default value) declares that the DOM subtree rooted at E is eligible to participate in the anchor node selection algorithm for any scrolling box created by E or an ancestor of E. overflow-anchor: none declares that the DOM subtree rooted at E is not eligible to participate in the anchor node selection algorithm for any scrolling box created by E or an ancestor of E." Do you guys happen to know how to use that property with the ROOT element so it applies to the whole page?
      Thanks
      Michael 
    • wyo22ski
      By wyo22ski+
      Hello,
       
      I'm basically a designer and understand a little on how to change CSS, etc., so please excuse my ignorance...  I recently upgraded to the newest platform from the DMS and my old DMS theme no longer functions.  I'm trying to replace the image slider that my Horizon Photography Theme (Nick Haskins) had created.  The Impulse image slider seemed the closest to what I need, but there are problems.
      It seems the the Impulse section for sliding images defaults to the image width, no the height.  I can change the Impulse stage height and width, but this does nothing to the internal content.  For instance, if I change the height to 200 pixels, the image remains the full width and only shows a cropped section.  I would like the ability to change the Impulse height, and have the image height fit space. 
      I've put this custom CSS in, but again, this only controls the stage height of Impulse:
      .pl-sn-impulse .pl-impulse-cell .cell-wrap, .pl-impulse-container, .owl-stage-outer {
        width: 100%;
      }
       
      Any suggestions welcome.  Thanks 
    • Objectif-Mariage
      By Objectif-Mariage+
      Hello. 
      I have just realized that CSS (Less plugin) , is not working..... I have disable all plugins (except PL CUSTOM LESS and PL5) , and ... it's not working ... 
      It's not the first time. Usually I had trouble with a plugin name Autoptimize , but it's Desactivate now , all memory have been purge, and it's still not working! :-/ So it's not from this plugin. 
      NB : When I am logged on my website, if i go on the black wordpress dashboard bar, go on the PL icon, clic on </> LESS/CSS => then the page suddenly apply the CSS .... But As soon that i reload the page, nothing. I think the problem is that the plugin LESS/CSS does not load properly (if I can say that with my simples words).
      I order to keep the site "good looking" I have temporally copy/paste all my LESS code in a plugin : Script n Styles that apply the LESS/CSS code... but it's not a solution for long time.
      Can someone help me ? Did I do something wrong ? Is it an update ? 
       
      my website : https://www.wedding-photography-minneapolis.com
    • Jason
      By Jason+
      Feel free to delete this post if its not helpful or its just plain wrong.
       
      I though it might be useful to share how I customize the size of the builder. (reduce my eyestrain )
      1 - install stylerbot extension in chrome (stylerbot keeps this css every time you access the url)
       
      2- add this css to stylerbot for the site you are working on
      .CodeMirror {
          font-size: 14px;
          height: 600px;
      }
      .pl-workarea.pl-has-sidebar .pl-workarea-sidebar-container {
          right: 0px;
          width: 500px;
      }
      .pl-workarea.pl-has-sidebar .iframe-container {
          right: 500px ;
      }
       
      change sizes to suit.
       
      Cheers.
    • Jason
      By Jason+
      Hi.
      I can't seem to get the Teamwork section to accept custom css. I am trying to change the padding from 7em to 1em on the splash part
      I have tried
        .pl-sn-teamwork .pl-tw-splash {
          padding-top: 1em;
          padding-bottom: 1em;
        }
       
      This works in chrome inspect but when added to custom css nothing happens.
      I have also tried most of the classes I can see accoiated with this section but again nothng seems to happen.
      Any ideas?
×