Jump to content

Recommended Posts

loiborg    0
loiborg

Hi forum!

I am trying to have the PageLines theme framework translated into Danish. Therefore I have downloaded the current translation from the translations center page. I have also downloaded and activated the PageLines Customize plugin from the PageLines framework. There were no 'languages' folder in that theme, so I've added it (which makes the path /wp-content/plugins/pagelines-

customize/languages)

I've added the language .po-file which was exported using the site. I've renamed it to 'da_DK.po'. It still doesn't work - what am I doing wrong? (the site isn't very clear on this, unfortunately).

I also saw that on the page, where PageLines announced the translation feature (*), there was a suggestion to split translations between front- and back end. How is this done? The progress in the Danish translation is very low and it doesn't make sense to translate the back end, as every Dane speaks English.

Furthermore I've added a bunch of translations, but they seem to need to be approved. I have a journalism degree, so my Danish is flawless. Can I somehow approve them? (it doesn't seem like there are a lot of Danes using PageLines - at least there's not a lot using the translation framework). Furthermore, how do I make sure that the translations I have already made (but hasn't been approved yet) are included in the downloaded file?

(*) http://www.pagelines.com/translation-localization-center/

Thanks in advance!

Share this post


Link to post
Share on other sites
Danny    1,327
Danny

Hi,

 

Although I am no expert in translating, our documentation on translating, which you can be found here - http://support.pagelines.me/docs/getting-started/internationalization-and-localization/

 

One thing I noticed in your post above is that you do not mention changing the language in the wp-config.php file?


Please search our forums, before posting!

Share this post


Link to post
Share on other sites
loiborg    0
loiborg

Hi Ninja,

 

Thanks for the quick reply. It should already be set to the correct language as I'm using the official translated version of Wordpress in Danish.

Share this post


Link to post
Share on other sites
James B    436
James B

Hi there, I see in another post you've managed to get the translation sorted and installed. Let us know if its ok to resolve this thread and continue conversations on the other post etc.


Kindly search the forum and read the documentation before posting. It will help you resolve many issues.

For CSS help be sure to check out W3Schools first and be sure to download FireBug for FireFox for troubleshooting.

James B

Share this post


Link to post
Share on other sites
loiborg    0
loiborg

Hi there, I see in another post you've managed to get the translation sorted and installed. Let us know if its ok to resolve this thread and continue conversations on the other post etc.

Uhm, nope? You must mistake me for some one else - I haven't found out what to do :)

Share this post


Link to post
Share on other sites
Danny    1,327
Danny

The folder needs to be called "language" and not "languages" like you have. Please try that and let us know if this resolves the issue.


Please search our forums, before posting!

Share this post


Link to post
Share on other sites
loiborg    0
loiborg

Now the path is wp-content/plugins/pagelines-customize/language/da_DK.po - doesn't seem to work.

Share this post


Link to post
Share on other sites
Danny    1,327
Danny

Can you provide the following please.

 

A link to the site in question.

Enable PageLines debug - PageLines > Site Options > Debug

Disable all non-PageLines plugins


Please search our forums, before posting!

Share this post


Link to post
Share on other sites
loiborg    0
loiborg

Hi Danny,

 

Unfortunately I can't do that. The site is not live (using a maintenance plugin) and I can't set it live until it's ready.

 

I could set up a user for you - would that work? I don't want to post the URL here since I don't want the topic to end up on search engines when searching for the domain name.

 

I have now enabled the debug.

Share this post


Link to post
Share on other sites
Rob    547
Rob

Hi,

 

Danny's not in today, so I've sent him a message alerting him to your question.


Former PageLines Moderator, Food Expert and Raconteur

Share this post


Link to post
Share on other sites
Danny    1,327
Danny

@loiborg,

Can you send me all the files you're using please, so I can attempt to translate my test site, also, in the email can you enable PageLines debug and take a screenshot of all the settings.

 

Email me at danny at pagelines dot com


Please search our forums, before posting!

Share this post


Link to post
Share on other sites
Danny    1,327
Danny

Hi Christian,

 

I have successfully translated parts of my test site into Danish using the exported language from the Translation Centre. Here is what I did.

 

First of all you were missing the .mo, you need to go to the Translation Center and export the file as a .po which you already have and as a .mo. I called the files the following:

 

 

da_DK.mo
da_DK.po
 
I then uploaded these files to /wp-content/plugins/pagelines-customise/language/
 
Then I opened the wp-config.php file and where:
 
define('WPLANG', '');
 
I changed to this:
 
define('WPLANG', 'da_DK');
 
I then cleared by browsers cache, and parts of the site were translated (see image below and the search filed label) which is no longer "Search" but "Søg".
 
 
Also, on your PL Debug mode info, you have the following:
 
PHP Open basedir restriction : Yes!  <=== This can cause PHP to refude to open certain files.
 
PHP Magic Quotes gpc : Yes (bad)  <=== This has been completely removed as of PHP version 5.4
 
I recommend you contact your host and ask them to resolve the open_basefir and to upgrade your PHP, so magic quotes is removed.

Please search our forums, before posting!

Share this post


Link to post
Share on other sites
loiborg    0
loiborg

Hi Danny,

 

You are absolutely correct, I was missing the .mo - don't know how I missed that. Thanks a lot for the time and great answer!

I will definitely contact my host about the PHP-stuff - thanks for the heads up and the links!

 

In the first post in this thread I asked about front end translation only - is this possible?

I also saw that on the page, where PageLines announced the translation feature (*), there was a suggestion to split translations between front- and back end. How is this done? The progress in the Danish translation is very low and it doesn't make sense to translate the back end, as every Dane speaks English.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


  • Similar Content

    • DonRicardoRVM
      By DonRicardoRVM+
      ¿Where can  I translate the english items "Orders", "Adress", "Payment Methods". "Edit Account" and "Sing Out"of the my account page of the plugin Quickshop? In the po file they are not.
      I think that it have relation with this error: "Your theme version of my-account.php template', '2.6', 'the latest version, which supports multiple account pages and navigation, from WC 2.6.0".

      I use the Frame Work Pagelines´s Child theme for platform 5.

    • DonRicardoRVM
      By DonRicardoRVM+
      I need to translate the quickshop plugin to spanish, but I can´t do it. I edit the pot file, and compile the spanish translation in es_ES.mo and es_ES.po, bu it doesn´t works.
      Pleasu, could somebody help me?
    • reklov79
      By reklov79+
      Hi,
      Meganav seems to have a bug if you upload a Logo with a higher resolution (which actually is useful as it looks then sharper on mobile phones). But on mobile the Logo is then larger than on a desktop. Problem is the following code in the meganav style.css. Simply the "height: auto !important" needs to be removed.
      @media (max-width: 480px) { style.css?ver=5.0.14:133 body .meganav-logo img{ height: auto !important; } } But how to achieve that? What is the standard method for customizing that? Overriding via CSS / LESS doesn't work - in this case especially because of the !important derictive used in the original CSS I believe.
      Changing the original CSS is something I don't want to do as it leads into issues when upgrading.
      Btw: I seem not to be the only one with that issue - anyhow, the solution here (not displaying the Logo on mobile) is not acceptable for me.
      Thanks,
      Volker
       
    • Kedark
      By Kedark+
      Hello, when you update the DMS to the latest version 2.2.4, unfortunately, does not work translation theme. Has anyone encountered this? It looks as if the file with the translation was not read .. everything is in the original language. (Wordpress is also updated to the latest version)
      Help....
      RKA
×