Jump to content
Sign in to follow this  
trisquelmedia

Website with pagelines framework 2.4 with all plugins deactivated - Load 56M PHP Memory , is normal?

Recommended Posts

trisquelmedia

Hi:

 

My limit is 128 MB, and few plugin installed the limit is reached ,any solution?

 

website: tqmdesarrollo.com/anembe

 

Regards

Share this post


Link to post
Share on other sites
Danny

Hi,

 

If you view your debug info, you can see that you have a number issues related to how your server has been configured.

 

http://www.tqmdesarrollo.com/anembe/?pldebug=1

 

For example, the following are not correct on your server configuration.

 

PHP Open basedir restriction : Yes!

PHP Register Globals : Yes (bad)
PHP Magic Quotes gpc : Yes (bad)
PHP type : Apache2handler
 
You also have:
 
PHP User : Posix functions are disabled on this host!
 
Posix is part of the PHP core and has for some reason been disabled by your host.
 
And finally, the sections plugin is disabled, therefore, I recommend you contact your host and ask them to resolve the following configuration issues. Only your host can resolve these.

Please search our forums, before posting!

Share this post


Link to post
Share on other sites
trisquelmedia

ok.

 

but with this changes php load down?

 

However this variables is ok , isnt it?

 

PHP Open basedir restriction : Yes!

PHP type : Apache2handler
 
I talk with my host to activate Poxix functions and deactivate magic quotes

Share this post


Link to post
Share on other sites
greenfly

OK - let us know how you get on 


The answer to many issues can be found by searching in the forum before posting as someone else  may very well have had the same problem before you have.  Also, reading the documentation can help you gain a good understanding of how everything works. 

 

Please do not send me private messages. Occam's razor - The principle states "Keep things simple!"

Share this post


Link to post
Share on other sites
trisquelmedia

Poxix functions cant activate, security reasons

Global Functions disabled

Magic Quotes disabled

 

The server PHP load is the same :-(

 

The URL that you provide (tqmdesarrollo.com/anembe) is the test site, the changes are implemented in production site (is a replica), because there I cant disable the plugins, I say if the debug you see the variables without updating.

 

Any idea?

Share this post


Link to post
Share on other sites
James B

Will the host not allow you to up the limit then? To 256mb etc?

 

Do you know if your host uses suhosin? Suhosin is set to block php scripts and that can raise the memory limit.

 

Check this thread our developer commented on, it might be able to help with some other pointers - http://www.pagelines.com/forum/topic/25083-apache-hangs/?hl=php+memory#entry146241


Kindly search the forum and read the documentation before posting. It will help you resolve many issues.

For CSS help be sure to check out W3Schools first and be sure to download FireBug for FireFox for troubleshooting.

James B

Share this post


Link to post
Share on other sites
trisquelmedia

No, the limit is 128M

Sushohin is enabled, i dont understand the PHP consumption is so high, no way to see that is generating this high consumption?

Share this post


Link to post
Share on other sites
Danny

128MB should be more than enough, as from our tests on average PageLines requires no more than 45MB, depending on PHP version. Therefore, if you have 128MB and you have ran out of PHP allocated memory, then you must have a lot of plugins active.

 

Also, the following still hasn't been resolved.

 

 

PHP Open basedir restriction : Yes!
PHP Register Globals : Yes (bad)
PHP Magic Quotes gpc : Yes (bad)
 

Please search our forums, before posting!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this  

×