Jump to content
Sign in to follow this  
derick

Shortcodes not working

Recommended Posts

derick    0
derick

Hi there,

I am trying to enable both a grid and an accordion via the shortcode in one of my pages.

I have lifted the code directly from the tools page http://demo.pagelines.me/tools/ but neither is displaying.

I am pasting the code into the Text editor and have used the [pl_raw] wrap as well. I have tried disabling all my plugins, but still cant get the grid/accordion to display. 

The page for the accordion is: http://www.sqaacademy.org.uk/sslnwordpress/?page_id=292 and the password is test

Many thanks

Share this post


Link to post
Share on other sites
greenfly    230
greenfly

Hi Derick 

 

When you paste in the code - make sure you are on the text mode as this allows you enter the code. 

 

http://screencast.com/t/LXPmPntK 


The answer to many issues can be found by searching in the forum before posting as someone else  may very well have had the same problem before you have.  Also, reading the documentation can help you gain a good understanding of how everything works. 

 

Please do not send me private messages. Occam's razor - The principle states "Keep things simple!"

Share this post


Link to post
Share on other sites
Danny    1,327
Danny

Hi,

 

If the code is appearing on your page like it currently is, you're adding the code to the visual editor and not the text one, see my image.

 

http://d.pr/i/6EFT


Please search our forums, before posting!

Share this post


Link to post
Share on other sites
derick    0
derick

Hi, 

Thanks for your quick replies!

I am entering the code into the text editor (as mentioned in first post) not the visual one. I am not even touching the visual editor at all. 

Here is a screen shot: http://d.pr/i/5Q5F

 

Any ideas?

Share this post


Link to post
Share on other sites
greenfly    230
greenfly

Try removing the code by cutting it and then ensure you have the text editor selected and then paste the code back in. 


The answer to many issues can be found by searching in the forum before posting as someone else  may very well have had the same problem before you have.  Also, reading the documentation can help you gain a good understanding of how everything works. 

 

Please do not send me private messages. Occam's razor - The principle states "Keep things simple!"

Share this post


Link to post
Share on other sites
derick    0
derick

Hi Martin, 

I tried your suggestion but it didn't make any difference. 

I have also disabled the visual editor via my user profile, again didn't make a difference :/

Share this post


Link to post
Share on other sites
Danny    1,327
Danny

Are you copying the code straight from the demo site to your page editor or using an application before hand ?

 

As the way you're adding the code is not correct, for some reason is it not being correctly formated and Wordpress thinks its text, so that is why it is being displayed on your page.

 

I have just copied the code from the page you linked and added it to a test page and the accordion worked fine.

 

http://d.pr/i/BK3b

 

Therefore, if try again but this time copy the code straight from out documentation here - http://support.pagelines.me/docs/miscellaneous/shortcodes/

to your Page editor and see if this resolves your issue.

If that doesn't resolve your issue, disable all non-PageLines plugins and try again.


Please search our forums, before posting!

Share this post


Link to post
Share on other sites
derick    0
derick

Hi Danny, 

 

I am copying straight from the documentation into my page editor, I am not pasting it anywhere else before hand. 

 

I had previously disabled all plugins and tested to see if that resolved the issue and it didn't work. 

 

I have just disabled them again, so at present my site isn't running any plugins. 

Share this post


Link to post
Share on other sites
greenfly    230
greenfly

Hi Derick 

 

Can you create a logon with admin privileges and send the details to hello@pagelines.com and i will investigate further for you. 


The answer to many issues can be found by searching in the forum before posting as someone else  may very well have had the same problem before you have.  Also, reading the documentation can help you gain a good understanding of how everything works. 

 

Please do not send me private messages. Occam's razor - The principle states "Keep things simple!"

Share this post


Link to post
Share on other sites
derick    0
derick

Hi all,

Resolved! I had missed a wordpress update, so once I upgraded to the latest version of wordpress the shortcodes are now working.

Thanks for everyones help

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this  

  • Similar Content

    • John Olsson
      By John Olsson+
      We're often working with ACF (https://www.advancedcustomfields.com/) that's great for user experience in the backend, 'cause we don't want out clients to be in the editor to much.
      So we want to be able to use shortcodes in the editor fields, regardless of section, THIS WOULD BE SO GREAT. Is there a way to fix this, it should open up som much more functionality.
      In ACF, the shortcode is for example: 
      [acf field="field_name"] ...for example, I want to att field_names value to display in a section, i understand I can make it in embed and so, but I want it in titles and options, the whole range.
      I know I can build my own sections, that we've done, but it's not very effective, and thats what PL5 is about.
      Any ideas on this, can Pagelines take this in the core? I guessing there are more than just ACF out there who can use this.

    • DonRicardoRVM
      By DonRicardoRVM+
        First of all, sorry for my bad English.  I am developing an ecommeece with wp, woocommerce, PL5 and quickshop, and I need to do some changes in the simple product grid. I want to change the classes of some divs, but I can't find the templates. 
      Also, I change the grid of the category products pages, but I didn't make it correctly.
      This is the cat archive's: http://globosdemar.com/wp/categoria-producto/camisetas-para-ninos-y-ninas/
      Can you help me?
    • jojoking
      By jojoking+
      I have to admit to being baffled.
      I'm trying to embed a video (from my WP media library) within a WP post using the videobox section shortcode.
      The shortcode section popup only allows two items to be configured - the section type, in this case videobox - and a unique id. There's no URL or other parameters such as autoplay or loop which are available within the Pagelines editor.
      Whatever I put in the unique ID makes no difference to what is shown which seems to be a default video with stars or white noise on a black background.
      I assume I need to define this ID somewhere else, or maybe WP has done it for me?
      HELP!
       
      PS This is the page source generated when a shortcode is added within the WP post editor
      <!-- VideoBox | Section --> <section id="videobox_1675853156" class="pl-sn pl-col-sm-12 pl-col-sm-offset-0 pl-sn-videobox" data-object="PL_VideoBox" data-clone="1675853156" data-level="0"><div class="pl-sn-wrap"><div class="pl-sn-pad fix" data-bind="pledit: true" > <div class="video-highlight"><h3 class="video-title" data-bind="pltext: vb_title"></h3></div> <div class="pl-video-box" data-bind="plcallback: { vb_autoplay: vb_autoplay(), vb_loop: vb_loop(), vb_controls: vb_controls(), vb_video: vb_video()}" data-callback="videobox"> <video id="280414138" autoplay loop > <source src="https://www.handinhandmanchester.org.uk/wp-content/plugins/pl-section-videobox/default.mp4?r=280414138" type="video/mp4" /> No browser html5 video. </video> <script> jQuery('#280414138')[0].load(); </script> </div> </div></div></section> </div>  
      If I add a videobox section using the Pagelines page editor the page source generated includes my video:
      <!-- VideoBox | Section --> <section id="videobox_udvu4uz" class="pl-sn pl-col-sm-12 pl-col-sm-offset-0 pl-sn-videobox" data-object="PL_VideoBox" data-clone="udvu4uz" data-level="0"><div class="pl-sn-wrap"><div class="pl-sn-pad fix" data-bind="pledit: true" > <div class="video-highlight"><h3 class="video-title" data-bind="pltext: vb_title"></h3></div> <div class="pl-video-box" data-bind="plcallback: { vb_autoplay: vb_autoplay(), vb_loop: vb_loop(), vb_controls: vb_controls(), vb_video: vb_video()}" data-callback="videobox"> <video id="429558737" autoplay loop > <source src="https://www.handinhandmanchester.org.uk/wp-content/uploads/2017/04/HIHWelcome.mp4?r=429558737" type="video/mp4" /> No browser html5 video. </video> <script> jQuery('#429558737')[0].load(); </script> </div> </div></div></section>  
    • bnapoli
      By bnapoli+
      On my site www.anewbeginning.com the "toggle" function mysteriously stopped working.  I have tried all browsers, tried disabling plugins, removing all the relevant CSS but still cant understand why it isn't working.
      The toggle is placed on this page: http://anewbeginning.com/?page_id=15965 and http://anewbeginning.com/?page_id=10779 but it does not display.
      On my other Platform5 websites, that exact code works fine: see here http://4aa.d11.myftpupload.com/?page_id=123
      Code is the same. Please help, thank you!
    • Samuel Costa - UDF
      By Samuel Costa - UDF+
      Hi.
      I need a shortcode activate a popup windows with contact form. It is possible without code?
      Link: https://www.udf.org.br/lancamentos/curso-mulher-que-prospera/
      Button: FAÇA SUA INSCRIÇÃO.
      Tks
×