Jump to content
Sign in to follow this  
dutch

morefoot not drilling down within blog posts and need a fix for bbpress

Recommended Posts

dutch

.blog #morefoot {display:none;} works fine for the first page, but as soon as you click a link to either view categories or an actual post it appears again. Plus I have bbpress integrated but have the problem of not being able to move the three columns. Does anybody have a solution?

Share this post


Link to post
Share on other sites
catrina

Hi, I looked at it and the problem is that the CSS code is written incorrectly. Replace

.blog #morefoot {display:none;}
with
div#morefoot {display:none;}

and that box should disappear for all posts and pages.


Please read the docs before posting. Please do not private message me unless I ask you to.

Designer | Catrina Dulay

Founder | Catrina and Mouse

Share this post


Link to post
Share on other sites
dutch

Hi Catrina, Reading through my original query I can see that I didn't mention that I needed the three columns on the home page but not throughout the site. The basic post pages were simple to take them away - through the admin. Unfortunately the admin feature of switching it off didn't work for the blog or forum sections - hence using .blog #morefoot... which worked fine for the first page of the blog but as soon as you drill down it breaks. As for the forum I just need a solution. I still want the #morefoot on the home page just not on the rest.

Share this post


Link to post
Share on other sites
catrina

Okay, sorry about that. I figured out a new solution. To change the coding so that the box with the columns only shows up on the Home page, you need to do the following: 1) Replace the CSS code that I gave you previously with this one:

div#individualfoot {display:none;}
2) Go to where you edit the HTML for the single post and find this code:
<div id="morefoot" class="fboxes fix">
. The "morefoot" needs to be changed to "individualfoot" so that the coding looks like this:
<div id="individualfoot" class="fboxes fix">

3) Go to where you edit the HTML for the single pages and repeat step 2. All of the boxes with columns should be wiped out except for the one displayed on the Home page.


Please read the docs before posting. Please do not private message me unless I ask you to.

Designer | Catrina Dulay

Founder | Catrina and Mouse

Share this post


Link to post
Share on other sites
catrina

In Appearance on the WordPress panel, go to "Editor" and once you're there, you should see a list of links on the right where you can edit the HTML coding for specific pages. Click on the link that says "Single Post" and you will be able to perform Step 2. To perform Step 3, click on "Page Template".


Please read the docs before posting. Please do not private message me unless I ask you to.

Designer | Catrina Dulay

Founder | Catrina and Mouse

Share this post


Link to post
Share on other sites
dutch

Hi Catrina Not getting anywhere I'm afraid. The pages you list are .php that refer to other php referring to other php's and within each I cannot locate the div's to replace. There is only one global - morefoot.php Could this be the one?

Share this post


Link to post
Share on other sites
dutch

<?php if(m_pagelines('full_width_widget', $post->ID) && VPRO):?> <div id="fullwidth_bottom_widgets" class="widget"> <?php if (!function_exists('dynamic_sidebar') || !dynamic_sidebar('Full-Width Bottom Sidebar')) : ?> <div class="widget"> <p class="subtle"><?php _e('Full width widgets selected but no widgets have been added.',TDOMAIN);?></p> </div> <?php endif;?> </div> <?php endif;?> <div class="clear"></div> <?php global $bbpress_forum; if(($bbpress_forum && pagelinesforum('hide_bottom_sidebars')) || !pagelines('bottom_sidebars') || pagelines('hide_bottom_sidebars', $post->ID)) $hide_footer = true; else $hide_footer = false; ?> <?php if(!$hide_footer && VPRO):?> <div id="morefoot" class="fboxes fix"> <div class="fboxdividers fix"> <div class="fbox"> <div class="fboxcopy"> <?php if ( !function_exists('dynamic_sidebar') || !dynamic_sidebar('Footer Left') ) : ?> <?php if(!pagelines('sidebar_no_default')):?> <h3><?php _e('Looking for something?', TDOMAIN);?></h3> <p><?php _e('Use the form below to search the site:', TDOMAIN);?></p> <div class="left p"><?php include (THEME_LIB . '/_searchform.php'); ?></div> <div class="clear"></div> <p><?php _e('Still not finding what you're looking for? Drop a comment on a post or contact us so we can take care of it!', TDOMAIN);?></p> <?php endif;?> <?php endif; ?> </div> </div> <div class="fbox"> <div class="fboxcopy"> <?php if ( !function_exists('dynamic_sidebar') || !dynamic_sidebar('Footer Middle') ) : ?> <?php if(!pagelines('sidebar_no_default')):?> <h3><?php _e('Visit our friends!', TDOMAIN);?></h3><p><?php _e('A few highly recommended friends...', TDOMAIN);?></p>

  • <?php wp_list_bookmarks('title_li=&categorize=0'); ?>
<?php endif;?> <?php endif; ?> </div> </div> <div class="fbox"> <div class="fboxcopy"> <?php if ( !function_exists('dynamic_sidebar') || !dynamic_sidebar('Footer Right') ) : ?> <?php if(!pagelines('sidebar_no_default')):?> <h3><?php _e('Archives', TDOMAIN);?></h3><p><?php _e('All entries, chronologically...', TDOMAIN);?></p>
  • <?php wp_get_archives('type=monthly&limit=12'); ?>
<?php endif;?> <?php endif; ?> </div> </div> </div> </div><!-- Closes morefoot --> <?php endif; ?>

Share this post


Link to post
Share on other sites
catrina

In the code you just pasted above, there's this code:

<div id="morefoot" class="fboxes fix">
(control+F or command+F so that you can spot it easily since it's buried in there) Please replace "morefoot" with "individualfoot" so that the code ends up looking like this:
<div id="individualfoot" class="fboxes fix">
Then, make sure that the CSS in the header is this:
div#individualfoot {display:none;}


Please read the docs before posting. Please do not private message me unless I ask you to.

Designer | Catrina Dulay

Founder | Catrina and Mouse

Share this post


Link to post
Share on other sites
dutch

okay. Code in place, but it has knocked out the home page (morefoot)!

Share this post


Link to post
Share on other sites
catrina

Did you only change the

<div id="morefoot" class="fboxes fix">
to
<div id="individualfoot" class="fboxes fix">
for the Single Post? Also, please double check to make sure that only
div#individualfoot {display:none;}
is in the CSS and that
div#morefoot {display:none;}

is not there.


Please read the docs before posting. Please do not private message me unless I ask you to.

Designer | Catrina Dulay

Founder | Catrina and Mouse

Share this post


Link to post
Share on other sites
dutch

The div changed correctly in the php Ive added the CSS to the CSS custom option in iPro4 i.e. in the WP admin area. I've looked in the other .CSS's in the folders through FTP and can't find nothing!

Share this post


Link to post
Share on other sites
catrina

I'm finding that the solution is still wiping out the box with columns in all pages. Even if the coding for that box for a Single Post is edited, it's affecting the box on the Home page, too. Please delete this:

div#individualfoot {display:none;};

For now, I'll keep re-working it to see what could be the problem.


Please read the docs before posting. Please do not private message me unless I ask you to.

Designer | Catrina Dulay

Founder | Catrina and Mouse

Share this post


Link to post
Share on other sites
catrina

Hi, Can you remove the following code out of the Single Post HTML to see if the box is also being removed from the Home page?:

	<?php if(m_pagelines('full_width_widget', $post->ID) && VPRO):?>
	<div id="fullwidth_bottom_widgets" class="widget">
	<?php if (!function_exists('dynamic_sidebar') || !dynamic_sidebar('Full-Width Bottom Sidebar')) : ?>
	<div class="widget">
	<p class="subtle"><?php _e('Full width widgets selected but no widgets have been added.',TDOMAIN);?></p>
	</div>
	<?php endif;?>
	</div>
	<?php endif;?>
	<div class="clear"></div>
	
	<?php
	
	global $bbpress_forum;
	if(($bbpress_forum && pagelinesforum('hide_bottom_sidebars')) || !pagelines('bottom_sidebars') || pagelines('hide_bottom_sidebars', $post->ID)) $hide_footer = true;
	else $hide_footer = false;
	?>
	<?php if(!$hide_footer && VPRO):?>
	<div id="morefoot" class="fboxes fix">
	<div class="fboxdividers fix">
	<div class="fbox">
	<div class="fboxcopy">
	<?php if ( !function_exists('dynamic_sidebar') || !dynamic_sidebar('Footer Left') ) : ?>
	<?php if(!pagelines('sidebar_no_default')):?>
	<h3><?php _e('Looking for something?', TDOMAIN);?></h3>
	<p><?php _e('Use the form below to search the site:', TDOMAIN);?></p>
	<div class="left p"><?php include (THEME_LIB . '/_searchform.php'); ?></div>
	<div class="clear"></div>
	<p><?php _e('Still not finding what you're looking for? Drop a comment on a post or contact us so we can take care of it!', TDOMAIN);?></p>
	<?php endif;?>
	<?php endif; ?>
	</div>
	</div>
	
	<div class="fbox">
	<div class="fboxcopy">
	<?php if ( !function_exists('dynamic_sidebar') || !dynamic_sidebar('Footer Middle') ) : ?>
	<?php if(!pagelines('sidebar_no_default')):?>
	<h3><?php _e('Visit our friends!', TDOMAIN);?></h3><p><?php _e('A few highly recommended friends...', TDOMAIN);?></p>
	
	      <?php wp_list_bookmarks('title_li=&categorize=0'); ?>
	
	<?php endif;?>
	<?php endif; ?>
	</div>
	</div>
	
	<div class="fbox">
	<div class="fboxcopy">
	<?php if ( !function_exists('dynamic_sidebar') || !dynamic_sidebar('Footer Right') ) : ?>
	<?php if(!pagelines('sidebar_no_default')):?>
	<h3><?php _e('Archives', TDOMAIN);?></h3><p><?php _e('All entries, chronologically...', TDOMAIN);?></p>
	
	      <?php wp_get_archives('type=monthly&limit=12'); ?>
	
	<?php endif;?>
	<?php endif; ?>
	</div>
	</div>
	</div>
	</div><!-- Closes morefoot -->
	<?php endif; ?>
	

I need to see if removing it would produce different results.


Please read the docs before posting. Please do not private message me unless I ask you to.

Designer | Catrina Dulay

Founder | Catrina and Mouse

Share this post


Link to post
Share on other sites
dutch

okay replaced the code as was before we started as you said. Have now taken away the code from the last request. The morefoot is back on all pages.

Share this post


Link to post
Share on other sites
catrina

Okay, I see that taking away the code made no difference. I might have the solution, but it might be easier for me to get in there to see what's going on and solve the problem. Would you mind? Also, thank you for your patience.


Please read the docs before posting. Please do not private message me unless I ask you to.

Designer | Catrina Dulay

Founder | Catrina and Mouse

Share this post


Link to post
Share on other sites
dutch

okay I have set up an admin account - should I post here or email?

Share this post


Link to post
Share on other sites
catrina

Go ahead and send the account info to catrinadulay[at]gmail.com and then I'll log in and try to dissect the problem. Thank you.


Please read the docs before posting. Please do not private message me unless I ask you to.

Designer | Catrina Dulay

Founder | Catrina and Mouse

Share this post


Link to post
Share on other sites
bryan-hadaway

There was never any need to hard code anything, this was all too unnecessary, if you can recover/revert all code back to it's original place, you only need to add a few lines of CSS to: Theme Options > Custom Code > Custom CSS: ` #morefoot{display:none} .home #morefoot{display:inline} ` and if that looks messed up at all, use this instead: ` #morefoot{display:none} .home #morefoot{display:block} ` Thanks, Bryan

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this  

×