Jump to content
barzeen

Buddypress CSS Problems

Recommended Posts

barzeen

For the life of me I can't get Buddypress pages to not break my CSS. I finally had a breakthrough by adding this code to the custome code header section on pagelines settings backend.

<link media="all" type="text/css" href="http://fhs.myyearstream.net/files/pagelines/compiled-css-1360575606.css" id="pagelines-less-css" rel="stylesheet">

 

It fixed the CSS on Google Chrome, and only Google Chrome. Safari, Firefox, and IE are still broken. I attached the screenshot of what it looks like. I have done the steps for buddypress and page lines, 1,000,000 times. I hope the code above can help people figure out my problem .

post-27949-0-92129300-1360707459_thumb.j

Share this post


Link to post
Share on other sites
Simon

Not really going to help much, that file is the compiled css, if you save ANY option in the backend the css hash number will be different and the css filename will change.

 

Unfortunately I found it impossible to view your site as it seems to be just a login page. Is there a correct URL to use?

Share this post


Link to post
Share on other sites
barzeen

I sent you a pm with my credentials. Did you get it?

Share this post


Link to post
Share on other sites
Rob

I don't believe Simon received them before going home for the evening.  I will send him a reminder for the morning.

 

Thanks.


Former PageLines Moderator, Food Expert and Raconteur

Share this post


Link to post
Share on other sites
Simon

Yes i logged in and enabled buddypress, your server is giving a 500 error for the file http://www.myyearstream.net/wp-content/themes/pagelines/pagelines-compiled-css-1_1358493704/

 

Cant really help more until you do the following:

  1. Disable the cache. Makes everything we do to try and debug absolutely impossible. Are you getting 100's of 1000's of unique visiters per hour?
  2. View the server logs to see what the 500 error means.

Share this post


Link to post
Share on other sites
barzeen

Well it works now. Someone told me to add this to my wp-config 

define( 'PL_NO_DYNAMIC_URL', true );

 

Any possibile problems with this solution?

Share this post


Link to post
Share on other sites
James B

Hi Barzeen,

 

No problems with this solution as far as I'm aware. Glad you got it sorted :-)

 

Ref: http://www.pagelines.com/forum/topic/24608-less-compiler-500-internal-server-error/?hl=css+error+500#entry143459


Kindly search the forum and read the documentation before posting. It will help you resolve many issues.

For CSS help be sure to check out W3Schools first and be sure to download FireBug for FireFox for troubleshooting.

James B

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


  • Similar Content

    • chamois_blanc
      By chamois_blanc+
      Hello,
      Shouldn't the image PL5 component be using the srcset/picture css directives to pick the correct size for an image? or it does already and I don't know how to use it? Thank you for any advice or enlightenment.
    • Dan Haddock
      By Dan Haddock
      Plugins Active and installed: 
      Akismet Anti-Spam
      Coming Soon Page & Maintenance Mode by SeedProd
      Contact Form 7
      Cookie Law Info
      DMS Professional Tools  
      Enhanced Media Library  
      Flamingo
      Google Analytics for WordPress by MonsterInsights
      Google XML Sitemap
      Jetpack by WordPress.com
      Legull 
      Loginizer   
      MailChimp for WordPress
      PageLines Updater    
      Schema App Structured Data 
      Sucuri Security - Auditing, Malware Scanner and Hardening
      Uber reCaptcha    
      Yoast SEO
      Wordpress Version: 4.8.1
      Pagelines Version: 2.2.4
       
      Good Evening/Afternoon or Morning, 
      I am running into a problem with CSS styling not applying inside of most browsers (Safari, Firefox) when I am logged in to wordpress, and all browsers that I have tested when I am logged off and the site has been made public (Chrome, Firefox and Safari).
      As a result, I have managed to identify the probable cause. It looks as though these browsers are refusing to render my sites compiled CSS file due to it being a HTTP URL rather than HTTPS.
      I have attempted to change this URL to HTTPS in my browser, however it brings back an ERROR: File not found page - https://www.shortfilmblog.com/wp-content/uploads/pagelines/compiled-css-core-1505847507.css
      What would you suggest in this regard? Would this be resolvable from your end?
      Happy to provide any further details required.
    • Borries
      By Borries+
      I know this is not an easy problem. Maybe there is a easy solution.
      I have tryed to uses the existing solution, that I have found in the forum
      I changed the colours of my nav (simple nav) and the hover effect (a. hover).
      I really tryed to highlight the active/used link in the nav but I cant figure it out.
      I want it to be black when active.
      Any help would be appreciated. Thanks.
      http://www.marcborries.de  nav link: "Sinn & Selbst" 
    • Michael Kummer
      By Michael Kummer+
      Hi guys,
      every since Chrome introduce scroll anchoring (see chrome://flags) blog posts on my page start scroll automatically as soon as the user scrolls down a bit. It is super annoying and I don't know exactly what triggers the incompatibility with Chrome's latest feature that is supposed to improve usability.
      Since I don't know what causes it (Pagelines, or a Plugin), I would like to disable the feature using a CSS override that Google describes as follow:
      "Scroll anchoring aims to be the default mode of behavior when launched, so that users benefit from it even on legacy content. A CSS property overflow-anchor can disable scroll anchoring in part or all of a webpage (opt out), or exclude portions of the DOM from the anchor node selection algorithm. This property supports the following values when applied to an element E:
      overflow-anchor: auto (the default value) declares that the DOM subtree rooted at E is eligible to participate in the anchor node selection algorithm for any scrolling box created by E or an ancestor of E. overflow-anchor: none declares that the DOM subtree rooted at E is not eligible to participate in the anchor node selection algorithm for any scrolling box created by E or an ancestor of E." Do you guys happen to know how to use that property with the ROOT element so it applies to the whole page?
      Thanks
      Michael 
    • wyo22ski
      By wyo22ski+
      Hello,
       
      I'm basically a designer and understand a little on how to change CSS, etc., so please excuse my ignorance...  I recently upgraded to the newest platform from the DMS and my old DMS theme no longer functions.  I'm trying to replace the image slider that my Horizon Photography Theme (Nick Haskins) had created.  The Impulse image slider seemed the closest to what I need, but there are problems.
      It seems the the Impulse section for sliding images defaults to the image width, no the height.  I can change the Impulse stage height and width, but this does nothing to the internal content.  For instance, if I change the height to 200 pixels, the image remains the full width and only shows a cropped section.  I would like the ability to change the Impulse height, and have the image height fit space. 
      I've put this custom CSS in, but again, this only controls the stage height of Impulse:
      .pl-sn-impulse .pl-impulse-cell .cell-wrap, .pl-impulse-container, .owl-stage-outer {
        width: 100%;
      }
       
      Any suggestions welcome.  Thanks 
×