Jump to content
revoltoid

Compiled CSS not found 404

Recommended Posts

revoltoid    1
revoltoid

Hello,

 

Can you guys please help me with this problem,

 

The CSS file fails to load every third (or so) time. It occurs on any pages on my site randomly but consistently.

 

I have checked the source in Firebug and it is looking for the file in this line:

 

wp-content/uploads/pagelines/compiled-css-1360606434.css

 

You can see it in around the 60th line in the source.

 

 

However, the file that I have in that folder on the server is named differently, so no CSS loads resulting in the usual plain html look when there is no CSS file.

If I stay on the page and refresh it, the correct CSS file appears in the script and it loads fine.

 

What to do?

 

Thank you,

 

Istvan

 

site: http://imagyarweddings.com

Share this post


Link to post
Share on other sites
Simon    247
Simon

You are using a 3rd party cache plugin, disable that 1st and see if the problem persists.

Share this post


Link to post
Share on other sites
revoltoid    1
revoltoid

Hi Simon,

 

I think I have tried it with cache plugin off and the error occurred, but I try it again, just to make sure I am right. Back with the results soon. 

Share this post


Link to post
Share on other sites
revoltoid    1
revoltoid

Hmm, it seems that without the cache plugin, it looks up the correct CSS file and loads fine.

 

Strange, because I have been using this cache plugin for quite a long time and it's been working fine.

 

Should I try to uninstall and install the plugin again?

Share this post


Link to post
Share on other sites
revoltoid    1
revoltoid

Wait, Simon,

I have just seen it loading without CSS again.

I have been loading pages for about 5 minutes without problems, then I tried on an iPad as well.

The 5th time I tried it loaded a page without CSS. I immediately checked on the desktop computer and the same page came html only!

All I did in between was, that I have changed a setting in the Pagelines Global Settings (arrows on dropdown).

The very next page came without CSS.

Share this post


Link to post
Share on other sites
revoltoid    1
revoltoid

I observed it.

Every time I save settings in the Pagelines panels, the CSS file name changes (which is normal I guess) and/but the script is looking for the recent one with the old name and because that is no more, no CSS loads. If I refresh the page, the correct file loads. If I change and save a setting on the Pagelines panels, file name changes, CSS not found and doesn't load, till I refresh the page when the correct CSS loads.

 

Cache plugin is off.

Share this post


Link to post
Share on other sites
Simon    247
Simon

Its showing some kind of mutex lock error now.

 

When you click save in the pagelines options it should create a new css file.

Share this post


Link to post
Share on other sites
revoltoid    1
revoltoid

Is 'mutex lock error' something that indicates what the problem is and how to solve it? :)

Share this post


Link to post
Share on other sites
Simon    247
Simon

Is 'mutex lock error' something that indicates what the problem is and how to solve it? :)

No its an error produced from your cache plugin.

 

<!-- Quick Cache: failed to write cache, unable to obtain a mutex lock at the moment. Quick Cache will try again later. -->

Share this post


Link to post
Share on other sites
revoltoid    1
revoltoid

The plugin is inactive.

Is that line somewhere in the source that I can see in Firebug?

Have just checked it and there is no mention of 'cache', or 'quick cache'.

 

And by the way Simon, it doesn't save (or doesn't apply saved) settings, for example, I want the arrows on the dropdown menu to go, but regardless to the box ticked or not, the arrows are there. (global settings/header and footer/enable arrows)

Share this post


Link to post
Share on other sites
Simon    247
Simon

The line was in the page source. Its gone now anyway. I just refreshed the page 15 times and saw no errors.

Share this post


Link to post
Share on other sites
revoltoid    1
revoltoid

I changed and saved settings just now, can you please check again? There are only 7 pages on the site, can you please check them all, thank you. (I mean except the blog posts, no need to check those, just the main ones in the menu)

Share this post


Link to post
Share on other sites
Simon    247
Simon

Got this sussed, your server is sending a cache control header, so the browser always tries to cache the html, so you click save and the css url changes slightly but to the end the keep looking at the cached browser version.

 

http://screencast.com/t/N0WR5z2oKx

Your page, notice the cache length

 

This forum

http://screencast.com/t/hjFCNSa4E

 

Notice no cache, its already expired, that tells the browser do not ever cache the page. 

  • Like 1

Share this post


Link to post
Share on other sites
revoltoid    1
revoltoid

Oh. Hmm, I see.

Based on this I checked my .htaccess file and saw these lines:

 

 

ExpiresActive On
ExpiresDefault "access plus 10 days"
ExpiresByType text/css "access plus 1 week"
ExpiresByType text/plain "access plus 1 month"
ExpiresByType image/gif "access plus 1 month"
ExpiresByType image/png "access plus 1 month"
ExpiresByType image/jpeg "access plus 1 month"
ExpiresByType application/x-javascript "access plus 1 month"
ExpiresByType application/javascript "access plus 1 week"
ExpiresByType application/x-icon "access plus 1 year"
 
I guess this is the reason? (because the cache plugin is inactive, so these lines are all that can control caching, right?
 
So options and questions;
 
 
1. If I activate the cache plugin and set browser-side cache off, should it work?
2. Does 'access plus one week' for css files mean that ANYONE who visits the page within a shorter period then one week and I HAVE made changes in this period, they will see the no CSS phenomenon?
3. I am not sure that my cache plugin has written these lines into my .htaccess file, as in that case the lines would have disappeared when I deactivated it wouldn't they? So can I just delete these lines and rely on whatever the cache plugin writes into the .htaccess file?

Share this post


Link to post
Share on other sites
Simon    247
Simon

OK those lines tell the user browser how long to cache files, images, icons whatever.. So your html page is cached for 10 days.

 

The cache plugin stores a cached version on the server. Two completely different things.

 

Remove this line ExpiresDefault "access plus 10 days"

Share this post


Link to post
Share on other sites
revoltoid    1
revoltoid

Excellent,

Thank you very much Simon,

I have deleted the line and now it works with and without the cache plugin. Great!

 

Now, if you don't mind, can you please advise me on the other thing I mentioned; the dropdown arrows don't disappear if I set them off in the global settings/header and footer/enable arrows option. What can be the reason? I have checked/unchecked that option many times with or without the cache plugin.

Share this post


Link to post
Share on other sites
Simon    247
Simon

That setting is for the 'Nav Classic & BrandNav Section - Drop Down Handling'

Share this post


Link to post
Share on other sites
revoltoid    1
revoltoid

Oops I missed that detail.

Does that mean that no option exist for the arrows for the fixed navbar?

Share this post


Link to post
Share on other sites
Simon    247
Simon

Yes there is no option, you'd have to use a bit of css.

Share this post


Link to post
Share on other sites
revoltoid    1
revoltoid

That is fine, thank you.

 

And thank you for your quick help in the caching issue, it seems to be working nice and steady now.

 

Thanks again,

 

Istvan

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


  • Similar Content

    • jagipson
      By jagipson+
      404 When trying to connect site to PL

    • Michael Kummer
      By Michael Kummer+
      Hi guys,
      every since Chrome introduce scroll anchoring (see chrome://flags) blog posts on my page start scroll automatically as soon as the user scrolls down a bit. It is super annoying and I don't know exactly what triggers the incompatibility with Chrome's latest feature that is supposed to improve usability.
      Since I don't know what causes it (Pagelines, or a Plugin), I would like to disable the feature using a CSS override that Google describes as follow:
      "Scroll anchoring aims to be the default mode of behavior when launched, so that users benefit from it even on legacy content. A CSS property overflow-anchor can disable scroll anchoring in part or all of a webpage (opt out), or exclude portions of the DOM from the anchor node selection algorithm. This property supports the following values when applied to an element E:
      overflow-anchor: auto (the default value) declares that the DOM subtree rooted at E is eligible to participate in the anchor node selection algorithm for any scrolling box created by E or an ancestor of E. overflow-anchor: none declares that the DOM subtree rooted at E is not eligible to participate in the anchor node selection algorithm for any scrolling box created by E or an ancestor of E." Do you guys happen to know how to use that property with the ROOT element so it applies to the whole page?
      Thanks
      Michael 
    • wyo22ski
      By wyo22ski+
      Hello,
       
      I'm basically a designer and understand a little on how to change CSS, etc., so please excuse my ignorance...  I recently upgraded to the newest platform from the DMS and my old DMS theme no longer functions.  I'm trying to replace the image slider that my Horizon Photography Theme (Nick Haskins) had created.  The Impulse image slider seemed the closest to what I need, but there are problems.
      It seems the the Impulse section for sliding images defaults to the image width, no the height.  I can change the Impulse stage height and width, but this does nothing to the internal content.  For instance, if I change the height to 200 pixels, the image remains the full width and only shows a cropped section.  I would like the ability to change the Impulse height, and have the image height fit space. 
      I've put this custom CSS in, but again, this only controls the stage height of Impulse:
      .pl-sn-impulse .pl-impulse-cell .cell-wrap, .pl-impulse-container, .owl-stage-outer {
        width: 100%;
      }
       
      Any suggestions welcome.  Thanks 
    • Objectif-Mariage
      By Objectif-Mariage+
      Hello. 
      I have just realized that CSS (Less plugin) , is not working..... I have disable all plugins (except PL CUSTOM LESS and PL5) , and ... it's not working ... 
      It's not the first time. Usually I had trouble with a plugin name Autoptimize , but it's Desactivate now , all memory have been purge, and it's still not working! :-/ So it's not from this plugin. 
      NB : When I am logged on my website, if i go on the black wordpress dashboard bar, go on the PL icon, clic on </> LESS/CSS => then the page suddenly apply the CSS .... But As soon that i reload the page, nothing. I think the problem is that the plugin LESS/CSS does not load properly (if I can say that with my simples words).
      I order to keep the site "good looking" I have temporally copy/paste all my LESS code in a plugin : Script n Styles that apply the LESS/CSS code... but it's not a solution for long time.
      Can someone help me ? Did I do something wrong ? Is it an update ? 
       
      my website : https://www.wedding-photography-minneapolis.com
    • Jason
      By Jason+
      Feel free to delete this post if its not helpful or its just plain wrong.
       
      I though it might be useful to share how I customize the size of the builder. (reduce my eyestrain )
      1 - install stylerbot extension in chrome (stylerbot keeps this css every time you access the url)
       
      2- add this css to stylerbot for the site you are working on
      .CodeMirror {
          font-size: 14px;
          height: 600px;
      }
      .pl-workarea.pl-has-sidebar .pl-workarea-sidebar-container {
          right: 0px;
          width: 500px;
      }
      .pl-workarea.pl-has-sidebar .iframe-container {
          right: 500px ;
      }
       
      change sizes to suit.
       
      Cheers.
×