Jump to content
Sign in to follow this  

Customize Hero section

Recommended Posts


I'm trying to learn how to customize the hero section using the custom code section. I used this video http://www.pagelines.com/docs/customization-tips as a reference. I don't think I've did it correctly or I've totally mis-understood it. Below is what I've put in the customize code box. Is it correct?


.page page-id-63 .pl-hero-wrap row #hero {background-color:#orange; border:solid, 1px, pink;}



Share this post

Link to post
Share on other sites

Thanks for the quick response. I'll let you know how I get on.

Share this post

Link to post
Share on other sites

That's got me on the right path. Thanks

Share this post

Link to post
Share on other sites


Former PageLines Moderator, Food Expert and Raconteur

Share this post

Link to post
Share on other sites

I may have misinterpreted this but is it possible to have a custom hero box per page? I've been trying to do this using the following code.


#page .page-id-59 #hero .pl-hero-wrap {background-color: #9ee851;}
#page .page-id-59 #hero p {color:#ffffff}
#page .page-id-59 #hero .m-bottom {color: #ffffff;}
#page .page-id-8 #hero .pl-hero-wrap {background-color: #ff66ac;}
#page .page-id-8 #hero p {color:#ffffff}
#page .page-id-8 #hero .m-bottom {color: #ffffff;}


When I publish this code it reverts back to default. I can customize it generally but when I add page-id-x it fails.

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this  

  • Similar Content

    • reklov79
      By reklov79+
      Meganav seems to have a bug if you upload a Logo with a higher resolution (which actually is useful as it looks then sharper on mobile phones). But on mobile the Logo is then larger than on a desktop. Problem is the following code in the meganav style.css. Simply the "height: auto !important" needs to be removed.
      @media (max-width: 480px) { style.css?ver=5.0.14:133 body .meganav-logo img{ height: auto !important; } } But how to achieve that? What is the standard method for customizing that? Overriding via CSS / LESS doesn't work - in this case especially because of the !important derictive used in the original CSS I believe.
      Changing the original CSS is something I don't want to do as it leads into issues when upgrading.
      Btw: I seem not to be the only one with that issue - anyhow, the solution here (not displaying the Logo on mobile) is not acceptable for me.
    • marcuscarson
      By marcuscarson
      I'm hoping to create multiple blog pages where each one only shows posts from a specific category.
      For example:
      Page 1: site.com/category/food Page 2: site.com/category/animals Page 3: site.com/category/mineral Currently, when I try to place a masthead section with a unique title at the top of one of these pages, the same masthead section appears on all of them. I have "unlinked" the page from any sort of template, and I have tried to create a unique templates for each. In all instances, the changes I make on one appears on all the other (except for the posts that are being displayed).
      Is it possible to do what I'm trying to accomplish? Any help is appreciated.
    • bwdsl247
      By bwdsl247
      Unless I am doing something wrong, I can confirm - and can replicate on demand - that DMS has a bug that causes the following things to occur whenever I click 'Customize' or go to Themes and switch to another Theme and then go back to DMS. 
      (Danny, you'll be happy to know that before reporting this, I deactivated all my plug-ins :-)  
      See DMS debug info below confirming this. 
      Here's what happens when I click 'Customize' or switch Themes:
      1. Custom CSS/LESS is wiped out.
      2. Main site logo is replaced with DMS2 logo; other DMS sample content appears on Home page, Headers and Footer.
      3. My existing post and page text and images are still there, but all headers and footers have been replaced, and all formatting lost.
      4. Debug mode was ON before clicking 'Customize' or switching Themes; afterwards, it shows set to off.
      There are currently no other users accessing the system. 
      I can replicate it on demand and recorded a video showing what happens. I am uploading it and will post it shortly for you to see.
      Is there anything I'm doing incorrectly, or is this a bug?
      Thank you!
      DMS Debug Info WordPress Version
      WordPress Debug
      Multisite Enabled
      Current Role
      Framework Path
      Framework URI
      Framework Version
      PHP Version
      WP memory limit
      40 MB
      WP MAX memory limit
      256 MB
      PHP memory limit
      256 MB
      Mysql version
      WP Max Upload Size
      50 MB
      PHP POST Max Size
      100 MB
      PHP Max Execution Time
      PHP type
      WebServer software
      PHP User
      Posix functions are disabled on this host. Not necessarily a problem, but if the user needs FTP/SFTP to install plugins/themes then creating CSS files might be an issue.
      « Back
    • dbereit
      By dbereit
      Help! I spent several hours setting up my DMS 2 site, including some custom CSS. The only plugins running are the PageLines ones.
      I was frustrated when the Site Settings options would not allow me to save a custom text color, despite clicking the Publish button numerous times, and refreshing many times.
      I went into the WordPress dashboard, and clicked the Appearance > Customize option, thinking it might give me some additional editing options. Instead it opened the DMS tour, and wiped out ALL of the customizations I had previously set up.
      #1 question- can my work be restored?
      #2 question- will these bugs be fixed, so I don't experience these challenges in the future?
      I REALLY want to use DMS 2, but find times where it is buggy and problematic, which make me worry about long-term stability. If what happened to me today happened to a live, public site, I would be in big trouble.
    • jotaro
      By jotaro
      How can I put customized Home icon for iHeader Navigation?