Jump to content
fourdw

Jigoshop product page frustration

Recommended Posts

fourdw

Hi

 

I've setup Page Options Setup --> Product Archive --> Show BrandNav

 

This works great, showing the BrandNav on the Jigoshop pages as expected, except the individual product page.

 

Why isn't the Jigoshop product page included in the Page Options Setup? The only way I can see to enable BrandNav is by ticking Show BrandNav on each individual product.

 

Is there a way to hard code this, or perhaps use a function?

 

Thanks for any help.

Share this post


Link to post
Share on other sites
Danny

Hi,

 

Once you have added a new product go to Wordpress > JigoShop > All products and then select your product. Then scroll down and that product should have the PageLines Meta Settings, where you can show/hide sections.


Please search our forums, before posting!

Share this post


Link to post
Share on other sites
fourdw

Thanks Danny, but I was hoping for a global solution. The clients will end up with 1000's of products and I just can't see them remembering to activtate it each time. We're also using import and export csv, so this would also mean they would have to go back through each product and tick the Show BrandNav box.

 

The product page is part of Jigoshop so it should be part of the Page Options Setup --> Product Archive shouldn't it?

Share this post


Link to post
Share on other sites
Danny

The single products are not part of the Products archive template.

The best alternative would be to show BrandNav by default and hide on all other pages, so basically you will just need to go to your pages and check hide.


Please search our forums, before posting!

Share this post


Link to post
Share on other sites
fourdw

OK, I'll rethink our logic.

 

Still think there should be more control over the actual Jigoshop product page, it doesn't make sense that you're not able to do much with the product template.

 

Thanks again,

Andy

Share this post


Link to post
Share on other sites
Danny

Andy, I completely understand, I will pass your issues onto our developers for you.


Please search our forums, before posting!

Share this post


Link to post
Share on other sites
fourdw

Thought I'd share the simple solution.

 

Just put BrandNav to show by default, then turned it off in the CSS...

body.page #brandnav .content-pad {display:none;}

 

Thanks for your time today Danny.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


×