Jump to content
dduban

NavBar Menu Secondary Menu Hidden under media

Recommended Posts

dduban

After updating to the newest pagelines framework, my secondary menu is hidden under the video content on my website (http://www.njiloa.org/rules-mechanics/2013-mens-rules-video/). I've disabled all plugins and reset all of the cache items but still have the same result. 

 

I tested this on my Mac and found no issues. I tested this on my windows vista pc and ran into the issues (see attached) in both Chrome and ie9. 

post-45706-0-55086100-1358890003_thumb.j

  • Like 1

Share this post


Link to post
Share on other sites
Rob

Hi,

 

For testing purposes, would you kindly disable the hover option to see if the menu works without the hover option or if the dropdown fails even without that option.

 

Please let us know and I'll have our developer test it further.


Former PageLines Moderator, Food Expert and Raconteur

Share this post


Link to post
Share on other sites
dduban

Rob -

 

The hover option has been disabled on my site for the time being. The dropdown still fails. 

 

Dave

Share this post


Link to post
Share on other sites
Rob

Dave,

 

Just so we can diagnose this, how did you put the video on the page? Embed code, shortcode.... ?  I'd like to give my developer specifics, if you can.

 

Thanks!


Former PageLines Moderator, Food Expert and Raconteur

Share this post


Link to post
Share on other sites
dduban

Rob - 

 

Here is my code:

 

 

<div class="row">
<div class="span2"></div>
<div class="span8">[pl_video type="youtube" id="Tl10Erk95pE"]</div>
<div class="span2"></div>
</div>
 
Dave

Share this post


Link to post
Share on other sites
Rob

Dave,

 

Wrap the code you have for the video in this and rename 'auniquename' to something else you prefer with no punctuation:

<div class="auniquename">

<div class="row">
<div class="span2"></div>
<div class="span8">[pl_video type="youtube" id="Tl10Erk95pE"]</div>
<div class="span2"></div>
</div>
</div>
 
Then, in your custom code, add:
 
.auniquename {
z-index:0;
}
 
See if that works. As we'd say in Joisey... couldn't hoit.

Former PageLines Moderator, Food Expert and Raconteur

Share this post


Link to post
Share on other sites
dduban

Rob -

 

No luck. Still trapped behind the media unfortunately. 

Share this post


Link to post
Share on other sites
Rob

Dave, try it with z-index:1;

 

The menu I believe is z-index:2020;

 

So it has to be a number lower than that.  Finding just the right one can be time consuming, but one of them should resolve it.

 

Optionally, add the actual video code directly to the page without any of the shortcode or divs.


Former PageLines Moderator, Food Expert and Raconteur

Share this post


Link to post
Share on other sites
dduban

Rob -

 

Is there any update on this? It's been almost 3 weeks. 

 

I would prefer for this to be fixed as opposed to trying to find the z-index. 

 

Thanks, 

 

Dave

Share this post


Link to post
Share on other sites
Danny

Try adding this to your video:

 

?wmode=transparent

 

So the code would look like this:

 

<div class="row">
<div class="span12 tac">
[pl_video type="youtube" id="Tl10Erk95pE?wmode=transparent"]
</div>
</div>

Please search our forums, before posting!

Share this post


Link to post
Share on other sites
Simon

I looked at the page source and can see no indication at all that the user is using the pl_video shortcode.

Share this post


Link to post
Share on other sites
dduban

I actually had to remove the shortcode to get this to work a few weeks back. My plan is to start to add more content and would prefer for this to work.

 

An example of the menu behind the content can be found here: http://www.njiloa.org/rules-mechanics/2013-rules-clarifications/

 

Here is the code:

 

 

Subject: 2013 Boys Lacrosse Rules Book Clarification
Dated: 1/31/2013
 
 
post-45706-0-09530200-1360677262_thumb.j

Share this post


Link to post
Share on other sites
Simon

OK now im lost this post started out about youtube videos, and a bug was posted saying our shortcode does not include the window transparency, now its a pdf? Did you add the transparency bit to that?

Share this post


Link to post
Share on other sites
dduban

Simon I can re-create the bug for the youtube shortcode on my site if you would like. Please let me know. 

 

As for the transparency for the pdf embedded object I did not add the transparent code yet. Let me know how to add it to the code and I can put it in this morning. 

 

Either way the menu doesn't have the proper characteristics to bring it to front regardless of the page content. Perhaps it isn't a bug, but I would think that would be the default behavior for this. 

Share this post


Link to post
Share on other sites
dduban

Simon - With or without the additional code posted by Danny? 

 

It looks like it works in Chrome, but it does not work on Internet Explorer 9. That is where I took my screenshot from. 

Share this post


Link to post
Share on other sites
dduban

Perfect. I can add that. Any thoughts on how to implement this for the PDF embed mentioned above?

 

Looks like it is the same issue in IE. 

Share this post


Link to post
Share on other sites
Simon

I have no idea, that parameter is passed to youtube so the embed is different.

 

I didnt know you could even embed a pdf

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


×