Jump to content
cfravel

Slow load and no style, with or without less/dynamic_url

Recommended Posts

cfravel    0
cfravel

Using a localhost, latest build of XAMPP and latest WP:

 

1. Install WP, update to latest

2. Drop in PL Framework

3. Navigate to localhost/plframework

 

No other plugins, barebones installation, 10-15 second response time, appears to be missing CSS styling.

 

I have tried adding the following to wp-config.php, both one at a time and together, per other topics I found in the forum.

 

define( 'PL_NO_DYNAMIC_URL', true );
define( 'LESS_FILE_MODE', true );

 

The 2012 theme loads in <1 second and the CSS appears fine, so it is not a general server setup issue.

 

I believe the CSS generation is performing very slowly, because every so often (about 1 in 5 times), the styling will work.  It seems to be a race condition, where if the CSS finishes processing in time and is available, everything is happy.  But if the style generation takes too long, Apache serves the page without CSS.

 

Is there a way to force the CSS to be pre-rendered and served as a static file?  I do not need dynamic CSS generation and it's a waste of resources to generate this every page load.  It's especially painful on a development machine where it takes 15 seconds to check every code change.

 

Please advise how I can get the speed to be comparable to other WP themes and how I can ensure styling completes in a timely manner.

 

Thanks.

post-38561-0-12475900-1358113901_thumb.j

Share this post


Link to post
Share on other sites
James B    436
James B

Hi there, I'd say check what your PHP memory allocation is on the local install, it needs to be over 128mb, 256Mb if possible. As of the last two upgrades a static css file has been set to be served as default.


Kindly search the forum and read the documentation before posting. It will help you resolve many issues.

For CSS help be sure to check out W3Schools first and be sure to download FireBug for FireFox for troubleshooting.

James B

Share this post


Link to post
Share on other sites
Simon    247
Simon

By default the css is written to a file, as long as you own the folder and the framework is able to write to it.

 

define( 'LESS_FILE_MODE', true ); is on by default now you dont have to add this.

 

define( 'PL_NO_DYNAMIC_URL', true ); is only needed if permalinks are broken or not setup.

 

If you can enable the debug mode under advanced settings we may be able to help more, but fixing your localhost isnt easy as there are so many Platforms, xampp xamp mamp etc etc.

Share this post


Link to post
Share on other sites
joan54    0
joan54

So...what is the solution then...for us who are not developers?...I have exactly the same problem. Please, indicate what to change and in which file...Thank you

Share this post


Link to post
Share on other sites
Simon    247
Simon

The file is wp-config.php

Which bit of the same problem are you having?

Share this post


Link to post
Share on other sites
greenfly    230
greenfly

Hi Joan54 

 

Please could you create a new topic detailing what problems you are having including links to your site etc so we can work on a solution for your particular setup? 

 

Thank you 


The answer to many issues can be found by searching in the forum before posting as someone else  may very well have had the same problem before you have.  Also, reading the documentation can help you gain a good understanding of how everything works. 

 

Please do not send me private messages. Occam's razor - The principle states "Keep things simple!"

Share this post


Link to post
Share on other sites
joan54    0
joan54

Hi, thank you for the answers.

 

Simon,

 

my problem was exactly the one presented in the beginning of this post. Even the thumbnail member "cfravel" attached was the one I had. i am using XAMPP

 

I found another conversation here  http://www.pagelines.com/forum/topic/19869-upgrade-to-wp-3-4-and-pagesline-framework-2-2-get-screwed/?hl=localhost%20installation

and that solve my problem.

 

I added  

 

define( 'PL_NO_DYNAMIC_URL', true ); 

 

and   define('WP_MEMORY_LIMIT', '256M');    (before was      define('WP_MEMORY_LIMIT', '120M');  )

 

in my wp-config.php

 

Also i changed the value on my   php.ini     

 

memory_limit = 256M          it was set :   memory_limit = 128M

 

 

But the      define( 'PL_NO_DYNAMIC_URL', true );     was my last change and I guess that did the magic. Now it seems it is fixed and moving forward to my customization.

 

Luis

Share this post


Link to post
Share on other sites
Rob    547
Rob

Hi Luis,

 

If you've not already done so, please open a new topic. Thanks.


Former PageLines Moderator, Food Expert and Raconteur

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


×