Sidebar show all pages

6 posts in this topic

Hi folks,


My secondary sidebar (default sidebar too) shows all my site pages:


How do I disable that? Or how I can display only pages which belong to the top page, in this case 'mcafee'?


Thank you,





Share this post

Link to post
Share on other sites

Hi there, are you using the 'pages' widget in the sidebar?


You really need to look for a plugin which will display subpages for the parent page in the menu. Like might be able to help, or you could create custom menus for each parent page using appearance>menus and then chose the menu in the wp standard 'pages' widget.


You would then need to use a plugin like widget logic to decide which widgets/menu display on which pages, so you have have all the menus appearing on one page.

Share this post

Link to post
Share on other sites

Hi James, thanks for your answered.


The thing is that I do not use the widget 'pages', I do not use any 'widget' related.


Any 'sidebar' shows all pages.

Share this post

Link to post
Share on other sites

Has this always happened or just recently appeared? If its just appeared have you upgraded to wordpress 3.5 recently?

Share this post

Link to post
Share on other sites

Indeed, I have upgraded to wordpress 3.5 .


I've read that Station Pro has no new updates. However, is it possible to solve this little incident?


Thank you.

Share this post

Link to post
Share on other sites

Hi there, that's true unfortunately, Station Pro is now considered a legacy theme and won't receive any further updates I'm afraid. As time goes on and wordpress updates you could see more problems like this, the logical thing to do would be consider upgrading to the main Pagelines framework. The Framework is still on Sale at the moment, which we strongly recommend as if purchased with PLUS will include --  live chat support and a free extension every month (a considerable savings on premium plugins and sections).


The only other thing i can suggest would be to deactivate any third party plugins in case one of them could be conflicting, checking in your launchpad account you are on the latest/last release of Station Pro, although I doubt either of these will be make much of a difference unfortunately as other users are noticing the same problems since the Wordpress 3.5 update.

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Similar Content

    • Blog sidebar and previous entries
      By Digital805
      Hello, Some differences between WHv3 and v6 is I can't figure out how to activate the sidebar widgets area. Also, I don't see previous entries at the bottom of my posts page that allows users to continue looking through posts. Can you help me with these?
    • Section not in editor, showing up on live site
      By abuzzelli+
      I have a site that is showing a rapidtabs section in the sidebar when the DMS editor is inactive. When DMS editor is active it's gone. I don't want it to be there, but I can't figure out how to get to it in order to delete it. Any ideas?
    • Styling secondary sidebar in Widgetizer area
      By emilyf+
      Hi there!
      I have a "catalog" section on my site and I need to override the default text in the sidebar, which is hard to read. The sidebar was created with the Sidebar & Widget Manager for Wordpress. It's in a Widgetizer section. So far, I've done the following, to no avail:
      Added a custom styling class = .shopsidebar Added the following to Custom CSS: #site.shopsidebar a {
          color: #000;
          font-family: 'Franklin Gothic Medium', Arial, sans-serif;
          font-size: 18px;
      Sorry if this is way basic - but, what am I doing wrong? This does not show any changes on the front end of my site.
    • boxes and sidebar floating outside global content width
      By liberatedspaces
      My site ( started having a couple of weird problems on my home page all of a sudden, without me doing anything. It's run on the latest version of Pagelines Framework.
      1. My Facebook widget that is set to the secondary sidebar to the right of the page content (the info and Open Table widget) is dropping down into the box section
      2. The box section below the content is no longer conforming to the global content width set to 960px in the Site Option Layout Editor and stretching out to the edge of the browser on both sides.
      Any help would be much appreciated!

    • Sidebar Column Randomly Disappear from Templates
      By canadvo
      Hi there,
      This is a "phantom" problem we've had on our site since we upgraded to DMS2 eight or nine months ago.
      We have a large site and depend on the template system for almost all of our pages/posts. Typically it is a two column setup, with one containing the post loop/breadcrumbs, and the other column containing a widgetizer that displays the appropriate sidebar. Seemingly at random, the entire sidebar column will disappear from a template, leaving only the main column with post loop. We've never been able to isolate the problem or duplicate it. Sometimes, it happens to templates applied to pages that we haven't edited or even visited in quite some time. Sometimes, it will happen to templates we edited/published in the previous few days.
      I've never felt moved to post about this because the issue is impossible to predict, but it just now happened before my very eyes.
      I had just published a page that did not have a template applied. I wanted to apply the template we use on our "about us" pages, but I wasn't sure what it was called. I clicked on a page that had the template in question applied. All elements were present, the template was fine. Once I had the template name, I navigated back and loaded the correct template on the newly-edited page. When the page refreshed, the template had loaded without the sidebar column. I stopped and switched to Firefox (where I was logged out) and found that all pages within that template suddenly had no sidebar.
      I understand that this is an issue that is hard to provide support for, given that I've never been able to replicate it at will. Is this a problem others have had? Were there any plugins identified as a potential culprit? We have no cache plugins installed.