Jump to content
cerchris

Is it possible to display heading text using 2 colours?

Recommended Posts

cerchris

Hi There

 

http://janetnicol.co.nz/?page_id=23

In the boxes section, I am wanting to display the heading in the left hand box with "Courses for" in blue, and "CHILDREN" in white.

 

Any suggestions wd b greatly appreciated

Share this post


Link to post
Share on other sites
Simon

Wrap your words in a span like this...

 

 

<span class="course_1">Courses</span> for <span class="children_1">Children</span>

 

 

then use some css...

 

 

.course_1 {
    color: blue;
}

Share this post


Link to post
Share on other sites
cerchris

When I created the box, I filled in the "title" section with the heading. R u saying I can use the html section of the "edit box" page to put in my heading?

Share this post


Link to post
Share on other sites
cerchris

Hey great that worked!

 

Except it has knocked out the html and/or css for the learn more button links below the text in the boxes section.
Any clues on how to fix this?

Share this post


Link to post
Share on other sites
Rob

I'm not sure how those buttons were supposed to look.  Do you have an old screenshot?


Former PageLines Moderator, Food Expert and Raconteur

Share this post


Link to post
Share on other sites
cerchris

see on this link that the buttons have gone to the standard primary button display - http://janetnicol.co.nz/?page_id=23

This what they where styled to look like  (the hover state as per the css below) before I put the html into the box title:
 

post-41056-0-06509900-1357609799_thumb.j

 

This is the css I used to style the button:

.btn {
    background: url(http://janetnicol.co.nz/wp-content/uploads/2013/01/readmore-bk3.jpg) no-repeat top left;
    width: 155px;
    height: 46px;
        color: #fff;
    border: none;
        cursor: pointer;
        display: inline-block;
    font-family: 'Domine';
        font-size: 14px;
    margin-top: 15px;
        padding: 11px 0px 0px 25px;
        text-align: left;
        text-shadow: none;
        vertical-align: middle;
    box-shadow: none;}
.btn:hover {
    background: url(http://janetnicol.co.nz/wp-content/uploads/2013/01/readmore-bk3-HOVER.jpg) no-repeat top left;}

Share this post


Link to post
Share on other sites
Danny

Adding a span to the title, wouldn't cause the .btn class to not load an image. However, not sure why you have changed the .btn code by adding a background-image to it.

 

The button code I provided in another post, gives the button a few classes, for example

 

class="btn btn-large btn-primary"

 

You can simply replace btn-primary and add your own using the primary CSS as a template to create your own button.


Please search our forums, before posting!

Share this post


Link to post
Share on other sites
cerchris

Ok I think I am starting to understand, this is the html I have placed in the "edit box" section: <a href="http://janetnicol.co.nz/?page_id=37" class="btn btn-large btn-box">LEARN MORE</a>

naming my class btn-box. - is that what you mean't?

 

But the css is not taking effect, in my css file I have tried the following:

.btn-box {.....

This one makes the hover effect work but not the static state  - #boxes .btn {.......

.btn btn-large btn-box {.....

 

not sure why this is not working? I had it working before I added button icon links for social media in the footer - maybe there is a clash of code happening now?

Share this post


Link to post
Share on other sites
James B

Hi there, I'm not really sure I'm following on the last post. But if you've made your own class for the button like in Danny's example you'll need to apply the your custom css for both states in order for it to work, there shouldn't be a clash unless you've used the same class elsewhere on the site.

 

.btn-box {..... would be the static state, 

.btn-box :hover {..... would be the hover state. 

Kindly search the forum and read the documentation before posting. It will help you resolve many issues.

For CSS help be sure to check out W3Schools first and be sure to download FireBug for FireFox for troubleshooting.

James B

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


  • Similar Content

    • glyph.marketing
      By glyph.marketing+
      Hello, I am having a problem similar to that experienced by Michael Kummer here. We have pages that show this automatic scrolling issue (examples here and here) and it is sufficiently annoying that we have seen customers bounce while trying to convert. Strangely, it only happens at specific resolutions, so it can be difficult to reproduce. In general we can only consistently reproduce it on a 4k resolution with a browser width between 1517 and 1536px. 
      Thanks to Michael Kummer's help we were able to set the overflow-anchor property to none in the entire body, which fixed the issue as far as we can tell, but also obviously disabled scroll anchoring for the whole site. I tried applying it to the specific element that looked like it was being reloaded, which was the PL Meganav extension, but that was unsuccessful. 
      Can anyone help us figure out which element or ID we can apply this property to, so that we can fix the scrolling issue but not disable scroll anchoring for the entire site?
      Thank you - 
      Glyph Language Services
    • chamois_blanc
      By chamois_blanc+
      Hello,
      Shouldn't the image PL5 component be using the srcset/picture css directives to pick the correct size for an image? or it does already and I don't know how to use it? Thank you for any advice or enlightenment.
    • Dan Haddock
      By Dan Haddock
      Plugins Active and installed: 
      Akismet Anti-Spam
      Coming Soon Page & Maintenance Mode by SeedProd
      Contact Form 7
      Cookie Law Info
      DMS Professional Tools  
      Enhanced Media Library  
      Flamingo
      Google Analytics for WordPress by MonsterInsights
      Google XML Sitemap
      Jetpack by WordPress.com
      Legull 
      Loginizer   
      MailChimp for WordPress
      PageLines Updater    
      Schema App Structured Data 
      Sucuri Security - Auditing, Malware Scanner and Hardening
      Uber reCaptcha    
      Yoast SEO
      Wordpress Version: 4.8.1
      Pagelines Version: 2.2.4
       
      Good Evening/Afternoon or Morning, 
      I am running into a problem with CSS styling not applying inside of most browsers (Safari, Firefox) when I am logged in to wordpress, and all browsers that I have tested when I am logged off and the site has been made public (Chrome, Firefox and Safari).
      As a result, I have managed to identify the probable cause. It looks as though these browsers are refusing to render my sites compiled CSS file due to it being a HTTP URL rather than HTTPS.
      I have attempted to change this URL to HTTPS in my browser, however it brings back an ERROR: File not found page - https://www.shortfilmblog.com/wp-content/uploads/pagelines/compiled-css-core-1505847507.css
      What would you suggest in this regard? Would this be resolvable from your end?
      Happy to provide any further details required.
    • Borries
      By Borries+
      I know this is not an easy problem. Maybe there is a easy solution.
      I have tryed to uses the existing solution, that I have found in the forum
      I changed the colours of my nav (simple nav) and the hover effect (a. hover).
      I really tryed to highlight the active/used link in the nav but I cant figure it out.
      I want it to be black when active.
      Any help would be appreciated. Thanks.
      http://www.marcborries.de  nav link: "Sinn & Selbst" 
    • Michael Kummer
      By Michael Kummer+
      Hi guys,
      every since Chrome introduce scroll anchoring (see chrome://flags) blog posts on my page start scroll automatically as soon as the user scrolls down a bit. It is super annoying and I don't know exactly what triggers the incompatibility with Chrome's latest feature that is supposed to improve usability.
      Since I don't know what causes it (Pagelines, or a Plugin), I would like to disable the feature using a CSS override that Google describes as follow:
      "Scroll anchoring aims to be the default mode of behavior when launched, so that users benefit from it even on legacy content. A CSS property overflow-anchor can disable scroll anchoring in part or all of a webpage (opt out), or exclude portions of the DOM from the anchor node selection algorithm. This property supports the following values when applied to an element E:
      overflow-anchor: auto (the default value) declares that the DOM subtree rooted at E is eligible to participate in the anchor node selection algorithm for any scrolling box created by E or an ancestor of E. overflow-anchor: none declares that the DOM subtree rooted at E is not eligible to participate in the anchor node selection algorithm for any scrolling box created by E or an ancestor of E." Do you guys happen to know how to use that property with the ROOT element so it applies to the whole page?
      Thanks
      Michael 
×