Jump to content
PeriniNero

Pageless issues loading time

Recommended Posts

PeriniNero+    8
PeriniNero

Hi there,

 

We're having loading issues regarding to pageless file. We can't figure out what the problem is; some sites having "compiled" working better, it seems. Don't know where to adjust.

 

We've read the issues http://www.pagelines...ow/?hl=pageless and http://www.pagelines...e-loading-time/. We tested with and without W3 Total Cache (apc).

 

We added define( 'LESS_FILE_MODE', true ); to wp-config of the wp network.

 

It's a wordpress network installation with recruytment.nl (we still have to adjust the images :-)) as main site. Subdomain install with f.e. www.recruitmentpartners.nl as multisite. At both, pagelines debug is activated now. All sites in the network use the pagelines framework with a custom pagelines child theme. Pages are small but load time is extremely high, except sometimes for the mainsite, but still the pageless file seems to slow down this one as well. Analysis via tools.pingdom.com and webpagetest.org result all in showing issues/extreme load time with the pageless file.

 

In some other wordpress-network-pagelines-installs we see compiled-css files, some others show pageless.

 

Again, we have tested this with and without W3 Total Cache. Issues are the same in both situations.

 

Thank you for your time.

post-34511-0-91682500-1357643247_thumb.j

post-34511-0-38213700-1357643255_thumb.j

Share this post


Link to post
Share on other sites
Danny    1,327
Danny

Hi,

 

Your sites and pages are loading fine for me, not slow at all, in fact there instant ?

 

Have you resolved the issue ?


Please search our forums, before posting!

Share this post


Link to post
Share on other sites
PeriniNero+    8
PeriniNero

Hi Rockstar :-),

 

Main site Recruytment.nl just loaded in over 10 seconds, with page size 428kb.

Subsite recruitmentpartners.nl just loaded in 10.82 seconds, with page size 177kb.

See the attached file, pageless file takes 5 about seconds.

 

I have sites with over 1mb loading in 2 seconds. Using the same vps, pagelines and w3tc.

Share this post


Link to post
Share on other sites
PeriniNero+    8
PeriniNero

pingdom_recruitmentpartners.jpg

Share this post


Link to post
Share on other sites
Danny    1,327
Danny

First of all please disable W3 Total Cache, if your site is still under construction, being designed etc.., then the plugin shouldn't be active. Only enable it when site design is finalised.

 

Also, if you go directly to your Compiled CSS file, it loads instantly, the compiled CSS file is not to blame.

 

If your page size is 177.5KB and is taking over 10seconds to load, this is server related in my opinion. However, I will speak with one of our developers, who is a bit of a boffin with server setups, load speed etc.. and reply here when I have more information.


Please search our forums, before posting!

Share this post


Link to post
Share on other sites
PeriniNero+    8
PeriniNero

Thanks. Would be great to hear from you/your developers.

Share this post


Link to post
Share on other sites
Simon    247
Simon

The css will not be written out to a css file because you have opted to run PHP in mod_php mode as the user apache. So if it writes a file, you cant delete it via FTP, unless you are actually called apache lol.

 

You can overide the checks for this and try and force the css to be written to a file with the following:

 

 

add_filter( 'render_css_posix_', '__return_true' );

Share this post


Link to post
Share on other sites
PeriniNero+    8
PeriniNero

Hi Advocate!

 

We've added the line in de child theme functions.php

 

Somehow this does not work?

 

We've asked our hoster CloudVPS.com to change "PHP User: Posix functions are disabled on this host".

Share this post


Link to post
Share on other sites
Simon    247
Simon

There is not much we can do here if you have enabled that filter and it still isnt writing a css file.

 

No way for me to check as you still have w3 cache on. Is it a busy site?

Share this post


Link to post
Share on other sites
PeriniNero+    8
PeriniNero

w3 cache is on (see at bottom page source), but will de-activate now

Share this post


Link to post
Share on other sites
Simon    247
Simon

If you activate PageLines debug mode in advanced settings it might give a clue why the file mode isnt working.

Share this post


Link to post
Share on other sites
PeriniNero+    8
PeriniNero

debug mode is activated on both recruytment.nl and recruitmentpartners.nl

w3 total cache disabled at both

Share this post


Link to post
Share on other sites
Simon    247
Simon

Theres only a few things that will stop the file mode from working...

 

Your uploads dir is is not writable.

 

You have PL_NO_DYNAMIC_URL set to true.

 

Your server is running with PHP as apache/www-data etc

We already know this is the case, and if its a VPS why are you running php as user apache anyway? Its the most unsecure way of doing it!

The filter I supplied earlier bypasses the check.

 

Before you disabled W3 I checked your site in pingdom and the css was loading in < 300ms whole site was 1.1s The twitter widget down the bottom was taking longer to load than the css file.

Share this post


Link to post
Share on other sites
PeriniNero+    8
PeriniNero

Uploads dir seems to be an issue regarding to wp network installs; uses /blogs.dir/; will 777 them

 

pl_no_dynamic... don't understand what to do

 

php/apache/www-data... we will forward your message to our hoster CloudVPS.com

 

Yeah, loading time of the main site recruytment.nl was not an issue; seems like multi-sites are having problems; in fact only regarding to the pageless file (5 seconds of the 10)

Share this post


Link to post
Share on other sites
Simon    247
Simon

Why contact your host? Its a VPS isn't it? You manage it yourself.

 

Did you install apache/php? Is it a control panel?

Share this post


Link to post
Share on other sites
PeriniNero+    8
PeriniNero

:-) because anything regarding to the technical... is way out of my league

pre-installed vps, CentOS5 with directadmin control panel

also vps control interface, terminal, but we do not have any experience with this :-(

Share this post


Link to post
Share on other sites
Simon    247
Simon

Well directadmin has a huge community forum here: http://forum.directadmin.com/ First thing you need to find out is how to switch apache and php to run in either suPHP or mod_fcgid mode.

Share this post


Link to post
Share on other sites
PeriniNero+    8
PeriniNero

Hi again Advocate!

 

In the meanwhile, we tried something else, with our wordpress network (multisite) subdomains install.

Huge performance improvements.

 

First we switched off, at networksettings/domain mapping:

1. remote login

4. redirect admin pages

 

Then we deactivated W3TC at the subdomains.

Reactivated per subdomain.

Created a new CDN per subdomain.

 

Testing now but huge improvements.

 

Furthermore, maybe it's a good suggestion to add more info at the debug info page, like what to change if certain settings are not good. For non-technical-heroes like us, a statement like "sections dir not writable" automaticly delivers the quesstion: should this be writable?

 

So far so good, now more testing and optimizing vps.

 

Thanks!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


  • Similar Content

    • dreamsight
      By dreamsight+
      Hi, 
      I'm trying to make improvements to 2 of our sites PageSpeed scores using W3 and Autoptimize, specifically Eliminate render-blocking JavaScript and CSS in above-the-fold content using Autoptimize.
      Both sites are running on Pagelines (2.2.4) but I'm having trouble locating the aggregated CSS stylesheet which should be at the top of the site header, but on these particular sites the source code look much different (http://imgur.com/a/0kqbc - Actual site we are improving)
      Whereas most of the sites we have improved in the past (inclduing the example demo site of the plugin) the source code looks like this; http://imgur.com/LjRy5K7 (Tutorial Site Example of Source Code with Aggregated CSS link)
      I've turned off all the plugins on both sites and at this point I am 99.9% sure the source code formatting has been 'altered' by pagelines. 
      Does anybody know where/how i can locate the stylesheet I need?
      Thanks in advance.
    • micstepl
      By micstepl+
      I wonder what to do to change - to increase site speed.
      Are there any recommendations on the How´s?
      If you check site-speed with https://developers.google.com/speed/pagespeed/insights/ the performance of all PL5 sites I check leaves lots of room for improvement (indicaores RED  .... approx. 45-50/100) for desktop & mobile)
    • ea/
      By ea/+
      [attachment=2539:Screen Shot 2014-12-16 at 12.06.57 PM.png]
       
      Hi Enrique,
       
      SITE: http://www.dev.legacyfamilyoffice.ca
       
      I love your theme overall, and am really happy with how the site is starting to come together. However, I do have a question about how to change the speed at which the Testimonials slider is rotating. I'd like to slow it down, maybe by one or two seconds, but I won't know until I experiment with it. 
       
      How do I do this?
       
      Thanks,
       
      ea/
    • atcdomainsolutions
      By atcdomainsolutions+
      Hey everyone!
       
      I'm always looking at ways to speed up a DMS site in loading in the browser and have been using a plugin for my past few sites with no issues so figured I would share here.
       
      Plugin name is "GZip Ninja Speed Compression" and I have been running it with "WP Super Cache".  When either of these is run alone, they work great but together, it really speeds up site load time.  I have even noticed it speeding up load times when logged into the DMS editor in Chrome.
       
      I have been using it with Wordpress 4.0 and DMS 2.1.6.1 and have noticed zero issues.
       
      The ONLY problem I experience is I started adding Gzip to my local test sites Master File I install for all new builds but noticed an issue of the site transfer to a live development server (via the Duplicator plugin) not working properly. After testing and removing Gzip from my local install and transferring, it worked fine so I guess it doesn't play well from local to live so best to only install once you have moved it from your local install (not that you need it locally since local installs fly anyway...I was just being lazy and adding plugins I always use to my XAMMP).
       
      Just an fyi!
       
      James
    • faagerritsen
      By faagerritsen
      Hi,
       
      for some reason the pageless css file is increasing the loadtime (file taks 1.6 to 2.8 sec to load). I'm talking about the Pageless file (http://afrankadvice.nl/?pageless=1_1409431991)  Can anybody help me to solve this issue so my site will load faster.
       
      Thanks
       
      Frank
×