Jump to content
saerdna_elfk

Sidebar under content

Recommended Posts

saerdna_elfk    0
saerdna_elfk

Hello,

 

my name is Michael. I just started to create a website. Now I tried to add a sidebar to the blog-page. The sidebar is shown under the actual content. This also happens, if I try to add a sidebar to any other page:

problem1.jpg

 

I added a picture, just to let you see, what's my problem.

 

I have a bit of custom code. But I don't think that's the problem. Here it is:

@font-face {
  font-family: Kirchenfont;
  src: url("/webfonts/azuro-regular.eot?ie"), url("/webfonts/azuro-regular.woff");
}
@font-face {
  font-family: Kirchenfont;
  src: url("/webfonts/azuro-italic.eot?ie"), url("/webfonts/azuro-italic.woff");
  font-style: italic;
}
@font-face {
  font-family: Kirchenfont;
  src: url("/webfonts/azuro-bold.eot?ie"), url("/webfonts/azuro-bold.woff");
  font-weight: bold;
}
@font-face {
  font-family: Kirchenfont;
  src: url("/webfonts/azuro-bolditalic.eot?ie"), url("/webfonts/azuro-bolditalic.woff");
  font-weight: bold;
  font-style: italic;
}


body,
.font1,
.font-primary,
.commentlist,
input {
  font-family: 'Kirchenfont', sans-serif;
}
h1,
h2,
h3,
h4,
h5,
h6,
.site-title,
.ui-tabs,
.ui-button,
.ui-tabs-panel,
.tab-top-nav {
  font-family: 'Kirchenfont', sans-serif !important;
}
.font2,
.font-sub,
ul.main-nav li a,
#secondnav li a,
.metabar,
.subtext,
.subhead,
.widget-title,
.post-comments,
.reply a,
.editpage,
#pagination .wp-pagenavi,
.post-edit-link,
#wp-calendar caption,
#wp-calendar thead th,
.soapbox-links a,
.fancybox,
.standard-form .admin-links,
#featurenav a,
.pagelines-blink,
.ftitle small,
.button,
input[type="submit"],
input[type="button"],
input[type="reset"],
.submit {
  font-family: 'Kirchenfont', sans-serif !important;
  text-transform: uppercase;
  letter-spacing: .1em;
}
input[type="text"],
input[type="password"],
textarea,
#dsq-content textarea {
  font-family: 'Kirchenfont', sans-serif !important;
}


  
/*--CHANGE COLOR NavBar FIXED--*/
.navbar.pl-color-black-trans {
background-color: rgba(131,180, 44, 1.0);
background-image: none;
background-repeat: repeat-x;
border-top: none;}

/*--CHANGE COLOR NavBar SEARCH--*/
.navbar .searchform .searchfield {
background-color: rgba(255, 255, 255, 0.35);
border: none;
box-shadow: 0px 1px 2px rgba(0, 0, 0, 0.1) inset, 0px 1px 0px rgba(255, 255, 255, 0.15);}

/*--CHANGE COLOR NavBar HOVER--*/
.dropdown-menu li > a:hover, .dropdown-menu li > a:focus, .dropdown-submenu:hover > a, .dropdown-menu li.current-menu-item > a {
background-color: rgb(198, 7, 105);
background-image: none;
background-repeat: repeat-x;}

#navbar.container.no_clone.section-navbar.fix div.content div.content-pad div.navbar.fix.navbar-content-width.pl-color-black-trans {
  border-radius: 0 !important;
  -moz-border-radius: 0 !important;
  -webkit-border-radius: 0 !important;
  -moz-background-clip: padding !important;
  -webkit-background-clip: padding-box !important;
  background-clip: padding-box !important;
  background-image: none !important;

}

.fixed-top .plbrand { display: none; }

#branding {.mainlogo-link, .mainlogo-img{margin:0 auto;float:none;}}

.btn-success {
    background-color: #83b42c;
    background-image: -moz-linear-gradient(center top , #83B42C, #83b42c);
    background-image: -webkit-linear-gradient(center top, #83B42C, #83b42c);

  }

body{
.fbox {
  padding:5px;
  background:@baseLighterMore;
  border:1px solid @baseLighterMost;
  border-bottom: 5px solid @baseContrastMore;
  border-left: 1px solid @baseContrastMore;
  border-right: 1px solid @baseContrastMore;
  border-top: 1px solid @baseContrastMore;
  .box-shadow(0px 1px 6px 1px rgba(211, 211, 211, 0.3));
  .border-radius(5px);
}

.content .content-pad {
    padding: 30px;
}
  
#boxes .content-pad {
    padding-bottom: 30px;
}  

body .content .content-pad {
    padding: 15px;  
  
}

.masthead .masthead-title {
    font-size: 3.0em;  

}
  
.masthead .btn-large {
    border-radius: 6px 6px 6px 0px;
    }
  


 


}
#footer {
background-color: #83B42C;
}

#cred {
    padding-bottom:0px !important;
}

So, I hope someone can help...

 

Thank you very much, Michael.

Share this post


Link to post
Share on other sites
batman    389
batman

Hi Michael

 

Please go to 

Pagelines > Site Option > Layout editor 

and verify in "Default Layout Mode "

you have select the default layout that you want.

 

Captura%2520de%2520pantalla%25202013-01-


Life is too short to remove USB safely ...

Share this post


Link to post
Share on other sites
saerdna_elfk    0
saerdna_elfk

Hello batman,

 

thank you for your response. I already did that, and the setting is the right one!

Share this post


Link to post
Share on other sites
Rob    547
Rob

Hello Michael,

 

Several things can cause this. 

 

First, let's go to Dashboard > PageLines > Site Options > Layout Editor. Please tell us if if both the Default Layout Mode and the Layout Dimension Editor have a single sidebar layout.   Both should be the same selection. 

 

Next, let's go to that page.  In the PageLines Meta Settings, do you have the sidebar hidden? (This is a checkbox option.)

If not, let's go to Dashboard > PageLines > Page Options > Blog Page > Page Setup.   Let us know if any of the sidebars are hidden there by checkbox.

 

Now, let's go to Dashboard > PageLines > Drag & Drop  and click SB1.  What's in there?

 

Also in Drag & Drop, under Content Area, is PostLoop present on all the templates except for 404 Error?


Former PageLines Moderator, Food Expert and Raconteur

Share this post


Link to post
Share on other sites
saerdna_elfk    0
saerdna_elfk

Hello Rob,

 

thank you for your advises...

I have been going through the things you've mentioned.

 

Default Layout Mode and Layout Dimension Editor have a single sidebar layout and have the same selection.

Sidebar is not hidden, not on that page and also not under Dashboard > PageLines > Page Options > Blog Page > Page Setup

Under Dashboard > PageLines > Drag & Drop  and SB1 is "Primary Sidebar".

PostLoop ist present on all the templates except 404

Share this post


Link to post
Share on other sites
Rob    547
Rob

Either there's a setting I'm not thinking of, or a plugin is causing this.

 

Do you have any older plugins or ones that are not compatible with WP 3.5?   Have you installed any lately?


Former PageLines Moderator, Food Expert and Raconteur

Share this post


Link to post
Share on other sites
saerdna_elfk    0
saerdna_elfk

I already had the same idea, and deactivated all plugins, but the problem is still there.

Share this post


Link to post
Share on other sites
Rob    547
Rob

If you'd like to set up a new Administrator level account, I'd be happy to look behind the scenes. Please email the credentials to robert@pagelines.com


Former PageLines Moderator, Food Expert and Raconteur

Share this post


Link to post
Share on other sites
saerdna_elfk    0
saerdna_elfk

I've set you up a Administrator level account and sent the credentials to your mail-account. Thank you for your help!

Share this post


Link to post
Share on other sites
Rob    547
Rob

If you go to the page itself, and look at the PageLines Meta Settings, you have the page set up for full width, but the template you're using has a sidebar associated with it. You didn't hide the sidebar, which is why this is so strange. See the two pictures below:

 

I found this CSS in the site:

.one-sidebar-right #pagelines_content #column-wrap {
}

As you can see, it's empty, which means either a piece of custom code or something's happened to override the content.

 

When I add width:70%; to it, the sidebar moves right up along side. 

 

I'll send a note to our developers about this, so please don't remove the Admin level account in case they need to inspect anything. When we resolve this, I'd suggest removing it then.

post-6-0-99217600-1357511771_thumb.jpg

post-6-0-05990100-1357511796_thumb.jpg


Former PageLines Moderator, Food Expert and Raconteur

Share this post


Link to post
Share on other sites
saerdna_elfk    0
saerdna_elfk

First of all, thank you for your help.

 

I changed the setting on the page, because it doesn't work, when i click on the button with the left sidebar on it. I just was trying around.

 

I don't understand what peace of custon code could cause the empty line of code you showed me. I didn't do anything to the sidebar settings until I liked to use it.

 

Again: Thank you for your work! I will try the 70% you mentioned.

 

I will let the administrator account open.

Share this post


Link to post
Share on other sites
Rob    547
Rob

That conflict in code could be coming from a variety of sources.  It may not be something you specifically added.


Former PageLines Moderator, Food Expert and Raconteur

Share this post


Link to post
Share on other sites
saerdna_elfk    0
saerdna_elfk

Okay... One last question: How did you apply the 70% to .one-sidebar-right... what was the code you're using?

Share this post


Link to post
Share on other sites
Rob    547
Rob

I have sent a note to our developer. As soon as he's back from an illness, I'll find out what caused this.

 

It was a pleasure helping.


Former PageLines Moderator, Food Expert and Raconteur

Share this post


Link to post
Share on other sites
irm89    0
irm89

I have the same problem. :( Please Update the Framework!

Share this post


Link to post
Share on other sites
Rob    547
Rob

Hi irm89,

 

The problem is often the incorrect customization of some of the templates in Drag & Drop and the layout of the page. A certain combination will result in this.  It's easily corrected by following the guidance in http://support.pagelines.me/docs


Former PageLines Moderator, Food Expert and Raconteur

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


×