Jump to content
benz_admin

Wrong author page link on post/page

Recommended Posts

benz_admin    0
benz_admin

Hi to all,

 

with Rich Snippet test tool I discovered that all my posts and pages link to a wrong author page

Each post or page linking to www.turismopesaro.com/**POST-URL**/author/VacanzePesaro/ instead they should linking to http://www.turismopesaro.com/author/VacanzePesaro/

 

How can I solve it?

 

Thanks in advanced

Bye

Michel

Share this post


Link to post
Share on other sites
Danny    1,327
Danny

Hi,

 

I have reviewed your website and all the author links appear to be linking to the correct author page, can you provide a link where this isn't the case please.


Please search our forums, before posting!

Share this post


Link to post
Share on other sites
benz_admin    0
benz_admin

Hi Danny,

thanks for your reply on Sunday :)

Google Rich Snippet tool find the error on each page...

I upload some screenshot

 

www.turismopesaro.com/download/1.jpg

www.turismopesaro.com/download/2.jpg

www.turismopesaro.com/download/3.jpg

Share this post


Link to post
Share on other sites
Danny    1,327
Danny

As far as I know, we haven't had any other reports of users having this issue and I have no experience with the Google Rich Snippet tool. Are you sure you have configured the Rich Snippet tool correctly.


Please search our forums, before posting!

Share this post


Link to post
Share on other sites
Rob    547
Rob

Buongiorno Michel,

 

I'd suggest updating your permalinks. To do this, go to Dashboard > Settings > Permalinks.  Do not change anything. Simply click the Save button which should update all links on your site.  Let me know if this works.


Former PageLines Moderator, Food Expert and Raconteur

Share this post


Link to post
Share on other sites
benz_admin    0
benz_admin

Thanks for yiur help Catrina.

I deactivated all plugins and resaved my permalink settings and now it works!

 

now I try to activate a plugin at a time to figure out which is causing the problem

Share this post


Link to post
Share on other sites
benz_admin    0
benz_admin

the plugin who generate the error is: Wordpress SEO by Yoast

 

How can I solve it?

I wouldn't give up to this plugin because it is the best for me at the moment...

Share this post


Link to post
Share on other sites
Simon    247
Simon

I use wp-seo on my blog and the google thing validates 100%

 

Impossible to see what info is on your site as you are using caching and minifying the HTML too.

 

If you want us to help debug something please let us at least see the page source.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


×