Jump to content
Sign in to follow this  
peters_publishing

Shorten Nav?

Recommended Posts

peters_publishing    0
peters_publishing

It appears in Firebug that the navigation bar on  my website is overlapping my language switcher, making nearly impossible to switch to Russian. 

 

http://www.skypeenglishclasses.com/

 

See the switcher in the upper right hand corner of the site.

 

I've been trying to figure out how I can shorten the right side of the nav bar to fix this, or somehow make it so that the language switcher is above the nav bar so that all languages are clickable. No luck so far.

 

 

Share this post


Link to post
Share on other sites
catrina    103
catrina

Please try adding this custom CSS to Custom Code > Custom CSS:

#page #nav_row .main_nav {width: 600px;}

Please read the docs before posting. Please do not private message me unless I ask you to.

Designer | Catrina Dulay

Founder | Catrina and Mouse

Share this post


Link to post
Share on other sites
peters_publishing    0
peters_publishing

Doesn't seem to change anything. I've left it in for now so you can check it out.

Share this post


Link to post
Share on other sites
batman    389
batman

Hi you can try with

 

 

.main_nav_container.nosearch, .nosearch .main_nav {
    margin-right: 150px;
}

 

  • Like 1

Life is too short to remove USB safely ...

Share this post


Link to post
Share on other sites
peters_publishing    0
peters_publishing

That did it! Thanks Bat Learning! 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this  

  • Similar Content

    • JP
      By JP+
      Hello,
      We are working on a 2 languages site (https://liguecardioliga.be) with wpml, and lately the call of a category in the loops section (and all the sections requiring a category to select posts) doesn't work in the translated language. It worked well until recently so I wonder if it's because of a recent update (wordpress, wpml, pagelines, a plugin?). Anyone has the same problem? a solution?
      TIA
    • mrhinsh
      By mrhinsh
      I am trying to get WPML working on my Pagelines instance. I am interested in getting help from anyone that has tried, especially @claudedagenais who seams to have it working.
      My issues are:
      How to translate header and footer How to get the menu to show all nav even if not translated How to get non-translated posts /pages to show up when only in default language - true for Masonry, Newsfront, and other list showing items... I have zero skills in PHP and its my site for my company. 
      note: Multi-lingual is a business decision and is required. I have vetted all of the multi-lingual options and the only one fit for purpose is WPML. 
    • JP
      By JP+
      Hello,
      How can you set the translations with platform5, the parts that are not in pages or posts? Texts and images…
    • claudedagenais
      By claudedagenais+
      Hello, we have this strange new problem with DMS2 when used with WPML. We can save our change to the section only in the main language. When trying to edit DMS sections in the other languages DMS won't let us save. The work around is to change the main language in WPML to the language you want to change and switch back afterward to the language you really want to be the main one.
      This is a new problem that did not exist before a few days ago. We are unsure if it is linked to the Wordpress 4.4 update, the WPML 3.3.3 Update or the DMS 2.2.1.1 update (!) that we did recently. We tried unsuccessfully deactivating everything (except WPML of course) including our child theme in a test environment. We can't turn off the DMS editor either from the other language pages. Some of the websites we are having this problem with are  http://www.artssutton.com/ , http://journalletour.com/, ...
      Tx
    • Ellery
      By Ellery
      I am using pageline (v2.2.1.1) and WPML (3.3.3). WP 4.3.1
      Here is the problem: when I set the language to be a path like this:
      http://localhost/pageline/zh-hant
      all [pl_site_url] will become above, which means, if you are using images in textbox, or pageheader, the full URL would become
      http://localhost/pageline/zh-hant/wp-content/upload......
      which is wrong.
      Furthermore, if the site requires AJAX, the calling URL becomes:
      http://localhost/pageline/zh-hant/wp-admin/admin-ajax.php
      which is also wrong.
      Now you may want me to use ?lang=zh-hant instead of using /zh-hant/, but it would become
      http://localhost/pageline/?lang=zh-hant/wp-admin/admin-ajax.php
      which is also wrong.
      Can you please tell me how to fix it?
      Thank you very much in advance for your help.
×