Jump to content
sidianmsjones

Custom CSS not being recognized by the site

Recommended Posts

sidianmsjones    0
sidianmsjones

Site here: http://storytime.booklamp.org/

 

Hi all. So I've been utilizing the Custom CSS area for quite a while. Then I updated WP and Pagelines and suddenly my site doesn't pull in my CSS.

 

Here's my code...

 

body{}
body.fixed_width .section-branding .content-pad {
padding:0;
}

.fixed_width #branding .content-pad {
padding-bottom:0;
padding-left:0;
padding-right:0;
padding-top:0;
}

#feature-area {
background-color:black;
}

#branding .content {width: 980px}

.fixed_width #page {
  margin:0px auto 0;
  margin-top:0px;
  padding-top:0;
}

}
element.style {
}
.icons {
   z-index:9999;
}

Share this post


Link to post
Share on other sites
sidianmsjones    0
sidianmsjones

Like this?

 

#page body.fixed_width .section-branding .content-pad {
padding:0;
}

Share this post


Link to post
Share on other sites
James B    436
James B

Hi there, yes adding #page will make your css more specific. If it's happened since a recent update then also try refreshing/flushing your permalinks if that doesn't work. 

 

Just go to settings>permalinks and hit save, then refresh. I'm looking on your site though in firefox and it looks like all your css is loading correctly.


Kindly search the forum and read the documentation before posting. It will help you resolve many issues.

For CSS help be sure to check out W3Schools first and be sure to download FireBug for FireFox for troubleshooting.

James B

Share this post


Link to post
Share on other sites
sidianmsjones    0
sidianmsjones

Strange, I tried both the #page, and permalink thing, plus I've cleared my caches and used other browsers...still no love over here.

 

The most glaring thing I'm seeing is the big white padding around the BookLamp banner. Is that showing for you, James? The banner should blend into the background just like on BookLamp.org.

Share this post


Link to post
Share on other sites
James B    436
James B

Ok in that case I see the same as you, i was looking at the booklamp.org link thinking that was your site.

 

Looking in the source code for the storytime site the custom css isn't showing, all that's in there in its place is the below css and it doesn't refer to any particular section.

 

padding: 0px;padding-bottom: 0;
padding-left: 0;
padding-right: 0;
padding-top: 0;background-color: black;width: 980px;margin: 0px auto 0;
margin-top: 0px;
padding-top: 0;z-index: 9999; 

How are you adding your css? In the custom code box, via base theme or customize plugin?

 

Are you seeing any css/less error messages in the wp admin bar?

 

Have you migrate or moved the site directories around at all?


Kindly search the forum and read the documentation before posting. It will help you resolve many issues.

For CSS help be sure to check out W3Schools first and be sure to download FireBug for FireFox for troubleshooting.

James B

Share this post


Link to post
Share on other sites
sidianmsjones    0
sidianmsjones

Interesting, so it sees the values but not the selectors?

 

But no, no error messages. It's rather confounding.

Share this post


Link to post
Share on other sites
James B    436
James B

Is there meant to be anything on that page as it's coming up with a 404. Has this site always been set up into this sub-directory? Nothings been moved?

 

Disable all third party plugins see if anything causing issues there.

 

Have you placed any code in the functions.php or entered any scripts anywhere?


Kindly search the forum and read the documentation before posting. It will help you resolve many issues.

For CSS help be sure to check out W3Schools first and be sure to download FireBug for FireFox for troubleshooting.

James B

Share this post


Link to post
Share on other sites
sidianmsjones    0
sidianmsjones

There is, sorry I messed up the link. I've now fixed it above and here it is again: http://storytime.booklamp.org/

 

And yeah, it's always been in that sub, didn't move anything. I'll try the plugins. Haven't altered the functions or put any scripts aside from footer ones like Google Analytics.

Share this post


Link to post
Share on other sites
James B    436
James B

Ok no worries, could you can a screenshot of the custom code page too for us with the code in so we can take a look :-)


Kindly search the forum and read the documentation before posting. It will help you resolve many issues.

For CSS help be sure to check out W3Schools first and be sure to download FireBug for FireFox for troubleshooting.

James B

Share this post


Link to post
Share on other sites
sidianmsjones    0
sidianmsjones

Sure, here it is in it's current state...

 

3Zpzs.png

Share this post


Link to post
Share on other sites
James B    436
James B

Hi there,

 

Can you set up an admin level user for us and send the username and password to hello@pagelines.com for me. We'll log in and take a look for you.


Kindly search the forum and read the documentation before posting. It will help you resolve many issues.

For CSS help be sure to check out W3Schools first and be sure to download FireBug for FireFox for troubleshooting.

James B

Share this post


Link to post
Share on other sites
James B    436
James B

Hi there, looks like there was an unwanted bracket in the css, have removed and changes seem to be taking affect now. Please check and let me know all is ok.


Kindly search the forum and read the documentation before posting. It will help you resolve many issues.

For CSS help be sure to check out W3Schools first and be sure to download FireBug for FireFox for troubleshooting.

James B

Share this post


Link to post
Share on other sites
sidianmsjones    0
sidianmsjones

Really? I feel pretty silly now. Then again it's kind of weird a bracket would appear due to updating my site, but everything is now in working order. Thanks James!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


×