Jump to content
joaoreis

IE9 Issue - Sidebars not showing in the right place.

Recommended Posts

joaoreis    0
joaoreis

Hello! Guys,

 

 I've just found out that my site is not showing the sidebars in the right place of the page, they are showing bellow the post and the green page background i've added is not working, the Social icons are shown in the opposite side as well.

 

 If you open the site using Chrome or Mozilla there is no problem, the issue happens only with IE. The version i used for test was IE9.

 

 http://desenv.intesys.com.br

 

Thanks in advanced.

Share this post


Link to post
Share on other sites
Rob    547
Rob

That looks like a plugin is affecting it.  My guess is, the chat window is at fault. 

 

Please deactivate all your non-PageLines plugins.  Leave only the plugins you found via The Store and Akismet.


Former PageLines Moderator, Food Expert and Raconteur

Share this post


Link to post
Share on other sites
joaoreis    0
joaoreis

Hi! Rob,

 

 Now it's working only with the default plugins via store, but the issue continue.

 

 What else can i do?

 

Thanks!

Share this post


Link to post
Share on other sites
Danny    1,327
Danny

Hi,

 

Can you use the PageLines Grid to create that layout and see if this resolves your issue. Although I cant see the issue, as I am not able to check IE, if the Sidebar is appearing below the content, its most likely caused by either your images or the table HTML.

 

http://support.pagelines.me/docs/miscellaneous/grid-system/


Please search our forums, before posting!

Share this post


Link to post
Share on other sites
joaoreis    0
joaoreis

I used the pagelines-customize instead of base theme.

I was able to deactivated the pagelines-customize via control panel, but could not do the same with base theme. I've commented the codes i used for test in both files style.css and functions.php/basetheme, the files still in the themes/pagelines-template-theme folder should i remove it?

Share this post


Link to post
Share on other sites
joaoreis    0
joaoreis

Hi! Danny,

 

 I don't know about the pagelines Grid, but i'll have a look at this.

Share this post


Link to post
Share on other sites
joaoreis    0
joaoreis

I think the grid is not going to resolve the issue, i took out all the codes i used, even the menu widgets and the css, social menu all still being shown different when i browse with IE.

Share this post


Link to post
Share on other sites
Danny    1,327
Danny

Ok, well PageLines certainly works with IE9. The most common cause of the Sidebar appearing below the content, is issues with the HTML you have added to the page. Some plugins may even cause this issue.

 

I recommend you review the code you used to add those images to your page. Also as a test, simply add some basic text and see if the the Sidebar is in the correct position, if so then its definitely your HTML code.

 

If the text method still displays the sidebar below the content, then it has to be a plugin or custom code you have added to your site.


Please search our forums, before posting!

Share this post


Link to post
Share on other sites
joaoreis    0
joaoreis

 I did deactivate all the plugins and the sections i added. There is no extra HTML code running in the widgets at the moment, i also did the test with a simple text following your recommendations and it shown the sidebar in the wrong position when i use IE.

 

Here are the pictures of the site using ie and firefox.

 

http://ubuntuone.com/394Ta30QZs7b9gbAq9GHhT

 

http://ubuntuone.com/3F66WDnCVFJ2re4M1ufHj0

 

http://ubuntuone.com/66YkCRbuI2kM5UbVLUNAI7

 

http://ubuntuone.com/6csBbAcfMyOL1GKLlFKM81

 

 I'm going to review the code i use for the images as you said.

 

 Is there any other test i can do?

 

 Many thanks!

Share this post


Link to post
Share on other sites
joaoreis    0
joaoreis

Hi! Catrina,

 

It reduces the sidebar and goes a little bit more for the right side, but still bellow the line of the page.

This issue is ocurring in every page not only in pages with image.

Share this post


Link to post
Share on other sites
James B    436
James B

Check that compatibility mode is turned off in IE. This has been know to cause the sidebars to display like that.

 

http://help.typekit.com/customer/portal/articles/786466-using-typekit-with-a-self-hosted-wordpress-site


Kindly search the forum and read the documentation before posting. It will help you resolve many issues.

For CSS help be sure to check out W3Schools first and be sure to download FireBug for FireFox for troubleshooting.

James B

Share this post


Link to post
Share on other sites
joaoreis    0
joaoreis

Hi! James,

 

 I deactivated the compatibility mode, didn't solve the problem.

 

 I'm going to put the codes and widgets back and look at the source codes via IE.

 

Thanks!

Share this post


Link to post
Share on other sites
joaoreis    0
joaoreis

Despite this issue i activated the plugins and put all the codes back to the widgets to make a test, but now the main blog page, contact pages and other pages are not updating the sidebar.

Share this post


Link to post
Share on other sites
joaoreis    0
joaoreis

Hello! Guys,

 

 I don't know what to do anymore. As i'm trying to solve the problem i'm causing more errors.

 

 I deactivated all the extra plugins i added and extra codes inside the widgets, my guess is, if it is not any of these codes i used that is causing the problem then it's pagelines or wordpress.

 

 I still need help.

 

thanks!

Share this post


Link to post
Share on other sites
catrina    103
catrina

It's the browser paired with either PL or WP that's the main issue. What if you try using the browser-specific CSS plugin (http://www.pagelines.com/store/plugins/browser-css/) to adjust the sidebar position (to bring it up)?


Please read the docs before posting. Please do not private message me unless I ask you to.

Designer | Catrina Dulay

Founder | Catrina and Mouse

Share this post


Link to post
Share on other sites
joaoreis    0
joaoreis

Hello! Is it possible to somebody of the pagelines staff have a look at my site configurations?

 

 I've already done a lot of test, deactivated all the plugins, took out all the html and extra css from the widgets.

Share this post


Link to post
Share on other sites
Danny    1,327
Danny

Can you open your sites wp-config.php file and find this line please.

 

define('WP_DEBUG', true);

 

Add below it:

 

define( 'PL_NO_DYNAMIC_URL', true );

 

Save the file and then check your website again in IE.

Please search our forums, before posting!

Share this post


Link to post
Share on other sites
joaoreis    0
joaoreis

There isn't this line, define('WP_DEBUG', true);

Share this post


Link to post
Share on other sites
Danny    1,327
Danny

Its probably set to False like this:

 

define( 'PL_NO_DYNAMIC_URL', true );

Please search our forums, before posting!

Share this post


Link to post
Share on other sites
joaoreis    0
joaoreis

This is what i found inside the wp-config.php.

 

I've added the code you said above one of the lines, i don't with it is the right place.

 

http://paste.pagelines.com/9cd

Share this post


Link to post
Share on other sites
Danny    1,327
Danny

This is in a language I can not read, also in future do not post huge lines of code, please use our paste service http://paste.pagelines.com/

 

The WP Define Debug line of code is standard in all Wordpress installation, please add the line of code I gave you previously underneath the debug line of code. If you can not find WP Define Debug then its sounds like there is something wrong with your installation.

 

If that doesn't work, please reply here, as its most likely an issue with your server.

  • Like 1

Please search our forums, before posting!

Share this post


Link to post
Share on other sites
Simon    247
Simon

Your server is adding this to the header of every PHP page: http://screencast.com/t/OMilJoxM2gsi

 

Basically tells internet explorer to only work in ie7 mode.

 

Contact your host and ask why this is.

  • Like 1

Share this post


Link to post
Share on other sites
joaoreis    0
joaoreis

Danny,

 

 Sorry for the huge code.

 

 Now I've added the line you said.

 

 Here are the messages:

 

Notice: Use of undefined constant get_magic_quotes_gpc - assumed 'get_magic_quotes_gpc' in /home/desenv/www/wp-content/plugins/cforms/lib_functions.php on line 360

Notice: Undefined index: sps_action in /home/desenv/www/wp-content/plugins/statpress-seolution/statpress.php on line 16

Notice: register_sidebar_widget is deprecated since version 2.8! Use wp_register_sidebar_widget() instead. in /home/desenv/www/wp-includes/functions.php on line 2824

Notice: register_widget_control is deprecated since version 2.8! Use wp_register_widget_control() instead. in /home/desenv/www/wp-includes/functions.php on line 2824

Notice: register_sidebar_widget is deprecated since version 2.8! Use wp_register_sidebar_widget() instead. in /home/desenv/www/wp-includes/functions.php on line 2824

Notice: register_widget_control is deprecated since version 2.8! Use wp_register_widget_control() instead. in /home/desenv/www/wp-includes/functions.php on line 2824

Notice: load_plugin_textdomain foi chamado com um argumento que está obsoleto desde a versão 2.7 sem nenhuma alternativa disponível. in /home/desenv/www/wp-includes/functions.php on line 2910

Notice: Undefined offset: 1 in /home/desenv/www/wp-content/plugins/statpress-seolution/statpress.php on line 834

Notice: Undefined index: rcommentid in /home/desenv/www/wp-content/plugins/wp-recaptcha/recaptcha.php on line 481

Notice: Undefined index: rchash in /home/desenv/www/wp-content/plugins/wp-recaptcha/recaptcha.php on line 482

Notice: Undefined index: aiosp_front_meta_tags in /home/desenv/www/wp-content/plugins/all-in-one-seo-pack/aioseop.class.php on line 346

Notice: Undefined index: cforms_no_css in /home/desenv/www/wp-content/plugins/cforms/cforms.php on line 1048

Share this post


Link to post
Share on other sites
Simon    247
Simon

You may as well turn off debug. All those notices are from poorly coded plugins. The problem is highlighted in my reply above, please show your host the screenshot and ask why ie7 mode is being forced

  • Like 1

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


  • Similar Content

    • Michael Kummer
      By Michael Kummer+
      Hi guys,
      every since Chrome introduce scroll anchoring (see chrome://flags) blog posts on my page start scroll automatically as soon as the user scrolls down a bit. It is super annoying and I don't know exactly what triggers the incompatibility with Chrome's latest feature that is supposed to improve usability.
      Since I don't know what causes it (Pagelines, or a Plugin), I would like to disable the feature using a CSS override that Google describes as follow:
      "Scroll anchoring aims to be the default mode of behavior when launched, so that users benefit from it even on legacy content. A CSS property overflow-anchor can disable scroll anchoring in part or all of a webpage (opt out), or exclude portions of the DOM from the anchor node selection algorithm. This property supports the following values when applied to an element E:
      overflow-anchor: auto (the default value) declares that the DOM subtree rooted at E is eligible to participate in the anchor node selection algorithm for any scrolling box created by E or an ancestor of E. overflow-anchor: none declares that the DOM subtree rooted at E is not eligible to participate in the anchor node selection algorithm for any scrolling box created by E or an ancestor of E." Do you guys happen to know how to use that property with the ROOT element so it applies to the whole page?
      Thanks
      Michael 
    • TallTree
      By TallTree+
      Hi,
      I am trying to remove the sidebar areas from my child theme (pagelines.com) from the post pages on a site:
      https://staging4.talltreemusicfestival.com/2017/grand-analog/
      The content is all the way to the left and very small, and the two sidebar areas are taking up a lot of space.
      What I'm after is content to the left, taking up most of the space, and then a small sidebar width on the right for widgets.
      I've tried selecting 'read width content' and 'full width content' in the edit screen for the WP content section, but it doesn't change.  If I try to move the sidebars (1 or 2) to the left, it doesn't change.
      If I select the pagelines framework theme (not child), the two sidebars go away when not selecting them in the edit screen..
      Can someone please tell me what I'm doing wrong?
      Thanks in advance.
      -Matt
       
    • wyo22ski
      By wyo22ski+
      Hello,
       
      I'm basically a designer and understand a little on how to change CSS, etc., so please excuse my ignorance...  I recently upgraded to the newest platform from the DMS and my old DMS theme no longer functions.  I'm trying to replace the image slider that my Horizon Photography Theme (Nick Haskins) had created.  The Impulse image slider seemed the closest to what I need, but there are problems.
      It seems the the Impulse section for sliding images defaults to the image width, no the height.  I can change the Impulse stage height and width, but this does nothing to the internal content.  For instance, if I change the height to 200 pixels, the image remains the full width and only shows a cropped section.  I would like the ability to change the Impulse height, and have the image height fit space. 
      I've put this custom CSS in, but again, this only controls the stage height of Impulse:
      .pl-sn-impulse .pl-impulse-cell .cell-wrap, .pl-impulse-container, .owl-stage-outer {
        width: 100%;
      }
       
      Any suggestions welcome.  Thanks 
    • Objectif-Mariage
      By Objectif-Mariage+
      Hello. 
      I have just realized that CSS (Less plugin) , is not working..... I have disable all plugins (except PL CUSTOM LESS and PL5) , and ... it's not working ... 
      It's not the first time. Usually I had trouble with a plugin name Autoptimize , but it's Desactivate now , all memory have been purge, and it's still not working! :-/ So it's not from this plugin. 
      NB : When I am logged on my website, if i go on the black wordpress dashboard bar, go on the PL icon, clic on </> LESS/CSS => then the page suddenly apply the CSS .... But As soon that i reload the page, nothing. I think the problem is that the plugin LESS/CSS does not load properly (if I can say that with my simples words).
      I order to keep the site "good looking" I have temporally copy/paste all my LESS code in a plugin : Script n Styles that apply the LESS/CSS code... but it's not a solution for long time.
      Can someone help me ? Did I do something wrong ? Is it an update ? 
       
      my website : https://www.wedding-photography-minneapolis.com
    • Jason
      By Jason+
      Feel free to delete this post if its not helpful or its just plain wrong.
       
      I though it might be useful to share how I customize the size of the builder. (reduce my eyestrain )
      1 - install stylerbot extension in chrome (stylerbot keeps this css every time you access the url)
       
      2- add this css to stylerbot for the site you are working on
      .CodeMirror {
          font-size: 14px;
          height: 600px;
      }
      .pl-workarea.pl-has-sidebar .pl-workarea-sidebar-container {
          right: 0px;
          width: 500px;
      }
      .pl-workarea.pl-has-sidebar .iframe-container {
          right: 500px ;
      }
       
      change sizes to suit.
       
      Cheers.
×