Jump to content
cf666

How do I add a font that IS NOT a Google web font?

Recommended Posts

cf666    0
cf666

I'd like to add a font that is NOT a Google font and I'm not sure how.

This one, in particular: http://www.dafont.com/underwood1913.font

 

I've read things about Cufont not working well so I don't want to use it unless you can tell me how to use it without it causing problems.

Any pointers??

Thanks and happy new year to all!

 

Carina

Share this post


Link to post
Share on other sites
batman    389
batman

Hi Carina

 

I did this in my local host
- I create a directory named "fonts" by FTP in my htdocs
- I upload the file "Underwood_Etendu_1913.TTF"
- Then I wrote this in my CSS rules
@font-face {
font-family: Underwood;  
src: local('Underwood_Etendu_1913'), 
url("fonts/Underwood_Etendu_1913.TTF") format('truetype');  
font-weight: normal;  
}

.thead, h1, h2, h3, h4, h5, h6, .site-title, body, .font1, .font-primary, .commentlist {font-family:Underwood;}

and .... the magic appear 

 

Captura%2520de%2520pantalla%25202013-01-

;)

 

 

You can read this 

http://codex.wordpress.org/Playing_With_Fonts


Life is too short to remove USB safely ...

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


  • Similar Content

    • Claudio
      By Claudio+
      I have a problem with the typography settings. I set the H1 class with "font-weight: 300;" (Very thin weight), and "font-size: 50px;" (To have considerable evidence of my problem). Unfortunately, as you can see on the screenshots, those setting don't have any incidence on the site, Infact in the home page editor there is a trial title called "Text test", bold, and 26 px approximatly sized.
      Why the typography settings are not transposed on the site? Where I wrong?


    • Michael Kummer
      By Michael Kummer+
      Hi guys!
      I'm using the following typography configuration in Pagelines Settings:
      <link href="https://fonts.googleapis.com/css?family=Open+Sans" rel="stylesheet">
      font-family: 'Open Sans', sans-serif;
      But Lato is still being loaded according to Google Page Speed. Do you know how I can prevent Lato from being loaded if I'm not using it?
      Thanks
      Michael
    • David Shelton
      By David Shelton+
      I use Adobe's Fonts.com for specific branded fonts for our site, and it's working nicely on Chrome and Firefox. However, the fonts all default in Safari. Is there anything I need to look at?
      http://madeintheshadeblindsfranchising.com
    • nandorj78
      By nandorj78+
      How would I change font styles (type, color, face...) for post titles only using PL5?
    • janpeeters
      By janpeeters+
      Hi all,
      I was totally excited to find out about 'CSS Hero' (http://www.csshero.org) I read about it in the compatible plugins section of the PL5 docs (http://www.pagelines.com/resources/compatible-plugins) For me it's a great way to more easily customize my sites because I'm not a CSS pro.
      I'm wondering about one thing though… Does anyone know if using this will result in a heavy penalty on page loading speeds? Would love to start using it but only if it doesn't cost too much in terms of speed.
      Thanks, Jan
×