Jump to content
Sign in to follow this  
techinferno

Rounded Corners

Recommended Posts

techinferno    0
techinferno

Hi,
 
I saw an archived discussion about rounded corners for pagelines framework and the code works partially for me so far. The top of the page has rounded corners but the footer does not, any idea why? Here's the code:
 
 

 

 

#footer .content {
 border-bottom-left-radius: 15px;
 -webkit-border-bottom-left-radius: 15px;
 -moz-border-radius-botomleft:15px;
 border-bottom-right-radius: 15px;
 -webkit-border-bottom-right-radius: 15px;
 -moz-border-radius-botomright:15px;
}
#branding .content {
border-top-left-radius: 15px;
border-top-right-radius: 15px;
}

 

Thanks.

Share this post


Link to post
Share on other sites
Rob    547
Rob

If you read the code, you'd see it refers to the Branding area, which is the top of the page.  So that explains the location.

 

Look at the code in the branding tag and you'll see it refers to top-right and top-left.  No where does it mention bottom-right and bottom-left, so of course, it's not going to apply any rounded corners to the bottom of the section.

 

That said, the application of the top- and bottom- corner curves does not apply to every browser, which is why the footer code includes  webkit and moz

 

There are also errors and typos in the moz tags there.  Please see: http://www.w3schools.com/cssref/css3_pr_border-radius.asp

 

Also see http://css-tricks.com/snippets/css/rounded-corners/


Former PageLines Moderator, Food Expert and Raconteur

Share this post


Link to post
Share on other sites
techinferno    0
techinferno

I fixed the spelling mistakes and checked those links. The branding radius for the bottom was left out on purpose since I only want the top rounded (which it is). However, I cannot get the footer corners to be rounded no matter what. Any hints would be appreciated. I'm still new at CSS so bear with me.

Share this post


Link to post
Share on other sites
Rob    547
Rob

Those links should guide you towards the correct solution.  The same issue applies for the footer as for the branding issue, except that the code for the footer is using only the bottom left and right corners for curves.  It would appear you have errors in your code somewhere, since I find this at the bottom of your page:

/* */ 

There are also HTML coding errors, CSS errors and such in your construction, found here: http://validator.w3.org/check?uri=http%3A%2F%2Fwww.techinferno.com%2F&charset=%28detect+automatically%29&doctype=Inline&group=0

 

As a result, the footer itself isn't actually showing.  Content you may have had in the footer has been moved to the content area, which does not have the curved corners.   I'd strongly recommend hiring one of our Pros to help diagnose these errors in coding.  They may come from bad CSS code or from deprecated plugins, or possibly just from PlatformPro.  I also see the Google +1 icon in the top left outside the content area, where it doesn't belong, so something's definitely amiss.

 

PlatformPro is now a deprecated product itself.  The final update to 1.6.0 was released shortly before Christmas.  Your safest bet to resolve all this would be to upgrade promptly to Framework as PlatformPro will not be upgraded again.  Did you run the 1.6 update?


Former PageLines Moderator, Food Expert and Raconteur

Share this post


Link to post
Share on other sites
techinferno    0
techinferno

It's already on pagelines framework but I think a lot of those errors are caused by plugins including the junk you see in the footer. 

 

Thanks.

Share this post


Link to post
Share on other sites
Rob    547
Rob

I'll then correct your profile, as you are listed under PlatformPro.


Former PageLines Moderator, Food Expert and Raconteur

Share this post


Link to post
Share on other sites
techinferno    0
techinferno

One last unrelated question: I noticed that pagelines isn't showing secondary nav on pages, just posts/tags etc. Any idea why? The template setup has it. 

Share this post


Link to post
Share on other sites
Rob    547
Rob

Do you have a secondary menu set up in Dashboard > Appearance > Menus?

 

On the page where the secondary menu is supposed to appear, do you have that secondary menu selected in the PageLines Meta Settings?


Former PageLines Moderator, Food Expert and Raconteur

Share this post


Link to post
Share on other sites
techinferno    0
techinferno

Thanks, it was a matter of enabling it in the meta settings. Is there a way to make it automatically be enabled for any type of post or page rather than have to fool w/the meta settings each time?

Share this post


Link to post
Share on other sites
Rob    547
Rob

If you go to Dashboard > PageLines > Page Options > Blog Page > Page Setup.  You can select a Secondary menu that's global, for posts and pages there.  If you want one for Categories, you'd go to  > Page Options > Category Page > Page Setup and select the menu you want there, etc. for each of the page options available in that part of the Dashboard.  Just remember, you can override at the local page/post level.


Former PageLines Moderator, Food Expert and Raconteur

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this  

×