Jump to content
shannoga

Can't find variable jQuery after unchecking the 'Supersize The Background Image'

Recommended Posts

shannoga

I have a weird problem with my theme.

 

In many section I am using jQuery and everything worked fine.

I used to use a super-sized background (in  the Color Control section).

 

After deciding to remove the super-sized background I removed the background and unchecked the 'Supersize The Background Image' option.

Right after that I started to get this error - 'Can't find variable jQuery'. When I recheck the Supersize option, everything is working great.

 

How can I fix it.

 

Thanks

Shani

 

Share this post


Link to post
Share on other sites
batman

Hi shannoga

I repeat in my test forum (remove background and unchecked) with PL 2.3.8 and WP 3.5, I had not the error.

Please, first you try to deactivate all plugin.

Perhaps this resolve the issue. 

 

WordPress is frequently updated.  When it is, if plugin developers don't pay attention to the details of those upgrades, their plugins will become deprecated and have either security loopholes or break the sites because of code conflicts.


Life is too short to remove USB safely ...

Share this post


Link to post
Share on other sites
Rob

Batman is correct.  This sounds like a jQuery plugin related issue.  In the recent update of WordPress, they updated jQuery to the latest version.  Even if you did not update yet, their systems may be calling upon their servers for files that have been updated, even from an older version.  As a result things will break.

 

I recommend going through all your plugins to ensure they're compatible with 3.5, particularly those known to use jQuery.  Deactivate and remove any plugins that have not been updated recently, with attention to those which are more than 3 months old. If the plugin page doesn't show at least 3.4.2, the plugin author's not paying attention to it, and it's likely to break now or later.  Replace any that are like that.


Former PageLines Moderator, Food Expert and Raconteur

Share this post


Link to post
Share on other sites
shannoga

Thanks you both I will try that, but how do you explain the fact that it works fine when the supersize is activated ?

Share this post


Link to post
Share on other sites
Simon

how are you loading your jquery scripts?

Share this post


Link to post
Share on other sites
shannoga

Like this:

 

function section_styles(){
			wp_enqueue_script('flexSlider',get_stylesheet_directory_uri() . '/js/jquery.flexslider-min.js',array('jquery'));

			
		}

Share this post


Link to post
Share on other sites
James B

If you do disable the third party plugins, does the supersize bg work correctly without this message appearing?


Kindly search the forum and read the documentation before posting. It will help you resolve many issues.

For CSS help be sure to check out W3Schools first and be sure to download FireBug for FireFox for troubleshooting.

James B

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


  • Similar Content

    • dbrowne02
      By dbrowne02+
      Hi, I noticed that framework and pagelines.com child theme has a number of errors when run through themecheck. The others, like material and bootstrap, don't have any errors when run through theme check. Is there a way to get it so that there are no errors on the child theme?

    • kakadong
      By kakadong+
      All I want to ask is that where can I download the child theme? 
      I have searched all over the site and can't find it anywhere ? 
×